Author Topic: The "Proper Pixel Format"-Problem  (Read 1101 times)

0 Members and 1 Guest are viewing this topic.

The "Proper Pixel Format"-Problem
Alright, so after a long time of absence, I once again installed FS2 Open  using the Installer program. When trying to run the game through the launcher, however, I get the message "Unable to get Proper Pixel Format for OpenGL Win32".
So I took a look at the forums, not wanting to use D3D8, and found some. However, they mostly conclude that it must be a problem with the GPU (Graphics Chip) or Windows Vista. This however can't possibly the case.

My System:
Windows XP SP2  [[So it is no Vista Problem]]
ATI Mobility Radeon 9700 on the current Omega Drivers [[Supports OpenGL in other games]]
Intel Pentium 4 HT 3,0 GHz
1256 MB RAM (Yeah, I know, strange number. Long story.)

And yes, it is a Notebook.

In any case, my main problem is this: it worked before. I admit that I updated the GPU drivers a couple of times since the last time, but the problem is definitely not related to my GPU. Also, since other games work, I can only conclude that it must be a problem within FS2. The same problem is encountered with WC: Saga, obviously, which ALSO worked before.

I hope to shed some light on the problem and possibly have motivated someone to take a qualified look at it. Any help would be appreciated!

 
Re: The "Proper Pixel Format"-Problem
Are you forcing any settings through Tray Tools in your drivers?

Are you able to try the latest Ati Mobility drivers from the official website?

Do you get this problem regardless of build?

 

Offline Wanderer

  • Wiki Warrior
  • 211
  • Mostly harmless
Re: The "Proper Pixel Format"-Problem
Check the pixel depth of the game and the desktop. Both should (most likely) be set to 32 bits.
Do not meddle in the affairs of coders for they are soggy and hard to light

 

Offline Zacam

  • Magnificent Bastard
  • Administrator
  • 211
  • I go Sledge-O-Matic on Spammers
    • Minecraft
    • Steam
    • Twitter
    • ModDB Feature
Re: The "Proper Pixel Format"-Problem
I _occasionally_ run into this problem as well.

However, I run with a LOT of semi-transparent windows, (Winamp, Trillian and I even have semi-transparent windows and applications... it made Axem twitch, I think) and I don't tend to close/restart applications until several day's have passed. (IE: not restarting Firefox for 3 weeks, leaving Winamp paused for 2 and Trillian running since it's last update.)

Usually, shutting a few things down, bringing up my video drivers Control Panel and opening then immediately closing the launcher (and making sure no duplicates appear in Task Manager) and THEN launching FSO... cures it.
Report MediaVP issues, now on the MediaVP Mantis! Read all about it Here!
Talk with the FSU on #SCP-FSU Talk with the SCP on #SCP
"If you can keep a level head in all this confusion, you just don't understand the situation"

¤[D+¬>

[08/01 16:53:11] <sigtau> EveningTea: I have decided that I am a 32-bit registerkin.  Pronouns are eax, ebx, ecx, edx.
[08/01 16:53:31] <EveningTea> dhauidahh
[08/01 16:53:32] <EveningTea> sak
[08/01 16:53:40] * EveningTea froths at the mouth
[08/01 16:53:40] <sigtau> i broke him, boys