Author Topic: crash on start (help thread doesn't help)  (Read 1236 times)

0 Members and 1 Guest are viewing this topic.

crash on start (help thread doesn't help)
Hey guys, a week ago fs2_open_3_6_9 was working just fine. When I tryed to start it today I got an error that said "Unable to get proper pixel format for OpenGL W32!". I then have to end the program from the task manager. I read the thread in here but none of the three things it lists fix the problem. I have the graphics set to OpenGL, I reinstalled the openAL files and the sound is set to generic software. I have a Geforce 7600 GT if that makes any difference. Can anyone help me get FS2 to run again? I need my fix. Thanks

Edit: comp specs: core 2 duo E6550 @ 2.33Ghz
                             2 gig ram
                             GeForce 7600 GT
                             windows xp
« Last Edit: March 17, 2008, 07:52:31 pm by theWakeful »

 

Offline FUBAR-BDHR

  • Self-Propelled Trouble Magnet
  • 212
  • Master Drunk
    • 165th Beer Drinking Hell Raisers
Re: crash on start (help thread doesn't help)
Make sure your color are set to 32bit in your display settings.  Also check in under the video tab in the launcher.
No-one ever listens to Zathras. Quite mad, they say. It is good that Zathras does not mind. He's even grown to like it. Oh yes. -Zathras

 
Re: crash on start (help thread doesn't help)
You mean 32 bit color in the windows settings? I have the launcher set to 32 bit, but I don't know what the windows settings are at.

Edit: windows is set to 32 bit color as well. any other ideas?

 

Offline FUBAR-BDHR

  • Self-Propelled Trouble Magnet
  • 212
  • Master Drunk
    • 165th Beer Drinking Hell Raisers
Re: crash on start (help thread doesn't help)
Did you install any new drivers or hardware recently?  Are you running in Opengl mode?  If not try it.  Make sure Opengl is set in the launcher.  If you have a bunch of programs running in background close a few.
« Last Edit: March 18, 2008, 01:16:45 am by FUBAR-BDHR »
No-one ever listens to Zathras. Quite mad, they say. It is good that Zathras does not mind. He's even grown to like it. Oh yes. -Zathras

 
Re: crash on start (help thread doesn't help)
Like I said, OpenGL is selected in the launcher. I changed nothing on my computer between the time that the game worked and when it didn't.

 

Offline Zacam

  • Magnificent Bastard
  • Administrator
  • 211
  • I go Sledge-O-Matic on Spammers
    • Minecraft
    • Steam
    • Twitter
    • ModDB Feature
Re: crash on start (help thread doesn't help)
I randomly get this issue as well. Make sure Launcher AND any possible copies of the SCP exe are in fact terminated.

Sometimes, I have to set it fail and WITHOUT hitting "Ok" on the error, I run a debug version directly.

I then switch back to windows and End Task on both exe's and the launcher.

I've also had issues with having alot of applications open at the time of running the exe and having the error. Especially if the app's are doing a lot of rendering. (Semi transparent Trillian, Winamp running Milkdrop, Photoshop CS3 Extended and at least one copy of PCS 2.0.1 will almost always reproduce the error for me.)

FYI to everyone else: It has _nothing_ to do with windows desktop color space. Re-read the error. The W32 is a generic reference to Win32 API.
Report MediaVP issues, now on the MediaVP Mantis! Read all about it Here!
Talk with the FSU on #SCP-FSU Talk with the SCP on #SCP
"If you can keep a level head in all this confusion, you just don't understand the situation"

¤[D+¬>

[08/01 16:53:11] <sigtau> EveningTea: I have decided that I am a 32-bit registerkin.  Pronouns are eax, ebx, ecx, edx.
[08/01 16:53:31] <EveningTea> dhauidahh
[08/01 16:53:32] <EveningTea> sak
[08/01 16:53:40] * EveningTea froths at the mouth
[08/01 16:53:40] <sigtau> i broke him, boys