Author Topic: In mission cutscenes not working right with new SVN SSE2 build I made last night  (Read 3762 times)

0 Members and 1 Guest are viewing this topic.

Offline CaptJosh

  • 210
In mission cutscenes not working right with new SVN SSE2 build I made last night
I'm not sure what's going on exactly, but I'm running a build from the SVN repository I updated from last night and in mission cutscenes aren't correctly returning to my fighter. After they cut out, I can move around, I can shoot, I can allocate power, but I don't seem to be able to target anything and none of my HUD is showing up at all. I'll test with other builds to see if it's specific to the SSE2 build, of course, but I just thought I'd let folks know about this to see if there's anything they might suggest right off.

EDIT: Saw something in another topic that I had missed earlier. I'll try again with my recent builds and see if Shift+O gives me my HUD back when this oddity happens.

EDIT 2: Once I set Shift+O to toggle my HUD and tested again, it worked, but I don't encounter this issue with taylors 0314 xt build or an older intermediate build I have around from before the project file was updated to label the EXEs it compiled as being *3_6_10*.exe. Some testing should be done to find out when this behavior started and why.
« Last Edit: November 08, 2008, 04:29:17 pm by CaptJosh »
CaptJosh

There are only 10 kinds of people in the world;
those who understand binary and those who don't.

 

Offline Goober5000

  • HLP Loremaster
  • 214
    • Goober5000 Productions
Re: In mission cutscenes not working right with new SVN SSE2 build I made last night
Mantis plz.

 

Offline CaptJosh

  • 210
Re: In mission cutscenes not working right with new SVN SSE2 build I made last night
Ok, soon as I remember my Mantis login. Don't worry, I don't need a password reset. Just have to remember. I'll also try making a new build just to make sure it hasn't already somehow been fixed.
CaptJosh

There are only 10 kinds of people in the world;
those who understand binary and those who don't.

 

Offline CaptJosh

  • 210
Re: In mission cutscenes not working right with new SVN SSE2 build I made last night
More info that is going into a mantis bug which I will edit into this post as soon as I get it filed (Bug filed. URL at bottom of post.). If you play through a mission with one of those in mission cutscenes twice with the same pilot, the second time it cuts back to the cockpit correctly. Very odd. This is, by the way, with a subversion build from today, the 19th, SSE2 enabled. Testing with the standard SSE build doesn't evidence the issue at all. It switches back just fine. Nor does the bug evidence itself in the standard build under windows. Tried to test with the debug build errors just getting it to get to the pilot selection screen are as follows:

Code: [Select]
Warning: For 'explo3', 3 of 4 LODs are missing!
File: weapons.cpp
Line: 1267


Call stack:
------------------------------------------------------------------
    fs2_open_3_6_10d-11192008.exe 0091b2cb()
    fs2_open_3_6_10d-11192008.exe 0091d82c()
    fs2_open_3_6_10d-11192008.exe 0091fc9f()
    fs2_open_3_6_10d-11192008.exe 0073137c()
    fs2_open_3_6_10d-11192008.exe 0073dd99()
    fs2_open_3_6_10d-11192008.exe 0073e10e()
    fs2_open_3_6_10d-11192008.exe 00c90f66()
    fs2_open_3_6_10d-11192008.exe 00c90def()
    kernel32.dll 7c817067()
------------------------------------------------------------------

Warning: Weapon explosion 'SubbeamWarm' does not have an LOD0 anim!
File: weapons.cpp
Line: 1241


Call stack:
------------------------------------------------------------------
    fs2_open_3_6_10d-11192008.exe 0091b2cb()
    fs2_open_3_6_10d-11192008.exe 0091d82c()
    fs2_open_3_6_10d-11192008.exe 0091fc9f()
    fs2_open_3_6_10d-11192008.exe 0073137c()
    fs2_open_3_6_10d-11192008.exe 0073dd99()
    fs2_open_3_6_10d-11192008.exe 0073e10e()
    fs2_open_3_6_10d-11192008.exe 00c90f66()
    fs2_open_3_6_10d-11192008.exe 00c90def()
    kernel32.dll 7c817067()
------------------------------------------------------------------

Warning: For 'bomb_flare', 3 of 4 LODs are missing!
File: weapons.cpp
Line: 1267


Call stack:
------------------------------------------------------------------
    fs2_open_3_6_10d-11192008.exe 0091b2cb()
    fs2_open_3_6_10d-11192008.exe 0091d87a()
    fs2_open_3_6_10d-11192008.exe 0091fc9f()
    fs2_open_3_6_10d-11192008.exe 0073137c()
    fs2_open_3_6_10d-11192008.exe 0073dd99()
    fs2_open_3_6_10d-11192008.exe 0073e10e()
    fs2_open_3_6_10d-11192008.exe 00c90f66()
    fs2_open_3_6_10d-11192008.exe 00c90def()
    kernel32.dll 7c817067()
------------------------------------------------------------------

Then it starts griping about being unable to load several starfield bitmaps when I try to got to mission briefing.

Again, as I said, this post will be edited in order to add the mantis bug number as soon as I post the bug.

Mantis URL for issue:
http://scp.indiegames.us/mantis/view.php?id=1830
« Last Edit: November 20, 2008, 09:04:34 pm by CaptJosh »
CaptJosh

There are only 10 kinds of people in the world;
those who understand binary and those who don't.

 

Offline phreak

  • Gun Phreak
  • 211
  • -1
Re: In mission cutscenes not working right with new SVN SSE2 build I made last night
Any particular mission to test with?
Offically approved by Ebola Virus Man :wtf:
phreakscp - gtalk
phreak317#7583 - discord

 

Offline CaptJosh

  • 210
Re: In mission cutscenes not working right with new SVN SSE2 build I made last night
Any mission that goes from cutscene to flying, can start with flying, cut, and go back to flying, or start with cutscene and go to flying. The second mission you actually fly is good, the red alert one that drops you near earth, 10 klicks from Waypoint one. It cuts to the transport docking with the escape pod, then back to flying to let you jump out, and it's very early in. One other detail I may have forgotten, if you have already flown it once in campaign, had the error, then fly it again, the error doesn't occur.
CaptJosh

There are only 10 kinds of people in the world;
those who understand binary and those who don't.

 

Offline phreak

  • Gun Phreak
  • 211
  • -1
Re: In mission cutscenes not working right with new SVN SSE2 build I made last night
what if you fly in the mission simulator?
Offically approved by Ebola Virus Man :wtf:
phreakscp - gtalk
phreak317#7583 - discord

 

Offline CaptJosh

  • 210
Re: In mission cutscenes not working right with new SVN SSE2 build I made last night
Well, in the simulator, you can only fly what you've already flown unless something gets altered, IIRC...
CaptJosh

There are only 10 kinds of people in the world;
those who understand binary and those who don't.

 

Offline karajorma

  • King Louie - Jungle VIP
  • Administrator
  • 214
    • Karajorma's Freespace FAQ
Re: In mission cutscenes not working right with new SVN SSE2 build I made last night
Press CTRL +SHIFT + S in the simulator and then you can fly everything.
Karajorma's Freespace FAQ. It's almost like asking me yourself.

[ Diaspora ] - [ Seeds Of Rebellion ] - [ Mind Games ]

 

Offline CaptJosh

  • 210
Re: In mission cutscenes not working right with new SVN SSE2 build I made last night
That was what I was trying to remember. Thank you.
CaptJosh

There are only 10 kinds of people in the world;
those who understand binary and those who don't.

 

Offline phreak

  • Gun Phreak
  • 211
  • -1
Re: In mission cutscenes not working right with new SVN SSE2 build I made last night
I'm not getting it to occur using the mission simulator on mission2 (...With Vast Seas)
Offically approved by Ebola Virus Man :wtf:
phreakscp - gtalk
phreak317#7583 - discord

 

Offline Aardwolf

  • 211
  • Posts: 16,384
    • Minecraft
Re: In mission cutscenes not working right with new SVN SSE2 build I made last n
Since when did that have cutscenes?

 

Offline Darius

  • Moderator
  • 211
Re: In mission cutscenes not working right with new SVN SSE2 build I made last n
The second mission you actually fly is good, the red alert one that drops you near earth, 10 klicks from Waypoint one. It cuts to the transport docking with the escape pod, then back to flying to let you jump out, and it's very early in.

 

Offline CaptJosh

  • 210
Re: In mission cutscenes not working right with new SVN SSE2 build I made last night
phreak, are you testing with an SSE2 build? This bug is ONLY appearing on the SSE2 enabled builds, based on my own testing.
CaptJosh

There are only 10 kinds of people in the world;
those who understand binary and those who don't.

 

Offline phreak

  • Gun Phreak
  • 211
  • -1
Re: In mission cutscenes not working right with new SVN SSE2 build I made last night
yes, i built it myself.  again, i was only testing from the mission simulator.  does it occur in the mission simulator for you?
Offically approved by Ebola Virus Man :wtf:
phreakscp - gtalk
phreak317#7583 - discord

 

Offline CaptJosh

  • 210
Re: In mission cutscenes not working right with new SVN SSE2 build I made last night
Other thing. Is it a pilot that already flew the mission. It appears to only have this issue the first time through on any given mission with an on engine cutscene. Subsequent replays do not appear to evidence the behavior.
CaptJosh

There are only 10 kinds of people in the world;
those who understand binary and those who don't.