Author Topic: Manual Install Isn't Working  (Read 3550 times)

0 Members and 1 Guest are viewing this topic.

Manual Install Isn't Working
I had to do the manual install of FSPort, STR, and the upgraded FS2 stuff (the installer program wouldn't run on my computer).  The MediaVP's for FS2 seem to work (so far), but if I select FSPort in the mod list I get the error "Invalid MOD ini multiple mod parameter, only -mod calls are allowed."

My mod.ini in the fsport folder reads:
Quote
[launcher]
modname      = FSPort v3.1;
image255x112 = fsport.bmp;
infotext     = A fourteen-year war between the Terran and Vasudan species leads into something far more sinister.  This is the story of the Great War.;
website      = http://fsport.hard-light.net/;
forum        = http://www.hard-light.net/forums/index.php/board,39.0.html;

[multimod]
primarylist  = fsport-mediavps;
secondarylist = mediavps;

The directions in the main installation thread don't match up with what the file says.

What do I do to get things running?

Edit: While proofreading my post, I thought the "fsport-mediavps" looked odd, so I went through all the other mod.ini's and decided to change the last two lines to:
Quote
primarylist  = fsport_mediavps;
secondarylist = fsport,mediavps;
It doesn't immediately give me an error, but I really don't know what I'm doing.  Can anyone confirm or deny that I'm going in the right direction?

Edit 2: Whoah, never mind about things working better.  I only ever get a black screen now (though sound works), no matter what mod I select, even if I run without a mod.  The game did work with the FS2 upgrade but no FS1 stuff.

I notice that when I select a mod, the list it gives me has things it shouldn't, like my backup STR files in another part of the hard drive.  Could this be affecting things?  If so, is there any way to isolate my unused FS-related files?

I think I'll stop touching things and just wait for you guys now.  :o
« Last Edit: May 12, 2009, 09:23:01 pm by DreadArchon »

 

Offline Herra Tohtori

  • The Academic
  • 211
  • Bad command or file name
Re: Manual Install Isn't Working
Yep, mod.ini files can't deal with hyphens.

This would work:

Code: [Select]
primarylist  = fsport_mediavps;
secondarylist = mediavps;

This would not work:

Code: [Select]
primarylist  = fsport-mediavps;
secondarylist = fsport,mediavps;

Of course, you need to also change the fsport-mediavps directory to fsport_mediavps, otherwise it won't find the directory (and won't say anything about it either).

Adding fsport to the secondarylist is unnecessary and redundant, but the reason for the problem is the hyphen in the fsport-mediavps. mod.ini file parser interprets it as start of another command line argument and throws a fit because it's supposed to only have -mod command line arguments.

Confusingly, it works just fine when you manually add the -mod command line to the Custom flags field in the Features tab, as in:

-mod fsport-mediavps,fsport,mediavps works just as fine as -mod fsport_mediavps,fsport,mediavps. With corresponding directory names, of course.
There are three things that last forever: Abort, Retry, Fail - and the greatest of these is Fail.

 
Re: Manual Install Isn't Working
Thank you, that helps.

I still have the black screen problem; I played around with it a little and decided that the upgrade has never worked, I was just opening the normal program from the GOG install.

Should the last lines of the main mediavps mod.ini be
Quote
[multimod]
primarylist  = ;
secondarylist = ;
...or am I doing something else wrong?

 

Offline Herra Tohtori

  • The Academic
  • 211
  • Bad command or file name
Re: Manual Install Isn't Working
Yes. When you activate the mediaVP's, it is not supposed to enable other mods as such; therefore the multimod section of the mod.ini file is purposely as it is.

For further troubleshooting... run a debug build (3.6.10 RC2 builds are the latest recommended ones to use) and post the log from ..\FreeSpace2\data\fs2_open.log, either in code tags, pastebin link or attachement.

That will tell what exactly is going on. My guess is either you haven't been using the mediaVP's at all (which would point to misconfiguration somewhere), or you have a corrupt version of the mediaVP's, which would happen if you used Turey's online installer to acquire them (although I haven't heard of them making the splash screen not appear).
There are three things that last forever: Abort, Retry, Fail - and the greatest of these is Fail.

 
Re: Manual Install Isn't Working
I got a bunch of error messages when I tried to run the debugger.  I wanted to paste some, but they just kept coming, and after I missed the first couple I just gave up.

Here's what I got from that file:
Code: [Select]
==========================================================================
DEBUG SPEW: No debug_filter.cfg found, so only general, error, and warning
categories can be shown and no debug_filter.cfg info will be saved.
==========================================================================
FreeSpace version: 3.6.10
Passed cmdline options:
  -env
  -mipmap
  -missile_lighting
  -glow
  -spec
  -normal
  -ballistic_gauge
  -dualscanlines
  -orbradar
  -rearm_timer
  -targetinfo
  -3dwarp
  -ship_choice_3d
  -weapon_choice_3d
  -warp_flash
  -mod mediavps
Building file index...
Found root pack 'C:\Program Files (x86)\GOG.com\Freespace 2\mediavps\FS2OGGcutscenepack.vp' with a checksum of 0x84396e99
Found root pack 'C:\Program Files (x86)\GOG.com\Freespace 2\mediavps\MV_AbolishAnimGlows.vp' with a checksum of 0x86397f07
Found root pack 'C:\Program Files (x86)\GOG.com\Freespace 2\mediavps\MV_Complete.vp' with a checksum of 0x31df7754
Found root pack 'C:\Program Files (x86)\GOG.com\Freespace 2\mediavps\mv_music.vp' with a checksum of 0xbbd92e16
Found root pack 'C:\Program Files (x86)\GOG.com\Freespace 2\Root_fs2.vp' with a checksum of 0xce10d76c
Found root pack 'C:\Program Files (x86)\GOG.com\Freespace 2\smarty_fs2.vp' with a checksum of 0xddeb3b1e
Found root pack 'C:\Program Files (x86)\GOG.com\Freespace 2\sparky_fs2.vp' with a checksum of 0x164fe65a
Found root pack 'C:\Program Files (x86)\GOG.com\Freespace 2\sparky_hi_fs2.vp' with a checksum of 0xa11d56f1
Found root pack 'C:\Program Files (x86)\GOG.com\Freespace 2\stu_fs2.vp' with a checksum of 0xd77da83a
Found root pack 'C:\Program Files (x86)\GOG.com\Freespace 2\tango1_fs2.vp' with a checksum of 0x4c25221e
Found root pack 'C:\Program Files (x86)\GOG.com\Freespace 2\tango2_fs2.vp' with a checksum of 0x86920b82
Found root pack 'C:\Program Files (x86)\GOG.com\Freespace 2\tango3_fs2.vp' with a checksum of 0x705e8d71
Found root pack 'C:\Program Files (x86)\GOG.com\Freespace 2\warble_fs2.vp' with a checksum of 0xd85c305d
Searching root 'C:\Program Files (x86)\GOG.com\Freespace 2\mediavps\' ... 1 files
Searching root pack 'C:\Program Files (x86)\GOG.com\Freespace 2\mediavps\FS2OGGcutscenepack.vp' ... 10 files
Searching root pack 'C:\Program Files (x86)\GOG.com\Freespace 2\mediavps\MV_AbolishAnimGlows.vp' ... 70 files
Searching root pack 'C:\Program Files (x86)\GOG.com\Freespace 2\mediavps\MV_Complete.vp' ... 5253 files
Searching root pack 'C:\Program Files (x86)\GOG.com\Freespace 2\mediavps\mv_music.vp' ... 32 files
Searching root 'C:\Program Files (x86)\GOG.com\Freespace 2\' ... 8 files
Searching root pack 'C:\Program Files (x86)\GOG.com\Freespace 2\Root_fs2.vp' ... 157 files
Searching root pack 'C:\Program Files (x86)\GOG.com\Freespace 2\smarty_fs2.vp' ... 10 files
Searching root pack 'C:\Program Files (x86)\GOG.com\Freespace 2\sparky_fs2.vp' ... 3027 files
Searching root pack 'C:\Program Files (x86)\GOG.com\Freespace 2\sparky_hi_fs2.vp' ... 1337 files
Searching root pack 'C:\Program Files (x86)\GOG.com\Freespace 2\stu_fs2.vp' ... 2355 files
Searching root pack 'C:\Program Files (x86)\GOG.com\Freespace 2\tango1_fs2.vp' ... 32 files
Searching root pack 'C:\Program Files (x86)\GOG.com\Freespace 2\tango2_fs2.vp' ... 15 files
Searching root pack 'C:\Program Files (x86)\GOG.com\Freespace 2\tango3_fs2.vp' ... 10 files
Searching root pack 'C:\Program Files (x86)\GOG.com\Freespace 2\warble_fs2.vp' ... 52 files
Found 15 roots and 12369 files.
Setting language to English
TBM  =>  Starting parse of 'mv_strings-lcl.tbm' ...
Initializing OpenAL...
  Using 'Generic Software' as OpenAL sound device...
  OpenAL Vendor     : Creative Labs Inc.
  OpenAL Renderer   : Software
  OpenAL Version    : 1.1

... OpenAL successfully initialized!
Initializing OpenGL graphics device at 1280x800 with 32-bit color...
  Initializing WGL...
  Requested WGL Video values = R: 8, G: 8, B: 8, depth: 32, double-buffer: 1
  Actual WGL Video values    = R: 8, G: 8, B: 8, depth: 32, double-buffer: 1
  OpenGL Vendor     : Intel
  OpenGL Renderer   : Intel Cantiga
  OpenGL Version    : 1.5.0 - Build 7.15.10.1527

WARNING: "Unable to go fullscreen!" at gropengl.cpp:1293
  Using extension "GL_EXT_fog_coord".
  Using extension "GL_ARB_multitexture".
  Using extension "GL_ARB_texture_env_add".
  Using extension "GL_ARB_texture_compression".
  Using extension "GL_EXT_texture_compression_s3tc".
  Using extension "GL_EXT_texture_filter_anisotropic".
  Using extension "GL_ARB_texture_env_combine".
  Using extension "GL_EXT_compiled_vertex_array".
  Using extension "GL_EXT_draw_range_elements".
  Unable to find extension "GL_ARB_texture_mirrored_repeat".
  Unable to find extension "GL_ARB_texture_non_power_of_two".
  Using extension "GL_ARB_vertex_buffer_object".
  Unable to find extension "GL_EXT_pixel_buffer_object".
  Using extension "GL_SGIS_generate_mipmap".
  Unable to find extension "GL_EXT_framebuffer_object".
  Using extension "GL_ARB_texture_rectangle".
  Using extension "GL_EXT_bgra".
  Using extension "GL_ARB_texture_cube_map".
  Using extension "GL_EXT_texture_lod_bias".
  Unable to find extension "NV_point_sprite".
  Unable to find extension "GL_ARB_shading_language_100".
  Unable to find extension "GL_ARB_shader_objects".
  Unable to find extension "GL_ARB_vertex_shader".
  Unable to find extension "GL_ARB_fragment_shader".
  Unable to find extension "GL_ATI_shader_texture_lod".
  Found special extension function "wglSwapIntervalEXT".

  Max texture units: 8 (8)
  Max elements vertices: 1024
  Max elements indices: 1024
  Max texture size: 2048x2048
  Can use compressed textures: YES
  Texture compression available: YES
  Using trilinear texture filter.
... OpenGL init is complete!
Size of bitmap info = 705 KB
Size of bitmap extra info = 40 bytes
ANI cursorweb with size 24x24 (25.0% wasted)
GRAPHICS: Initializing default colors...
SCRIPTING: Beginning initialization sequence...
SCRIPTING: Beginning Lua initialization...
LUA: Opening LUA state...
LUA: Initializing base Lua libraries...
LUA: Beginning ADE initialization
ADE: Initializing enumeration constants...
ADE: Assigning Lua session...
SCRIPTING: Beginning main hook parse sequence....
Wokka!  Error opening file (scripting.tbl)!
TABLES: Unable to parse 'scripting.tbl'!  Error code = 5.
SCRIPTING: Inititialization complete.
SCRIPTING: Splash screen overrides checked
SCRIPTING: Splash hook has been run
SCRIPTING: Splash screen conditional hook has been run
Using high memory settings...
Wokka!  Error opening file (interface.tbl)!
WMCGUI: Unable to parse 'interface.tbl'!  Error code = 5.
TBM  =>  Starting parse of 'mv_effects-sdf.tbm' ...
TBM  =>  Starting parse of 'mv_adveffects-sdf.tbm' ...
ANI 2_radar1 with size 209x170 (33.6% wasted)
Windoze reported 16 joysticks, we found 0
Current soundtrack set to -1 in event_music_reset_choices
TBM  =>  Starting parse of 'mv_music-mus.tbm' ...
TBM  =>  Starting parse of 'mv_advmuzzle-mfl.tbm' ...
Wokka!  Error opening file (armor.tbl)!
TABLES: Unable to parse 'armor.tbl'!  Error code = 5.
TBM  =>  Starting parse of 'mv_effects-wxp.tbm' ...
TBM  =>  Starting parse of 'mv_adveffects-wxp.tbm' ...
BMPMAN: Found EFF (exp20.eff) with 64 frames at 35 fps.
BMPMAN: Found EFF (ExpMissileHit1.eff) with 44 frames at 30 fps.
BMPMAN: Found EFF (exp05.eff) with 47 frames at 20 fps.
BMPMAN: Found EFF (exp06.eff) with 48 frames at 20 fps.
BMPMAN: Found EFF (exp04.eff) with 60 frames at 20 fps.
BMPMAN: Found EFF (Maxim_Impact.eff) with 23 frames at 30 fps.
ANI Lamprey_Impact with size 80x80 (37.5% wasted)
BMPMAN: Found EFF (Gmuzzle.eff) with 5 frames at 30 fps.
BMPMAN: Found EFF (PWmuzzle.eff) with 4 frames at 30 fps.
BMPMAN: Found EFF (Rmuzzle.eff) with 4 frames at 30 fps.
BMPMAN: Found EFF (Bmuzzle.eff) with 5 frames at 30 fps.
TBM  =>  Starting parse of 'mv_tech-wep.tbm' ...
TBM  =>  Starting parse of 'mv_models-wep.tbm' ...
TBM  =>  Starting parse of 'mv_effects-wep.tbm' ...
TBM  =>  Starting parse of 'mv_adveffects-wep.tbm' ...
TBM  =>  Starting parse of 'mv_trails-shp.tbm' ...
TBM  =>  Starting parse of 'mv_tech-shp.tbm' ...
TBM  =>  Starting parse of 'mv_models-shp.tbm' ...
TBM  =>  Starting parse of 'mv_dragon-shp.tbm' ...
TBM  =>  Starting parse of 'mv_adveffects-shp.tbm' ...
TBM  =>  Starting parse of 'mv_escort-hdg.tbm' ...
TBM  =>  Starting parse of 'mv_effects-str.tbm' ...
loading animated cursor "cursor"
ANI cursor with size 24x24 (25.0% wasted)
Ships.tbl is : VALID
Weapons.tbl is : VALID
cfile_init() took 768
!!DEBUG!! OpenGL Errors this frame: 1
Got event GS_EVENT_GAME_INIT (49) in state NOT A VALID STATE (0)
ANI cursor.ani with size 24x24 (25.0% wasted)
Frame  0 too long!!: frametime = 0.408 (0.408)
WARNING: "Unable to go fullscreen!" at gropengl.cpp:1293
Freeing all existing models...
ERROR: Verify failure: Vbuf0 != NULL

File: 3ddraw.cpp
Line: 451
    g3_draw_poly_constant_sw()    g3_draw_2d_poly_bitmap()    gr_bitmap()    gr_opengl_flip()    gr_flip()    gr_opengl_cleanup()    gr_close()    doexit()    exit()    Warning()    opengl_go_fullscreen()    gr_opengl_activate()    gr_activate()    change_window_active_state()    win32_message_handler()

 

Offline Jeff Vader

  • The Back of the Hero!
  • 212
  • Bwahaha
Re: Manual Install Isn't Working
Code: [Select]
  OpenGL Vendor     : Intel
  OpenGL Renderer   : Intel Cantiga
  OpenGL Version    : 1.5.0 - Build 7.15.10.1527
There's your problem. Intel graphics solutions suck at best.
23:40 < achillion > EveningTea: ass
23:40 < achillion > wait no
23:40 < achillion > evilbagel: ass
23:40 < EveningTea > ?
23:40 < achillion > 2-letter tab complete failure

14:08 < achillion > there's too much talk of butts and dongs in here
14:08 < achillion > the level of discourse has really plummeted
14:08 < achillion > Let's talk about politics instead
14:08 <@The_E > butts and dongs are part of #hard-light's brand now
14:08 <@The_E > well
14:08 <@The_E > EvilBagel's brand, at least

01:06 < T-Rog > welp
01:07 < T-Rog > I've got to take some very strong antibiotics
01:07 < achillion > penis infection?
01:08 < T-Rog > Chlamydia
01:08 < achillion > O.o
01:09 < achillion > well
01:09 < achillion > I guess that happens
01:09 < T-Rog > at least it's curable
01:09 < achillion > yeah
01:10 < T-Rog > I take it you weren't actually expecting it to be a penis infection
01:10 < achillion > I was not

14:04 < achillion > Sometimes the way to simplify is to just have a habit and not think about it too much
14:05 < achillion > until stuff explodes
14:05 < achillion > then you start thinking about it

22:16 < T-Rog > I don't know how my gf would feel about Jewish conspiracy porn

15:41 <-INFO > EveningTea [[email protected]] has joined #hard-light
15:47 < EvilBagel> butt
15:51 < Achillion> yes
15:53 <-INFO > EveningTea [[email protected]] has quit [Quit: http://www.mibbit.com ajax IRC Client]

18:53 < Achillion> Dicks are fun

21:41 < MatthTheGeek> you can't spell assassin without two asses

20:05 < sigtau> i'm mining titcoins from now on

00:31 < oldlaptop> Drunken antisocial educated freezing hicks with good Internet == Finland stereotype

11:46 <-INFO > Kobrar [[email protected]] has joined #hard-light
11:50 < achtung> Surely you've heard of DVDA
11:50 < achtung> Double Vaginal Double ANal
11:51 < Kobrar> ...
11:51 <-INFO > Kobrar [[email protected]] has left #hard-light []

 
Re: Manual Install Isn't Working
There's your problem. Intel graphics solutions suck at best.
Well, yes, there's only so much I can do without a (real) video card, this wasn't really meant to be a gaming computer.  Some things do work, though, so I thought this would would be worth a shot.

Am I limited to Freespace 2 and original graphics, then, or is there a simple fix?

 

Offline General Battuta

  • Poe's Law In Action
  • 214
  • i wonder when my postcount will exceed my iq
Re: Manual Install Isn't Working
Try pulling mv_advanced out of the MediaVPs.

 
Re: Manual Install Isn't Working
Try pulling mv_advanced out of the MediaVPs.
Thanks, I'll try that as soon as I can--I need a day or so to download the individual VP's instead of just MV_complete.

Until then: Should I need to do something similar for fsport, fsport_mediavps, and fsport_str, or are they all going off the main MediaVPs?

 

Offline General Battuta

  • Poe's Law In Action
  • 214
  • i wonder when my postcount will exceed my iq
Re: Manual Install Isn't Working
Well, STR is just a campaign, and I believe that fsport_mediavps doesn't contain anything as punishing as in mv_adveffects, so you oughta be okay.

 
Re: Manual Install Isn't Working
Removing bits of the mediavp's did not help.  I still get a black screen for the opening and the login screen.  (I can tell it's the login screen because random mouse movements give me the buttons' "beep" noise.)

Thank you all for the help, but it appears that my computer is not powerful enough to handle FS1 (ironically).

I'm still glad that I bought the original FS2.  Even with no modding possible, it's shaping up to be a fun game.

 

Offline General Battuta

  • Poe's Law In Action
  • 214
  • i wonder when my postcount will exceed my iq
Re: Manual Install Isn't Working
Whoa whoa. I doubt this problem is caused by your computer specs; you should be able to at least get into the main  hall with the MVPs active.

Did you get the individual MVPs from the Installer, or from a release thread here on HLP?
« Last Edit: May 14, 2009, 09:33:20 am by General Battuta »

 

Offline Herra Tohtori

  • The Academic
  • 211
  • Bad command or file name
Re: Manual Install Isn't Working
Well, since the debug log complains about not being able to go fullscreen, why don't you try and use the -window command line flag? It can be found in Dev Tool group of features.

What happens if you just run with no mods at all, but using FS2_Open?
There are three things that last forever: Abort, Retry, Fail - and the greatest of these is Fail.

 

Offline Jeff Vader

  • The Back of the Hero!
  • 212
  • Bwahaha
Re: Manual Install Isn't Working
it appears that my computer is not powerful enough to handle FS1
Nitpicking: FSPort is not FS1. It may look like it and allow you to play the FS1 main campaign, but it isn't FS1.

It is possible to try to narrow down the problem even further. Open your FSPort folder and throw the mod.ini in there away. Then use the Launcher to select the FSPort folder as your active mod and try to run the game. If it works, you will be able to play FSPort, though it'll look like retail. IF not... well, new hardware would really kick arse.
23:40 < achillion > EveningTea: ass
23:40 < achillion > wait no
23:40 < achillion > evilbagel: ass
23:40 < EveningTea > ?
23:40 < achillion > 2-letter tab complete failure

14:08 < achillion > there's too much talk of butts and dongs in here
14:08 < achillion > the level of discourse has really plummeted
14:08 < achillion > Let's talk about politics instead
14:08 <@The_E > butts and dongs are part of #hard-light's brand now
14:08 <@The_E > well
14:08 <@The_E > EvilBagel's brand, at least

01:06 < T-Rog > welp
01:07 < T-Rog > I've got to take some very strong antibiotics
01:07 < achillion > penis infection?
01:08 < T-Rog > Chlamydia
01:08 < achillion > O.o
01:09 < achillion > well
01:09 < achillion > I guess that happens
01:09 < T-Rog > at least it's curable
01:09 < achillion > yeah
01:10 < T-Rog > I take it you weren't actually expecting it to be a penis infection
01:10 < achillion > I was not

14:04 < achillion > Sometimes the way to simplify is to just have a habit and not think about it too much
14:05 < achillion > until stuff explodes
14:05 < achillion > then you start thinking about it

22:16 < T-Rog > I don't know how my gf would feel about Jewish conspiracy porn

15:41 <-INFO > EveningTea [[email protected]] has joined #hard-light
15:47 < EvilBagel> butt
15:51 < Achillion> yes
15:53 <-INFO > EveningTea [[email protected]] has quit [Quit: http://www.mibbit.com ajax IRC Client]

18:53 < Achillion> Dicks are fun

21:41 < MatthTheGeek> you can't spell assassin without two asses

20:05 < sigtau> i'm mining titcoins from now on

00:31 < oldlaptop> Drunken antisocial educated freezing hicks with good Internet == Finland stereotype

11:46 <-INFO > Kobrar [[email protected]] has joined #hard-light
11:50 < achtung> Surely you've heard of DVDA
11:50 < achtung> Double Vaginal Double ANal
11:51 < Kobrar> ...
11:51 <-INFO > Kobrar [[email protected]] has left #hard-light []

 
Re: Manual Install Isn't Working
Well, since the debug log complains about not being able to go fullscreen, why don't you try and use the -window command line flag? It can be found in Dev Tool group of features.

What happens if you just run with no mods at all, but using FS2_Open?
Second paragraph: Same thing as with mods.

First paragraph: That totally worked.  Thanks!  :yes: