Author Topic: FS2 Open framerate drops no matter what detail settings used  (Read 7523 times)

0 Members and 1 Guest are viewing this topic.

FS2 Open framerate drops no matter what detail settings used
Hi, I downloaded FS2 from GOG.com and used the automatic FS2O installer (the one that downloads the components), the install appears to have gone well, I can play the game and everything works how you would expect it's just that I'm getting framerate drops all the time, even with the lowest possible graphics settings, even at 640x480.

I have a Q6600 @3.5ghz, GTX 280 gpu and 4GB of ram, so my pc is no pussy cat, strangely if I max out every single setting and enable the MediaVPs mod it runs slightly better but still it can't seem to hold 60fps.

I should add I'm only on the second mission, no huge battles yet, these slowdowns happen when I'm looking at empty space and especially when the radio chatter window appears in the top left.

So does anyone have any ideas what could be going on?  It's rather strange when maxing out your settings actually reduces slowdown  :eek2:

 

Offline Scotty

  • 1.21 gigawatts!
  • 211
  • Guns, guns, guns.
Re: FS2 Open framerate drops no matter what detail settings used
I don't know exactly what the problem is there, but as a pre-emptive warning, turn down the detail before an asteroid mission (mostly user campaign related.  Looking at YOU Derelict!).  Large quantities of asteroids takes the rug out from under the framerate.

As for your problem, close anything not essential when playing and see what happens.  On my computer, for one, I have to close the HP Total Care Advisor (actually close via the task manager) or it lags it all to hell.

 
Re: FS2 Open framerate drops no matter what detail settings used
Thanks for the reply, I've got practically nothing else running, I don't think this is a matter of resources as the slowdown is the same or worse even with everything turned off and running in 640x480  :confused:

I noticed I placed this thread in the wrong area, If a mod happens to read this could you move it to the support area?

Cheers   :)

 

Offline castor

  • 29
    • http://www.ffighters.co.uk./home/
Re: FS2 Open framerate drops no matter what detail settings used
What kind of numbers does the fps counter show? (to be enabled somewhere in the launcher)

 

Offline General Battuta

  • Poe's Law In Action
  • 214
  • i wonder when my postcount will exceed my iq
Re: FS2 Open framerate drops no matter what detail settings used
Which build do you have selected in the Launcher? I believe I've heard of a problem like this before.

 

Offline FUBAR-BDHR

  • Self-Propelled Trouble Magnet
  • 212
  • Master Drunk
    • 165th Beer Drinking Hell Raisers
Re: FS2 Open framerate drops no matter what detail settings used
Yea there were some reports when 3.6.10 final came out about ani files causing slow downs for some reason.  No idea what the solution was (if any) though. 
No-one ever listens to Zathras. Quite mad, they say. It is good that Zathras does not mind. He's even grown to like it. Oh yes. -Zathras

 
Re: FS2 Open framerate drops no matter what detail settings used
Due to the design of the engine you will always see some drops.
It's not that your graphics card is limiting any part of the performance, however the backend is not in anyway efficient.
Also, we're not (currently) able to utilise multiple cores on a machine, so that may be a source of your inefficiency.

We're working on it!
Hope this helps!
STRONGTEA. Why can't the x86 be sane?

 
Re: FS2 Open framerate drops no matter what detail settings used
What kind of numbers does the fps counter show? (to be enabled somewhere in the launcher)

It appears to hover around 59.9 and 60, I've not seen it drop any lower, seems odd that the fps are a solid 60 but visually I'm getting judders.

 
Re: FS2 Open framerate drops no matter what detail settings used
Which build do you have selected in the Launcher? I believe I've heard of a problem like this before.

Yeah I found a forum post about people using the old executable, causing slowdown, my launcher is set to use 3.6.10  :yes:

 
Re: FS2 Open framerate drops no matter what detail settings used
Due to the design of the engine you will always see some drops.
It's not that your graphics card is limiting any part of the performance, however the backend is not in anyway efficient.
Also, we're not (currently) able to utilise multiple cores on a machine, so that may be a source of your inefficiency.

We're working on it!
Hope this helps!

I'll take your word for it, just seems odd that if I drop all the detail right down to rock bottom and change the resolution to 640x480 I get worse performance than if I crank everything up, max resolution, max antialiasing and anisotropic filtering with all the new eyecandy enabled :wtf:

Oh, I get roughly the same performance from OpenGL as I do in D3D, probably slightly better.

*edit* I just tested it with Vsync disabled, the fps counter reads 120 solid fps, unwavering, there is no visual slowdown/judder but I can't play witout vsync, space sims without vsync are pretty horrible to look at :(
« Last Edit: September 13, 2009, 11:44:39 am by WDeranged »

 

Offline The E

  • He's Ebeneezer Goode
  • Global Moderator
  • 213
  • Nothing personal, just tech support.
    • Steam
    • Twitter
Re: FS2 Open framerate drops no matter what detail settings used
No, you don't. The engine doesn't actually support D3D.
Let there be light
Let there be moon
Let there be stars and let there be you
Let there be monsters and let there be pain
Let us begin to feel again
--Devin Townsend, Genesis

 

Offline colecampbell666

  • I See Dead Pictures
  • 212
  • Evolution and ascension.
Re: FS2 Open framerate drops no matter what detail settings used
Checklist:

Run in OpenGL
Make sure that you get a recent Nightly Build
Make sure that your GPU drivers are up-to-date

By rights you shouldn't have any issues at all with that system.
Gettin' back to dodgin' lasers.

 
Re: FS2 Open framerate drops no matter what detail settings used
No, you don't. The engine doesn't actually support D3D.

So the Direct3D 8 option is just a placeholder?

 

Offline colecampbell666

  • I See Dead Pictures
  • 212
  • Evolution and ascension.
Re: FS2 Open framerate drops no matter what detail settings used
Yeah.
Gettin' back to dodgin' lasers.

 
Re: FS2 Open framerate drops no matter what detail settings used
Thanks for the quick replies guys  :)

Anyway I've tried the latest nightly build (in OpenGL) with no joy, exactly the same judder, it's related to the video link I'm sure, I could be staring at a blank empty section of space and the second that pilot animation in the top left starts the judders kick in, actual FPS are unaffected.

The moment the radio chatter stops, gameplay return to normal for the most part, however performance certainly isn't perfectly fluid.  I will try updating my drivers next, but you know how things go with Nvidia and new drivers these days  :shaking:

 

Offline colecampbell666

  • I See Dead Pictures
  • 212
  • Evolution and ascension.
Re: FS2 Open framerate drops no matter what detail settings used
Did you select the build in the top box of the launcher? Do you have the latest MediaVPs?
Gettin' back to dodgin' lasers.

 

Offline castor

  • 29
    • http://www.ffighters.co.uk./home/
Re: FS2 Open framerate drops no matter what detail settings used
Could it have something to do with the v-refresh rate of the desktop (some sort of a driver bug)? Maybe try to play with it a bit.

 

Offline Herra Tohtori

  • The Academic
  • 211
  • Bad command or file name
Re: FS2 Open framerate drops no matter what detail settings used
Try with -nosound enabled. Your mention of pilot chatter affecting things might suggest it being an audio issue, so disabling sounds is a pretty surefire way to isolate the problem on sound system - if problem disappears, correlation is quite clear; if not, we'll have to look elsewhere.

You could also check that you have the in-game text-to-speech disabled on missions; if the TTS conflicts with existing messages or if TTS is not working correctly, it could cause problems (this is mainly a shot in the dark though).

What sort of sound card are you using? What setting do you have on your FSO Launcher's Audio/Joystick panel? Generic Software is the default that should be tried (other options may be available, and they might work perfectly well, but if you have something else selected and it causes problems, choose Generic Software and retry.

Also, check that you don't have any processes running amok and grabbing CPU processing power from the game exec; the problems you described are consistent of something interrupting the game's process momentarily (it could be related to sound driver crapping itself out, or any other process with equal priority to FS2_Open that hogs the CPU.


Also mentioning what operating system you use would be helpful (default assumption that I tend to use is WinXP, but it can sometimes be wrong).


And you'll get used to quick replies on these forums I think. ;)
There are three things that last forever: Abort, Retry, Fail - and the greatest of these is Fail.

 
Re: FS2 Open framerate drops no matter what detail settings used
Did you select the build in the top box of the launcher? Do you have the latest MediaVPs?

I did but I had selected fs2_open_3_6_11r_5591 which was just the same, however fs2_open_3_6_11d_5591 has no problems with the radio chatter, I'm still getting gameplay related judder (the fps stays locked at 60 though), I think tweaking with the detail settings might help from now.

I'll keep tweaking and see what I can get, thanks  :)

Oh, the latest Nvidia drivers did nothing.

 
Re: FS2 Open framerate drops no matter what detail settings used
With regards to Herra Tohtori's post above I tried disabling audio, I also have an external sound card which I tested, the problem remains no matter what I try, playing with acceleration options and such, It looks as though this issue isn't audio related...however I'm pretty sure its HUD related, the 3.6.11d_5591 executable appears to solve the issue of com chatter slowdown but I have just noticed I get the same slowdown when I target a large vessel (the game has to render the ship in the lower left), It's almost like HUD activity is causing slowdowns for me.

All the while the FPS remains at 60 though, which is puzzling  :lol:

Thanks again for sticking with me though, I don't think I've seen a forum with this level of support.