Author Topic: Can't get to work with Intel GMA --- where can I find 3.6.9 ?  (Read 1231 times)

0 Members and 1 Guest are viewing this topic.

Offline Bus

  • 22
Can't get to work with Intel GMA --- where can I find 3.6.9 ?
So I can't get 3.6.12 to work with Intel GMA HD (mobile), I get "Unable to get proper pixel format for OpenGL W32!" Yes, updating the graphics driver didn't help. I read that I might be able to get this to work with the old 3.6.9 under D3D but I can't find any (working) download link :(. Does anyone know where to get it / do you have any other suggestions what do? (Apart from buying a new computer...) Thank you very much!

 

Offline The E

  • He's Ebeneezer Goode
  • Global Moderator
  • 213
  • Nothing personal, just tech support.
    • Steam
    • Twitter
Re: Can't get to work with Intel GMA --- where can I find 3.6.9 ?
Buy a new computer.

Seriously, even if you could find a 3.6.9 build, you wouldn't be able to play most of the new content that is out there. No mediavps, no new campaigns....

That being said, what kind of OS and what kind of Intel GPU specifically do you have?
Let there be light
Let there be moon
Let there be stars and let there be you
Let there be monsters and let there be pain
Let us begin to feel again
--Devin Townsend, Genesis

 

Offline Bus

  • 22
Re: Can't get to work with Intel GMA --- where can I find 3.6.9 ?
As I said, it's Intel GMA HD Mobile (the Core i5 540M one), on Win 7 (x64). I kinda hoped it would be capable of running 3.6.12 :(...

 

Offline The E

  • He's Ebeneezer Goode
  • Global Moderator
  • 213
  • Nothing personal, just tech support.
    • Steam
    • Twitter
Re: Can't get to work with Intel GMA --- where can I find 3.6.9 ?
Well, it seems Intel ****ed those up even more than usual then. Sorry, but intelgrated chips just aren't a good choice for gaming.
Let there be light
Let there be moon
Let there be stars and let there be you
Let there be monsters and let there be pain
Let us begin to feel again
--Devin Townsend, Genesis

 

Offline Bus

  • 22
Re: Can't get to work with Intel GMA --- where can I find 3.6.9 ?
I didn't really have problems running any other games so far. Although I admit that I probably haven't tried anything OpenGL. Theoretically my card should support OpenGL 2.1 and shader 4.0, except that it has a really low number of pipelines and uses shared memory. Apparently there's more that Intel forgot to mention on their site... I'm almost tempted to download the source code and try to figure it out myself.

 

Offline Zacam

  • Magnificent Bastard
  • Administrator
  • 211
  • I go Sledge-O-Matic on Spammers
    • Minecraft
    • Steam
    • Twitter
    • ModDB Feature
Re: Can't get to work with Intel GMA --- where can I find 3.6.9 ?
Good luck with that. I don't think Intel shares that easily. And even then, you are still going to run into a hardware limitation.

As for fixing in the SCP code....there isn't really anything to fix. We use OpenGL, not some vendor specific bastardization thereof. And I don't think it'll port to OpenCL very well.
Report MediaVP issues, now on the MediaVP Mantis! Read all about it Here!
Talk with the FSU on #SCP-FSU Talk with the SCP on #SCP
"If you can keep a level head in all this confusion, you just don't understand the situation"

¤[D+¬>

[08/01 16:53:11] <sigtau> EveningTea: I have decided that I am a 32-bit registerkin.  Pronouns are eax, ebx, ecx, edx.
[08/01 16:53:31] <EveningTea> dhauidahh
[08/01 16:53:32] <EveningTea> sak
[08/01 16:53:40] * EveningTea froths at the mouth
[08/01 16:53:40] <sigtau> i broke him, boys

 

Offline The E

  • He's Ebeneezer Goode
  • Global Moderator
  • 213
  • Nothing personal, just tech support.
    • Steam
    • Twitter
Re: Can't get to work with Intel GMA --- where can I find 3.6.9 ?
Also note that Intel's shader support doesn't cover OpenGL Shaders.
Let there be light
Let there be moon
Let there be stars and let there be you
Let there be monsters and let there be pain
Let us begin to feel again
--Devin Townsend, Genesis

 

Offline Bus

  • 22
Re: Can't get to work with Intel GMA --- where can I find 3.6.9 ?
Excellent, then why does even Intel claim to support OpenGL at all? :P Anyway I didn't want to "fix" the problem, I only wanted to see which function fails and how, then do a quick Google search only to discover that my GPU doesn't support feature X. But most likely I'll be too lazy to download VS. (Does it compile in express anyway?) Thanks for your comments E & Zacam. In the meantime, if anyone knows about a downloadable D3D version please let me know, thanks!

 

Offline General Battuta

  • Poe's Law In Action
  • 214
  • i wonder when my postcount will exceed my iq
Re: Can't get to work with Intel GMA --- where can I find 3.6.9 ?
Jeez, this sounds like a ****ty situation.  :(

 

Offline Jeff Vader

  • The Back of the Hero!
  • Moderator
  • 212
  • Bwahaha
    • Twitter
Re: Can't get to work with Intel GMA --- where can I find 3.6.9 ?
Well, there is this one. But you'll have problems with it, and if you want MediaVPs, you'll need to dig up the old 3.6.8 Zeta ones.

And remember to enable jpg/tga support.
23:40 < achillion > EveningTea: ass
23:40 < achillion > wait no
23:40 < achillion > evilbagel: ass
23:40 < EveningTea > ?
23:40 < achillion > 2-letter tab complete failure

14:08 < achillion > there's too much talk of butts and dongs in here
14:08 < achillion > the level of discourse has really plummeted
14:08 < achillion > Let's talk about politics instead
14:08 <@The_E > butts and dongs are part of #hard-light's brand now
14:08 <@The_E > well
14:08 <@The_E > EvilBagel's brand, at least

01:06 < T-Rog > welp
01:07 < T-Rog > I've got to take some very strong antibiotics
01:07 < achillion > penis infection?
01:08 < T-Rog > Chlamydia
01:08 < achillion > O.o
01:09 < achillion > well
01:09 < achillion > I guess that happens
01:09 < T-Rog > at least it's curable
01:09 < achillion > yeah
01:10 < T-Rog > I take it you weren't actually expecting it to be a penis infection
01:10 < achillion > I was not

14:04 < achillion > Sometimes the way to simplify is to just have a habit and not think about it too much
14:05 < achillion > until stuff explodes
14:05 < achillion > then you start thinking about it

22:16 < T-Rog > I don't know how my gf would feel about Jewish conspiracy porn

15:41 <-INFO > EveningTea [[email protected]] has joined #hard-light
15:47 < EvilBagel> butt
15:51 < Achillion> yes
15:53 <-INFO > EveningTea [[email protected]] has quit [Quit: http://www.mibbit.com ajax IRC Client]

18:53 < Achillion> Dicks are fun

21:41 < MatthTheGeek> you can't spell assassin without two asses

20:05 < sigtau> i'm mining titcoins from now on

00:31 < oldlaptop> Drunken antisocial educated freezing hicks with good Internet == Finland stereotype

11:46 <-INFO > Kobrar [[email protected]] has joined #hard-light
11:50 < achtung> Surely you've heard of DVDA
11:50 < achtung> Double Vaginal Double ANal
11:51 < Kobrar> ...
11:51 <-INFO > Kobrar [Mibb[email protected]] has left #hard-light []

 

Offline Bus

  • 22
Re: Can't get to work with Intel GMA --- where can I find 3.6.9 ?
Thanks! I'll give it a try. Yes I've seen the zeta ones somewhere so that shouldn't be a problem.

EDIT: Except that those links are broken too. Sigh. I'll have to do some more googling...
« Last Edit: November 24, 2010, 02:28:19 pm by Bus »

 

Offline The E

  • He's Ebeneezer Goode
  • Global Moderator
  • 213
  • Nothing personal, just tech support.
    • Steam
    • Twitter
Re: Can't get to work with Intel GMA --- where can I find 3.6.9 ?
But be aware that that build is completely unsupported. We will not be able to offer you any support for it, and you won't be able to run any new content. In addition, you will encounter a lot of random crashes and general slowness.
Let there be light
Let there be moon
Let there be stars and let there be you
Let there be monsters and let there be pain
Let us begin to feel again
--Devin Townsend, Genesis

 

Offline Bus

  • 22
Re: Can't get to work with Intel GMA --- where can I find 3.6.9 ?
Yes, I totally understand that. I will probably look into that 3.6.12 problem eventually anyway..

 

Offline The E

  • He's Ebeneezer Goode
  • Global Moderator
  • 213
  • Nothing personal, just tech support.
    • Steam
    • Twitter
Re: Can't get to work with Intel GMA --- where can I find 3.6.9 ?
One thing you should do is run this: http://www.realtech-vr.com/glview/download.html and post the report it generates.
Let there be light
Let there be moon
Let there be stars and let there be you
Let there be monsters and let there be pain
Let us begin to feel again
--Devin Townsend, Genesis

 

Offline Bus

  • 22
Re: Can't get to work with Intel GMA --- where can I find 3.6.9 ?
Nooo it says I only have the 1.1 features (and one 1.2 feature) :( :(. I don't get it, I've tried three different drivers and still the same result. Some more googling for me...

 

Offline FUBAR-BDHR

  • Self-Propelled Trouble Magnet
  • 212
  • Master Drunk
    • 165th Beer Drinking Hell Raisers
Re: Can't get to work with Intel GMA --- where can I find 3.6.9 ?
You said win 7 right?  Just for the heck of it try running as a super admin if you can.  Someone else had an issue like this in the last week.  Sounds crazy but you never know. 
No-one ever listens to Zathras. Quite mad, they say. It is good that Zathras does not mind. He's even grown to like it. Oh yes. -Zathras