Author Topic: Display driver crashing upon campaign resume  (Read 3991 times)

0 Members and 1 Guest are viewing this topic.

Offline Aegis

  • 21
Display driver crashing upon campaign resume
Hello, I'm trying to play through the FS2 campaign, but each time I attempt to resume the campaign (even before the briefing) the game hangs before the loading bar even moves, and the display driver crashes, along with the game. I can happily start a campaign, and play through many missions without any problems, so it isn't a mission-specific crash.

If I start the game using the debug file, fs2_open_3_6_12d_INF_SSE2.exe, the game successfully loads the next mission, and I can play. However, it's jittery and feels sluggish.
I use the fs2_open_3_6_12r_INF_SSE2.exe and have a 4870X2 with 11.5 drivers. I have MediaVPs installed.
The game also crashes with the fs2_open_3_6_12r_INF.exe, and it doesn't matter whether I have all the graphical features under "features" in the launcher on or off.
I also experience flashing debris, even when using ma-sdrvfix.vp.

I've attached the log, hopefully it can shed some light even though the game didn't break when I was using the debug .exe :doubt:

Thank you everyone! From what I've played, it's very fun and a definitely shinier experience compared to vanilla FS2.

[attachment deleted by ninja]


Offline The E

  • He's Ebeneezer Goode
  • Moderator
  • 213
  • Nothing personal, just tech support.
    • Steam
    • Twitter
Re: Display driver crashing upon campaign resume

The problem is, the 11.5 drivers seem to be less than stable (When I used them, they had some strange memory leakage thing going on, causing performance to drop into a deep black hole after a few hours of system uptime).

My personal recommendation would be to either extract the atioglxx.dll from an earlier version (11.4 seems to be OK so far), and place that in your FS2 folder, or reverting to an earlier driver altogether.

See also: this topic
If I'm just aching this can't go on
I came from chasing dreams to feel alone
There must be changes, miss to feel strong
I really need lifе to touch me
--Evergrey, Where August Mourns


Offline Aegis

  • 21
Re: Display driver crashing upon campaign resume
It was very difficult to find 11.4 drivers, so I ran a search of my entire computer to find all of the atioglxx.dlls. I had about 4, and I took the oldest one (2010) and put it into the FS2 directory, and now everything works :)
As an added bonus, there is no more flashing debris, too!
Thanks for your help


Offline Zacam

  • Magnificent Bastard
  • Administrator
  • 211
  • I go Sledge-O-Matic on Spammers
    • Steam
    • Twitter
    • ModDB Feature
Re: Display driver crashing upon campaign resume

Would you mind zipping that file up and uploading it somewhere?

It might be useful for other folks.
Report MediaVP issues, now on the MediaVP Mantis! Read all about it Here!
Talk with the community on Discord
"If you can keep a level head in all this confusion, you just don't understand the situation"


[08/01 16:53:11] <sigtau> EveningTea: I have decided that I am a 32-bit registerkin.  Pronouns are eax, ebx, ecx, edx.
[08/01 16:53:31] <EveningTea> dhauidahh
[08/01 16:53:32] <EveningTea> sak
[08/01 16:53:40] * EveningTea froths at the mouth
[08/01 16:53:40] <sigtau> i broke him, boys


Offline jr2

  • The Mail Man
  • 212
  • It's prounounced jayartoo 0x6A7232
    • Steam
Re: Display driver crashing upon campaign resume
Which OS are you using?  AFAIK XP driver files are different from Vista/7 ones.


Offline Aegis

  • 21
Re: Display driver crashing upon campaign resume
No problem, here's the link:

I'm using Windows 7, 64 bit.

EDIT: Ok, it turns it that it didn't fix it for me. What I did was uninstall 11.5, not restart, then install 11.4 preview (Which still has easy to find download links).
Then I got the atioglxx.dll and put it into the FS2 directory and played, finding that it worked. I restarted around here.
The game still worked, so I uninstalled 11.4 preview and installed 11.5. It still worked. However, after a restart it doesn't work.

So, I uninstalled 11.5, installed 11.4 preview (FS2 worked) and copied ALL of the DLLs under C:\Program Files (x86)\ATI Technologies\ATI.ACE and its subdirectories into the FS2 folder.
Then I uninstalled 11.4 preview, installed 11.5 and restarted. It didn't work.

Then I remove all DLLs from the directory, uninstall 11.5, don't restart, and it works. With no drivers.
I restart, and it doesn't work. Still with no drivers.
I install 11.4 preview, and it works. I restart, and it does't work.

So.... The game works when I have no drivers installed. Can anyone help me?
« Last Edit: May 27, 2011, 03:58:31 am by Aegis »


Offline jr2

  • The Mail Man
  • 212
  • It's prounounced jayartoo 0x6A7232
    • Steam
Re: Display driver crashing upon campaign resume
I blame Gremlins.


Offline Kruelt

  • 20
Re: Display driver crashing upon campaign resume
Hi all. I found a way to resolve this.

1. Drop the old driver in the FS2 folder as instructed on these forums
2. Whenever you run into the problem where it does not resume
a. Restart the game and create a new pilot. This will not actually be used
b. Start the campaign with this pilot. After the first training intro opens, press esc to get back to the hangar
c. Go to the barracks and switch to the pilot that you have been playing. Go back to the hangar and
d. Try to resume the campaign

Don't know if this will work for everyone, but it has worked for me every time. You only need to do 2a once. Whenever the resume issue comes back, just start with that pilot and do b,c,d.

Re: Display driver crashing upon campaign resume

For about a year +  I've not been able to play, thankfully the above solved the issue [the ati dll file and the resume fix] but not with the current releases.

For me neither of the fixes work using 3.6.12 Inferno release with any of the last 6 ATI drivers [that is as far as I went back in testing different drivers], the game just hangs when trying to access a mission or the tech room[white screen] then I must close it.

I've not tried any of the older Inferno releases other than the last which did not work either for me.

The latest beta however, along with the DLL file and the resume game work around seems to of fixed the problem -  "fs2_open_3_6_14_SSE_RC1.exe" - is the beta release that works for me.

I get the feeling the issue is linked to either crossfire and or anti-aliasing, you can tell when the game is going to work as when the "Hints/Tips" dialogue appears in the main screen, a purple horizontal bar comes up [can screen shot this if need be], in my experience that happens in some games when I've set AA up via CCC, in this case it happens either way. The bar vanishes when you close the tips dialogue.  When the game isn't going to work, e.g. with the 3.6.12 Inferno's, the bar does not come up at all and going to tech room or mission/hanger hangs the game / white screens it.

With the new CCC drivers they have added application profiles, to make sure it wasn't a crossfire issue i set up a profile for freespace to force crossfire disabled, made no difference.

So for now I'm stuck using the beta, but at least i can play :P Just none of the mods i have seem to be compatible with it as they refuse to load.

Not sure if i should of posted this in the relevant thread for the 3.6.14 RC1's, sorry if so.  But whatever you guys are doing keep it up pretty please as it makes the game playable again for me and for that, much <3 :)

« Last Edit: December 23, 2011, 12:58:28 pm by acidtwin »


Offline technopredator

  • Does not compute
  • 27
  • Don't get mad, consequences are revenging you.
Re: Display driver crashing upon campaign resume
CrossFire won't work with FSO read this to activate it. The latest Cats with optimizations is now 12.2 download it, uninstall the previous driver, restart and then install the new one, if everything goes OK you won't need to copy the atioglxx.dll to FSO directory. If that driver fails try the stable 12.1 (XP 32-bit, 7/Vista 64-bit, 7/Vista 32-bit). The South Bridge drivers are included.

Make sure the the 4 executables in Release 3.6.14 Release Candidate 4 and the launcher are set to run as Administrator.
« Last Edit: February 17, 2012, 08:24:07 am by technopredator »