Author Topic: "JPEG Error: Wrong JPEG library version: library is 62, caller expects 80"  (Read 5681 times)

0 Members and 1 Guest are viewing this topic.

"JPEG Error: Wrong JPEG library version: library is 62, caller expects 80"
Is the above error enough to cause a crash? Each time i try and hit 'continue' from the mainhall screen i get a crash to desktop, and that's the last thing in the debug log.

FSO-Linux
INF build : _d-nightly_r7097
Currently playing Wings of Dawn but FSO has been intermittently crashing during other stuff, and I've only recently been attempting to get this linux build going, so I'm thinking it's not mod specific error.

fs2_open.log attached, extremely verbose settings since i wasn't quite sure what to filter.

[attachment deleted by ninja]

 

Offline The E

  • He's Ebeneezer Goode
  • Global Moderator
  • 213
  • Nothing personal, just tech support.
    • Steam
    • Twitter
Re: "JPEG Error: Wrong JPEG library version: library is 62, caller expects 80"
Please, for the love of kittens, do NOT use the "extremely verbose settings", unless explicitly told to do so.
Let there be light
Let there be moon
Let there be stars and let there be you
Let there be monsters and let there be pain
Let us begin to feel again
--Devin Townsend, Genesis

 
Re: "JPEG Error: Wrong JPEG library version: library is 62, caller expects 80"
Please, for the love of kittens, do NOT use the "extremely verbose settings", unless explicitly told to do so.

XD. How's this?

[attachment deleted by ninja]

 

Offline Zacam

  • Magnificent Bastard
  • Administrator
  • 211
  • I go Sledge-O-Matic on Spammers
    • Minecraft
    • Steam
    • Twitter
    • ModDB Feature
Re: "JPEG Error: Wrong JPEG library version: library is 62, caller expects 80"

Interesting issue. Unable to replicate, but then, I'm not on linux. It may be possible your system is using a different version of libjpeg then.

The code was updated to use version 8c. But most compiles will use the system version. Windows (and I think OS X?) build against the version that is in SVN checkout.

Try seeing what version of libjpeg your machine is running and if it's lower than 8c, try an update on it?

Also, try a newer/latest version of a nightly build as well. Many things have gotten fixed since that revision.
Report MediaVP issues, now on the MediaVP Mantis! Read all about it Here!
Talk with the FSU on #SCP-FSU Talk with the SCP on #SCP
"If you can keep a level head in all this confusion, you just don't understand the situation"

¤[D+¬>

[08/01 16:53:11] <sigtau> EveningTea: I have decided that I am a 32-bit registerkin.  Pronouns are eax, ebx, ecx, edx.
[08/01 16:53:31] <EveningTea> dhauidahh
[08/01 16:53:32] <EveningTea> sak
[08/01 16:53:40] * EveningTea froths at the mouth
[08/01 16:53:40] <sigtau> i broke him, boys

 
Re: "JPEG Error: Wrong JPEG library version: library is 62, caller expects 80"

Interesting issue. Unable to replicate, but then, I'm not on linux. It may be possible your system is using a different version of libjpeg then.

The code was updated to use version 8c. But most compiles will use the system version. Windows (and I think OS X?) build against the version that is in SVN checkout.

Try seeing what version of libjpeg your machine is running and if it's lower than 8c, try an update on it?

Also, try a newer/latest version of a nightly build as well. Many things have gotten fixed since that revision.


OS repositories don't get any higher than this, upgrading to 8c would be "interesting", which was why i was asking before going through the effort. As for a newer build, i've tried the only other newer linux nightly, and i just tried a compile of the latest svn I did myself, same result.

Huh. The 3.6.12 release seems to get by this particular crash. But both this and the nightly builds tend to crash in-mission. Debug log for 3.6.12 doesn't mention the libjpeg error so I guess that might be a critical problem afterall. Well, i'll let you know after i figure out a way to manually install a newer version of a library with hundreds of dependencies X_X

 
Re: "JPEG Error: Wrong JPEG library version: library is 62, caller expects 80"
Code: [Select]
        <Zacam-Away> 6980 was the revision that we updated libjpeg in.
<Zacam-Away> So, you can either A: test a nightly prior to that revision or B: make a build based on a checkout prior to that revision and see if it all works hunky dory, and then do a build or a nightly based on that revision and see if then breaks as it currently does.
<Zacam-Away> Alternatively, if the newer code breaks things, we might have somebody about that could talk you through linking your compiling dependency to build based on the libjpeg in the SVN dir vs the OS system library.
<Zacam-Away> (At least, I think that is possible, it should be since there was a commit to make it able to rely on OS layer, but hopefully without having to do much in the way of code tree changes)
|<-- CR has left irc.esper.net (Ping timeout: 194 seconds)
<Zacam-Away> At the very very least, you could try grabbing the latest version of libjpegs makefile and sticking that in and linking to it in your build process.
<Zacam-Away> You could probably get the gist of it by looking at the log and changes made on Commit 5981 which is where it was made to use the system versions.
<Zacam-Away> If you're willing of course.
<Zacam-Away> At a minimum, testing the outlined builds and reporting that should be enough for us to flag it for further investigation, but I don't know who we would have available to look at it.
<Zacam-Away> (And failing all else, I can link you to converted .PNG versions of the files for you to put into your WoD dir so you can continue playing, or something)
<DarkBasilisk> wait. what was that part about the libjpegs makefile?
<Zacam-Away> Well, currently it doesn't have one anymore AFAIK but it did at one point in time.
<Zacam-Away> So, theINory, all you would need would be the makefile and place it into the libjpeg dir and modify makefile.am and/or configure.ac to link to it.
<DarkBasilisk> so it would install the library inside freespace and sidestep these issues altogether?
<DarkBasilisk> mm.
<Zacam-Away> It would compile the code against the version that is in the repository checkout, yes.
<Zacam-Away> (again, I'm not a linux expert, my last use of a distro was when Mandrake was still new and Red Hat never heard of calling themselves "Fedora" or offering "Enterprise")
<Zacam-Away> Not counting the MythTV I'm running that is.

6979 loads but the images are blue tinted. Going all the way back for 3.6.12 (which loads jpegs with the right colors), i got to play for a little while before a crash. Nothing in debug log i could make sense of but posting it here.

EDIT: I think we can solve the jpeg issue at least now that i've found out about the config option to statically link libjpeg, still not sure why it's crashing the other times though.
EDIT EDIT: Nevermind ^ it turns out that didn't work either :( That doesn't even make sense. Config file even said it was using libjpeg.a from the source folder. (debug log posted does not relate to this case but rather the attempt with the base 3.6.12 release).

[attachment deleted by ninja]
« Last Edit: June 18, 2011, 01:40:44 am by DarkBasilisk »