Author Topic: ''Unable to get proper pixel format for OpenGL W32!'' a 2011 story  (Read 4018 times)

0 Members and 1 Guest are viewing this topic.

Offline dekal

  • 23
''Unable to get proper pixel format for OpenGL W32!'' a 2011 story
So, after a year or so of not playing freespace 2, I decided to install it again to complete the blue planet and main freespace campaign for the 50th time. After the process of finding my freespace 2 discs and installing them was finished, I went for the 3.6.12 build and just for the bare minimum mediavps  so I could play at 60 fps... but wait what is this?!

''Unable to get proper pixel format for OpenGL W32!''

Glancing at this totally unexpected error, I simply thought that someone had upgraded the 3.6.12 build to require some files from new computers to make freespace more awesome. Thinking it was time to buy a new laptop i just went for the 3.6.10 build (the first one I got when I found out about fs2 open) which I had in another disc.

''Unable to get proper pixel format for OpenGL W32!''

 :confused: Well, it must be something I did to my pc since freespace 3.6.12 and 3.6.10 worked perfectly fine before... time to google the error! And I found some posts... from 2009. There, I found out that this was because you had  a really bad graphics card that didn't support Open gl  or didn't update your drivers.

Huh? But I just updated the drivers for my ATI Radeon HD 3200 card and even with my old drivers the thing worked! I also found out from the FSO FAQ that ATI sucked. So, I started to install every single other older driver that exists, but the error just won't go away.

I also played retail freespace and it works, so it's not an installation problem. I'm now posting here hoping that someone just says ''Oh, you just miss this .dll link''. I know hardware is old but not a problem since I stopped playing some time after the 3.6.12 mediavps were released.



[attachment deleted by ninja]

 

Offline The E

  • He's Ebeneezer Goode
  • Global Moderator
  • 213
  • Nothing personal, just tech support.
    • Steam
    • Twitter
Re: ''Unable to get proper pixel format for OpenGL W32!'' a 2011 story
Okay, which driver version are you using? And does anything change if you use one of the nightly builds (found here)?
Let there be light
Let there be moon
Let there be stars and let there be you
Let there be monsters and let there be pain
Let us begin to feel again
--Devin Townsend, Genesis

 

Offline dekal

  • 23
Re: ''Unable to get proper pixel format for OpenGL W32!'' a 2011 story
Same error and crash when using the latest windows nightly build (I'll attach the log). I'm currently using the 11.8 drivers from ATI 

[attachment deleted by ninja]

 

Offline The E

  • He's Ebeneezer Goode
  • Global Moderator
  • 213
  • Nothing personal, just tech support.
    • Steam
    • Twitter
Re: ''Unable to get proper pixel format for OpenGL W32!'' a 2011 story
Well. The only thing that comes to mind right now would be to see if there's an atioglxx.dll in your FS2 folder, and delete it. If that is not the case, or if that doesn't fix it, a complete uninstall of the current driver, followed by a CCleaner pass, followed by a reboot and driver reinstall would be the only thing left to do.
Let there be light
Let there be moon
Let there be stars and let there be you
Let there be monsters and let there be pain
Let us begin to feel again
--Devin Townsend, Genesis

 

Offline Nuke

  • Ka-Boom!
  • 212
  • Mutants Worship Me
Re: ''Unable to get proper pixel format for OpenGL W32!'' a 2011 story
are you starting the game in 32 bit mode? are you selecting 32 bit in the launcher video settings?
I can no longer sit back and allow communist infiltration, communist indoctrination, communist subversion, and the international communist conspiracy to sap and impurify all of our precious bodily fluids.

Nuke's Scripting SVN

 

Offline dekal

  • 23
Re: ''Unable to get proper pixel format for OpenGL W32!'' a 2011 story
Yes, I'm starting the game at 32 bit mode. I also didn't find the atioglxx.dll in my fs2 folder

I'll reinstall the drivers doing a ccleaner pass and see if something is different. If it doesn't fix anything then the only explanation that comes to my mind is that AMD/ATI nuked Open gl support

 

Offline Jeff Vader

  • The Back of the Hero!
  • Moderator
  • 212
  • Bwahaha
    • Twitter
Re: ''Unable to get proper pixel format for OpenGL W32!'' a 2011 story
I also found out from the FSO FAQ that ATI sucked.
Ati sucks, Nvidia sucks, Intel sucks, S3 sucks (boy, does it suck), Via sucks. They all suck at one point or another. Ati is, by all means, not the only one.

If it doesn't fix anything then the only explanation that comes to my mind is that AMD/ATI nuked Open gl support
There are times when their OpenGL support sucks more than usual, but had they "nuked" it completely, there'd be a lot more people with this problem, yours truly included.

Edit: something probably not related to the problem, but:
Code: [Select]
-ogl_spec 60-no_emissive_lightThere should be a space there. Between "60" and "-no".
« Last Edit: September 11, 2011, 03:17:46 am by Jeff Vader »
23:40 < achillion > EveningTea: ass
23:40 < achillion > wait no
23:40 < achillion > evilbagel: ass
23:40 < EveningTea > ?
23:40 < achillion > 2-letter tab complete failure

14:08 < achillion > there's too much talk of butts and dongs in here
14:08 < achillion > the level of discourse has really plummeted
14:08 < achillion > Let's talk about politics instead
14:08 <@The_E > butts and dongs are part of #hard-light's brand now
14:08 <@The_E > well
14:08 <@The_E > EvilBagel's brand, at least

01:06 < T-Rog > welp
01:07 < T-Rog > I've got to take some very strong antibiotics
01:07 < achillion > penis infection?
01:08 < T-Rog > Chlamydia
01:08 < achillion > O.o
01:09 < achillion > well
01:09 < achillion > I guess that happens
01:09 < T-Rog > at least it's curable
01:09 < achillion > yeah
01:10 < T-Rog > I take it you weren't actually expecting it to be a penis infection
01:10 < achillion > I was not

14:04 < achillion > Sometimes the way to simplify is to just have a habit and not think about it too much
14:05 < achillion > until stuff explodes
14:05 < achillion > then you start thinking about it

22:16 < T-Rog > I don't know how my gf would feel about Jewish conspiracy porn

15:41 <-INFO > EveningTea [[email protected]] has joined #hard-light
15:47 < EvilBagel> butt
15:51 < Achillion> yes
15:53 <-INFO > EveningTea [[email protected]] has quit [Quit: http://www.mibbit.com ajax IRC Client]

18:53 < Achillion> Dicks are fun

21:41 < MatthTheGeek> you can't spell assassin without two asses

20:05 < sigtau> i'm mining titcoins from now on

00:31 < oldlaptop> Drunken antisocial educated freezing hicks with good Internet == Finland stereotype

11:46 <-INFO > Kobrar [[email protected]] has joined #hard-light
11:50 < achtung> Surely you've heard of DVDA
11:50 < achtung> Double Vaginal Double ANal
11:51 < Kobrar> ...
11:51 <-INFO > Kobrar [[email protected]] has left #hard-light []

 

Offline Parias

  • 27
Re: ''Unable to get proper pixel format for OpenGL W32!'' a 2011 story
Have you tried playing without -window - and / or tried different screen resolutions?

 

Offline dekal

  • 23
Re: ''Unable to get proper pixel format for OpenGL W32!'' a 2011 story
I only check the run in window flag to generate the fs2_open.log and I tried other resolutions but I still see no other result.

CCclean sweep after driver uninstall was also fruitless. If anyone has other ideas, I'll try them.

This what I get for uninstalling freespace in the first place...