Author Topic: PCS2 Subobject Radius Loss  (Read 2115 times)

0 Members and 1 Guest are viewing this topic.

Offline Droid803

  • Trusted poster of legit stuff
  • 213
  • /人 ◕ ‿‿ ◕ 人\ Do you want to be a Magical Girl?
    • Skype
    • Steam
PCS2 Subobject Radius Loss
This is getting seriously annoying.
Whoever made it so that you could manually edit the radius of subobjects messed up bigtime because it keeps setting values to 0 or some really tiny number like 0.00000171, or sometimes even negative values (what the **** is a negative radius D:).
Which causes (predictably) a whole ton of trouble, including SUPER LAG, madly-spinning debris, etc. Not to mention a whole slew of collision errors.

Easily fixed by going through and hitting reset on every afflicted subobject, but usually, that means every single subobject.
NOT COOL.
(´・ω・`)
=============================================================

 

Offline Droid803

  • Trusted poster of legit stuff
  • 213
  • /人 ◕ ‿‿ ◕ 人\ Do you want to be a Magical Girl?
    • Skype
    • Steam
Re: PCS2 Subobject Radius Loss
*poke* anyone here?
As seen here clearly I am not the only one experiencing this issue.
(´・ω・`)
=============================================================

 

Offline Droid803

  • Trusted poster of legit stuff
  • 213
  • /人 ◕ ‿‿ ◕ 人\ Do you want to be a Magical Girl?
    • Skype
    • Steam
Re: PCS2 Subobject Radius Loss
Bumping because this is ****ing annoying and adds like 10 minutes to every conversion cycle.
Which is seriously putting me off doing it.

Would it ****ing kill someone to even respond?

This happens during DAE->POF saving process. The DAE has the correct radii but the pof does not. Fixing it on the pof (pof->pof) is fine.
Purging BSP cache does not help in any phase.

The longer this error persists the bigger chance there is of having an era of ****ed up models because people aren't thorough enough to reset the radius of EVERY GODDAMN SUBOBJECT...
(´・ω・`)
=============================================================

 

Offline Talon 1024

  • 29
  • How do you turn this on?
    • Mods, Games, and Stuff
Re: PCS2 Subobject Radius Loss
I think it would help if you provided a sample DAE that causes this problem so that Spicious or someone else can reproduce this issue.

BTW I'm using the April 1st build of PCS2, and I haven't had to reset the radius of every subobject in models I've converted...  Although I haven't made any models with LODs or Debris recently.

« Last Edit: August 19, 2012, 08:28:34 pm by Talon 1024 »
To understand religion, you need to understand morality first. | WCSaga website | WCSaga Forum | 158th website | 158th forum | Project Leader: WC: Hostile Frontier | WCHF Thread at CIC | Wing Blender | Twist of Fate | Multipart turrets on angled surfaces, tutorial included. | My Google Drive stuff | To convert speeds from WC to WCS, multiply both the cruise speed and the Afterburner speed by 0.15625 (5/32)

FS2 Mods I'm waiting on: Inferno 10th Anniversary
Current Project: Contestant Android app, Learn4Life iOS app, Blender Commander (importer).
The FreeSpace Font Foundry is back in action!

 

Offline Droid803

  • Trusted poster of legit stuff
  • 213
  • /人 ◕ ‿‿ ◕ 人\ Do you want to be a Magical Girl?
    • Skype
    • Steam
Re: PCS2 Subobject Radius Loss
Every DAE causes this problem.
At least, every one with Debris.
(´・ω・`)
=============================================================

 

Offline zookeeper

  • *knock knock* Who's there? Poe. Poe who?
  • 210
Re: PCS2 Subobject Radius Loss
Well, I can respond but can't really help.

Yes, it's a bug and a very annoying one, so hopefully someone will fix it soon. :sigh: Unfortunately Spicious doesn't seem to be around much these days.

 

Offline Spicious

  • Master Chief John-158
  • 210
Re: PCS2 Subobject Radius Loss
Yay, 2 character fix.

[attachment removed and sold on the black market]