Author Topic: The BP Compatibility package  (Read 21123 times)

0 Members and 1 Guest are viewing this topic.

Offline Ariel

  • 25
Re: The BP Compatibility package
even with the compatabillity pack  blue planet and  wwar in heaven don't work when i'm trying to activate it at the campaign room  it's crashing insted.

i'm using the 3.6.18 build of FSO what should i do next?

 

Offline Ariel

  • 25
Re: The BP Compatibility package
This is the error.



[attachment deleted by ninja]

 

Offline MatthTheGeek

  • Captain Obvious
  • 212
  • Frenchie McFrenchface
Re: The BP Compatibility package
i'm using the 3.6.18 build of FSO what should i do next?
Not using 3.6.18 is what you should do next. It won't work with BP. Use the build provided with the compatibility package.
People are stupid, therefore anything popular is at best suspicious.

Homeworld: Blue Planet     -     Help us help you     -     FSO Installer     -     BP extras portal     -     My legacy

666maslo666: Releasing a finished product is not a good thing! It is a modern fad.

SpardaSon21: it seems like you exist in a permanent state of half-joking misanthropy

Axem: when you put it like that, i sound like an insane person

bigchunk1: it's not retarded it's american!
bigchunk1: ...

batwota: steele's maneuvering for the coup de gras
MatthTheGeek: you mispelled grâce
Awaesaar: grace
batwota: oh right :P
Darius: ah!
Darius: yes, i like that
MatthTheGeek: the way you just spelled it it means fat
Awaesaar: +accent I forgot how to keyboard
MatthTheGeek: or grease
Darius: the killing fat!
Axem: jabba does the coup de gras
MatthTheGeek: XD
Axem: bring me solo and a cookie

 
Re: The BP Compatibility package
I've been using the 3.6.19 from the nightly builds forum, that works fine.

 

Offline Ariel

  • 25
Re: The BP Compatibility package
I've been using the 3.6.19 from the nightly builds forum, that works fine.
can you please  post the nightly build here cause i don't know how to work with the nightly builds as i'm not a pro like most of you. i
i'm using the 3.6.18 build of FSO what should i do next?
Not using 3.6.18 is what you should do next. It won't work with BP. Use the build provided with the compatibility package.
 
as i stated before  it's crashing with the compatability pack  will test the  3.6.17 and see what happens.

update: tested 3.6.17 works like  a charm thank you all.
« Last Edit: March 21, 2013, 10:07:20 am by Ariel »

 

Offline General Battuta

  • Poe's Law In Action
  • 214
  • i wonder when my postcount will exceed my iq
Re: The BP Compatibility package
Just go to the first post in this thread, click the link to the nightly builds forum, download the most recent one, and use it.

Your crash will stop.

 

Offline The E

  • He's Ebeneezer Goode
  • Global Moderator
  • 213
  • Nothing personal, just tech support.
    • Steam
    • Twitter
Re: The BP Compatibility package
I have updated the first post with instructions that should be a bit clearer.
Let there be light
Let there be moon
Let there be stars and let there be you
Let there be monsters and let there be pain
Let us begin to feel again
--Devin Townsend, Genesis

 
Re: The BP Compatibility package
Hey guys I finally got my copy of bp to work, but now I have 2 HUDS stacked on top of each other?  :confused:
I'm using a nightly build I downloaded a few days ago I think.
I ran debug and got some random errors that didn't seem to affect gameplay but might mean something to you guys.
Also post processing freezes the screen every 5 seconds oddly?

[attachment deleted by ninja]
« Last Edit: March 21, 2013, 12:52:24 pm by nickd0121 »

 

Offline The E

  • He's Ebeneezer Goode
  • Global Moderator
  • 213
  • Nothing personal, just tech support.
    • Steam
    • Twitter
Re: The BP Compatibility package
Your first issue can be addressed by changing the resolution.

The second one is, unfortunately, a result of your rather old GPU.
Let there be light
Let there be moon
Let there be stars and let there be you
Let there be monsters and let there be pain
Let us begin to feel again
--Devin Townsend, Genesis

 
Re: The BP Compatibility package
Your first issue can be addressed by changing the resolution.

The second one is, unfortunately, a result of your rather old GPU.
Changing the resolution up down, sideways? That's as high as I can go right now, my good monitor is broken. Anything else I can do???
Post processing used to work fine, guess I'll just leave it off. Forgot what it does anyway.  :blah:
Edit: Thanks for responding quickly btw
« Last Edit: March 21, 2013, 01:18:27 pm by nickd0121 »

 
Re: The BP Compatibility package
I think The E means that you should change the resolution in your launcher settings.

 

Offline Black_Yoshi1230

  • 28
  • Fat and lazy glory hound, mooch, narcissist.
    • Black Yoshi's YouTube Page
Re: The BP Compatibility package
About the double-HUD elements (this should be thrown in known release issues or something):

4:3 (which this happens on the most from what I've read) - 1024x768 and 1152x864 tend to be the best options. (I've also had some success running it on 1200x900, but that is a custom resolution, which is typed as "-res 1200x900" in Features/Custom Flags.)

16:9 - 1280x720 is the best option for low-end users. From what I've heard, any 16:9 resolution above 720p is safe.

You will need something above 1024 or 720p to run, otherwise, you get no HUD.
« Last Edit: March 22, 2013, 01:05:06 am by Black_Yoshi1230 »
The MechWarrior 2 Resource Forum / Flyboy's Flight Sim + Aviation Page / Falcom Sound Team JDK / Jane's F/A-18 - Resources

&& "LAUNCH! LAUNCH! S__T WE'RE HIT! WE'RE TAKING CANNON FIRE! GET US THE HELL OUTTA HERE!" - The best Jane's Longbow 2 Co-Pilot Audio Clips.

|| BEAMS! DEATH BY BEAMS! <- Blue Planet: War in Heaven in a nutshell. (Phrase is adapted from the Freeman's Mind spinoff Barney's Mind, Episode 14: BEES! DEATH BY BEES!)

^ Give a kid a stick and tell him to beat up his enemies, he'll do it without a second thought. Give a kid a book and tell him to defeat his opponent, and he'll read the book, defeat the other's mind, and smack him on top of the head. Give a kid a flower, he'll force his opponent to eat it.

 
Re: The BP Compatibility package
Thanks a bunch Yoshi, I'll try that when I get back home. I got it to work on 1024x768 the other night, maybe I'll mess around with the res some more.
Thanks again to E also.

Knossos, yeah I know, just hate lowering the res if I don't have to (1280x1024 is pretty low lol).

Did anyone notice the site seemed to go down last night?

 
Re: The BP Compatibility package
Yeah I have experienced resolution problems as well, but never the hud problem. In my situation, all of the ship models become elongated if I set the resolution to my laptop's native 1366x768. 1024x768 works fine for me too, but it appears to zoom in on the models when compared to other resolutions.

On another note, I've been wanting to ask the devs how this laptop would hold up when playing BP:

HP ENVY Sleekbook6-1110US w/ AMD Quad-Core A8-4555M APU (2.4 GHz/1.6 GHz) and Radeon HD 7600g graphics

http://www.shopping.hp.com/en_US/home-office/-/products/Laptops/HP-ENVY/C2K91UA?HP-ENVY-Sleekbook-6-1110us

EDIT: nickd0121 yeah I noticed that the site was down last night. I noticed that the font in the forums were enlarged, but I don't know if that was why the site was down.

 

Offline The E

  • He's Ebeneezer Goode
  • Global Moderator
  • 213
  • Nothing personal, just tech support.
    • Steam
    • Twitter
Re: The BP Compatibility package
That thing should be fast enough to run BP.
Let there be light
Let there be moon
Let there be stars and let there be you
Let there be monsters and let there be pain
Let us begin to feel again
--Devin Townsend, Genesis

 
Re: The BP Compatibility package
Great, thanks!

 

Offline InsaneBaron

  • 29
  • In the CR055H41R2
Re: The BP Compatibility package
As a guy stuck with a computer made mostly of virtual duck tape (Mackie?) I'm grateful and impressed that the BP team would take the time to make a compat package for people like me.

Thanks a ton guys!

 :yes2::yes:
Doesn't matter what the press says. Doesn't matter what the politicians or the mobs say. Doesn't matter if the whole country decides that something wrong is something right. This nation was founded on one principle above all else: the requirement that we stand up for what we believe, no matter the odds or the consequences. When the mob and the press and the whole world tell you to move, your job is to plant yourself like a tree beside the river of truth, and tell the whole world — "No, you move." - Captain America

InsaneBaron's Fun-to-Read Reviews!
Blue Planet: Age of Aquarius - Silent Threat: Reborn - Operation Templar - Sync, Transcend, Windmills - The Antagonist - Inferno, Inferno: Alliance

 
Re: The BP Compatibility package
Ok, so I finally got back home and downloaded all updates and when running BP2 textures were replaced with multi-colored boxes or just white.  Fighters, weapons fire, ships and other graphics are all showing up as white colored blocks.  Here is what I got when I ran debug after searching around:
Quote
==========================================================================
DEBUG SPEW: No debug_filter.cfg found, so only general, error, and warning
categories can be shown and no debug_filter.cfg info will be saved.
==========================================================================
Opened log '/Users/pabloparedes/Library/FS2_Open/data/fs2_open.log', Sun Jun 30 22:31:54 2013 ...
FreeSpace 2 Open version: 3.6.17.9465
Passed cmdline options:
  -spec_exp 15
  -ogl_spec 20
  -spec_static 1.5
  -spec_point 1.2
  -spec_tube 1.5
  -ambient_factor 35
  -missile_lighting
  -3dshockwave
  -soft_particles
  -post_process
  -fxaa
  -ballistic_gauge
  -dualscanlines
  -orbradar
  -rearm_timer
  -targetinfo
  -3dwarp
  -ship_choice_3d
  -weapon_choice_3d
  -warp_flash
  -snd_preload
  -mod blueplanet2,blueplanet,mediavps_3612
  -mipmap
  -window
  -fullscreen_window
  -nograb
  -spec
  -glow
  -normal
  -env
Deprecated flag '-spec' found. Please remove from your cmdline.
Deprecated flag '-glow' found. Please remove from your cmdline.
Deprecated flag '-normal' found. Please remove from your cmdline.
Deprecated flag '-env' found. Please remove from your cmdline.
Building file index...
Found root pack '/Applications/FreeSpace2/blueplanet2/adv-bp2.vp' with a checksum of 0x4d6319c8
Found root pack '/Applications/FreeSpace2/blueplanet2/bp2-audio1.vp' with a checksum of 0x4f978a6b
Found root pack '/Applications/FreeSpace2/blueplanet2/bp2-core.vp' with a checksum of 0x64e738b9
Found root pack '/Applications/FreeSpace2/blueplanet2/bp2-visuals1.vp' with a checksum of 0xbaa4dbd6
Found root pack '/Applications/FreeSpace2/blueplanet2/bp2-visuals2.vp' with a checksum of 0x9689af32
Found root pack '/Applications/FreeSpace2/blueplanet/adv-bp.vp' with a checksum of 0x07c8f9a5
Found root pack '/Applications/FreeSpace2/blueplanet/bp-audio1.vp' with a checksum of 0x0dc57722
Found root pack '/Applications/FreeSpace2/blueplanet/bp-audio2.vp' with a checksum of 0xca5604a6
Found root pack '/Applications/FreeSpace2/blueplanet/bp-core.vp' with a checksum of 0x099138b1
Found root pack '/Applications/FreeSpace2/blueplanet/bp-visuals1.vp' with a checksum of 0x31c7316a
Found root pack '/Applications/FreeSpace2/blueplanet/bp-visuals2.vp' with a checksum of 0x4eedd84a
Found root pack '/Applications/FreeSpace2/mediavps_3612/MV_Advanced.vp' with a checksum of 0x4b8b0f5a
Found root pack '/Applications/FreeSpace2/mediavps_3612/MV_AnimGlows.vp' with a checksum of 0x6a554026
Found root pack '/Applications/FreeSpace2/mediavps_3612/MV_Assets.3612.vp' with a checksum of 0x59649c21
Found root pack '/Applications/FreeSpace2/mediavps_3612/MV_Assets.vp' with a checksum of 0x529cc70f
Found root pack '/Applications/FreeSpace2/mediavps_3612/MV_Effects.3612.vp' with a checksum of 0x9c510aa0
Found root pack '/Applications/FreeSpace2/mediavps_3612/MV_Effects.vp' with a checksum of 0xb9a9a485
Found root pack '/Applications/FreeSpace2/mediavps_3612/MV_Music.vp' with a checksum of 0xb3e21469
Found root pack '/Applications/FreeSpace2/mediavps_3612/MV_RadarIcons.vp' with a checksum of 0x31dd7781
Found root pack '/Applications/FreeSpace2/mediavps_3612/MV_Root.vp' with a checksum of 0x6ffd5c78
Found root pack '/Applications/FreeSpace2/root_fs2.vp' with a checksum of 0xce10d76c
Found root pack '/Applications/FreeSpace2/smarty_fs2.vp' with a checksum of 0xddeb3b1e
Found root pack '/Applications/FreeSpace2/sparky_fs2.vp' with a checksum of 0x164fe65a
Found root pack '/Applications/FreeSpace2/sparky_hi_fs2.vp' with a checksum of 0xa11d56f1
Found root pack '/Applications/FreeSpace2/stu_fs2.vp' with a checksum of 0xd77da83a
Found root pack '/Applications/FreeSpace2/tango1_fs2.vp' with a checksum of 0x4c25221e
Found root pack '/Applications/FreeSpace2/tango2_fs2.vp' with a checksum of 0x86920b82
Found root pack '/Applications/FreeSpace2/tango3_fs2.vp' with a checksum of 0x705e8d71
Found root pack '/Applications/FreeSpace2/warble_fs2.vp' with a checksum of 0xd85c305d
Searching root '/Users/pabloparedes/Library/FS2_Open/blueplanet2/' ... 3 files
Searching root '/Users/pabloparedes/Library/FS2_Open/blueplanet/' ... 2 files
Searching root '/Users/pabloparedes/Library/FS2_Open/mediavps_3612/' ... 2 files
Searching root '/Users/pabloparedes/Library/FS2_Open/' ... 2 files
Searching root '/Applications/FreeSpace2/blueplanet2/' ... 0 files
Searching root pack '/Applications/FreeSpace2/blueplanet2/adv-bp2.vp' ... 33 files
Searching root pack '/Applications/FreeSpace2/blueplanet2/bp2-audio1.vp' ... 243 files
Searching root pack '/Applications/FreeSpace2/blueplanet2/bp2-core.vp' ... 92 files
Searching root pack '/Applications/FreeSpace2/blueplanet2/bp2-visuals1.vp' ... 682 files
Searching root pack '/Applications/FreeSpace2/blueplanet2/bp2-visuals2.vp' ... 2480 files
Searching root '/Applications/FreeSpace2/blueplanet/' ... 0 files
Searching root pack '/Applications/FreeSpace2/blueplanet/adv-bp.vp' ... 358 files
Searching root pack '/Applications/FreeSpace2/blueplanet/bp-audio1.vp' ... 41 files
Searching root pack '/Applications/FreeSpace2/blueplanet/bp-audio2.vp' ... 683 files
Searching root pack '/Applications/FreeSpace2/blueplanet/bp-core.vp' ... 47 files
Searching root pack '/Applications/FreeSpace2/blueplanet/bp-visuals1.vp' ... 400 files
Searching root pack '/Applications/FreeSpace2/blueplanet/bp-visuals2.vp' ... 1561 files
Searching root '/Applications/FreeSpace2/mediavps_3612/' ... 0 files
Searching root pack '/Applications/FreeSpace2/mediavps_3612/MV_Advanced.vp' ... 1283 files
Searching root pack '/Applications/FreeSpace2/mediavps_3612/MV_AnimGlows.vp' ... 1641 files
Searching root pack '/Applications/FreeSpace2/mediavps_3612/MV_Assets.3612.vp' ... 315 files
Searching root pack '/Applications/FreeSpace2/mediavps_3612/MV_Assets.vp' ... 1527 files
Searching root pack '/Applications/FreeSpace2/mediavps_3612/MV_Effects.3612.vp' ... 10 files
Searching root pack '/Applications/FreeSpace2/mediavps_3612/MV_Effects.vp' ... 1876 files
Searching root pack '/Applications/FreeSpace2/mediavps_3612/MV_Music.vp' ... 32 files
Searching root pack '/Applications/FreeSpace2/mediavps_3612/MV_RadarIcons.vp' ... 24 files
Searching root pack '/Applications/FreeSpace2/mediavps_3612/MV_Root.vp' ... 94 files
Searching root '/Applications/FreeSpace2/' ... 15 files
Searching root pack '/Applications/FreeSpace2/root_fs2.vp' ... 157 files
Searching root pack '/Applications/FreeSpace2/smarty_fs2.vp' ... 10 files
Searching root pack '/Applications/FreeSpace2/sparky_fs2.vp' ... 3027 files
Searching root pack '/Applications/FreeSpace2/sparky_hi_fs2.vp' ... 1337 files
Searching root pack '/Applications/FreeSpace2/stu_fs2.vp' ... 2355 files
Searching root pack '/Applications/FreeSpace2/tango1_fs2.vp' ... 32 files
Searching root pack '/Applications/FreeSpace2/tango2_fs2.vp' ... 15 files
Searching root pack '/Applications/FreeSpace2/tango3_fs2.vp' ... 10 files
Searching root pack '/Applications/FreeSpace2/warble_fs2.vp' ... 52 files
Found 37 roots and 20441 files.
ERROR: Unknown Language Checksum: -1162327434
Using default language settings...
Setting language to English
TBM  =>  Starting parse of 'mv_core-lcl.tbm' ...
Initializing OpenAL...
  OpenAL Vendor     : Apple Computer Inc.
  OpenAL Renderer   : Software
  OpenAL Version    : 1.1

  Found extension "AL_EXT_float32".

  Sample rate: 0 (44100)
  EFX enabled: NO
  Playback device: Built-in Output
  Capture device: Built-in Microphone
... OpenAL successfully initialized!
Failed to init speech
Initializing OpenGL graphics device at 1680x1050 with 32-bit color...
  Initializing SDL...
  Requested SDL Video values = R: 8, G: 8, B: 8, depth: 24, stencil: 8, double-buffer: 1, FSAA: 32
  Actual SDL Video values    = R: 8, G: 8, B: 8, depth: 24, stencil: 8, double-buffer: 1, FSAA: 8
  OpenGL Vendor    : ATI Technologies Inc.
  OpenGL Renderer  : AMD Radeon HD 6770M OpenGL Engine
  OpenGL Version   : 2.1 ATI-7.32.12

  Using extension "GL_EXT_fog_coord".
  Using extension "GL_ARB_multitexture".
  Using extension "GL_ARB_texture_env_add".
  Using extension "GL_ARB_texture_compression".
  Using extension "GL_EXT_texture_compression_s3tc".
  Using extension "GL_EXT_texture_filter_anisotropic".
  Using extension "GL_ARB_texture_env_combine".
  Unable to find extension "GL_EXT_compiled_vertex_array".
  Using extension "GL_EXT_draw_range_elements".
  Using extension "GL_ARB_texture_mirrored_repeat".
  Using extension "GL_ARB_texture_non_power_of_two".
  Using extension "GL_ARB_vertex_buffer_object".
  Using extension "GL_ARB_pixel_buffer_object".
  Using extension "GL_SGIS_generate_mipmap".
  Using extension "GL_EXT_framebuffer_object".
  Using extension "GL_ARB_texture_rectangle".
  Using extension "GL_EXT_bgra".
  Using extension "GL_ARB_texture_cube_map".
  Using extension "GL_EXT_texture_lod_bias".
  Using extension "GL_ARB_point_sprite".
  Using extension "GL_ARB_shading_language_100".
  Using extension "GL_ARB_shader_objects".
  Using extension "GL_ARB_vertex_shader".
  Using extension "GL_ARB_fragment_shader".
  Using extension "GL_ARB_shader_texture_lod".
  Using extension "GL_ARB_texture_float".
  Using extension "GL_ARB_draw_elements_base_vertex".
  Using extension "GL_EXT_framebuffer_blit".
  Using extension "GL_EXT_geometry_shader4".
  Using extension "GL_EXT_texture_array".

Compiling new shader:
   Loading built-in default shader for: soft-v.sdr
   Loading built-in default shader for: soft-f.sdr
Shader features:
   Depth-blended Particles
Compiling new shader:
   Loading built-in default shader for: soft-v.sdr
   Loading built-in default shader for: soft-f.sdr
Shader features:
   Distorted Particles
Compiling deferred light shader...
   Loading built-in default shader for: deferred-v.sdr
   Loading built-in default shader for: deferred-f.sdr
Fragment shader failed to compile:
ERROR: 0:11: Invalid qualifiers 'in' in global variable context
ERROR: 0:13: Invalid qualifiers 'in' in global variable context
ERROR: 0:37: Use of undeclared identifier 'lightposition'
ERROR: 0:38: Use of undeclared identifier 'lightDir'
ERROR: 0:39: Use of undeclared identifier 'dist'
ERROR: 0:42: Use of undeclared identifier 'lightDir'
ERROR: 0:44: Use of undeclared identifier 'conedot'
ERROR: 0:47: Use of undeclared identifier 'attenuation'
ERROR: 0:47: Use of undeclared identifier 'conedot'
ERROR: 0:49: Use of undeclared identifier 'conedot'
ERROR: 0:52: Use of undeclared identifier 'attenuation'
ERROR: 0:52: Use of undeclared identifier 'conedot'
ERROR: 0:55: Use of undeclared identifier 'dist'
ERROR: 0:63: Use of undeclared identifier 'beamvec'
ERROR: 0:64: Use of undeclared identifier 'beamvec'
ERROR: 0:64: Use of undeclared identifier 'beamlength'
ERROR: 0:66: Use of undeclared identifier 'lightDir'
ERROR: 0:66: Use of undeclared identifier 'beamDir'
ERROR: 0:66: Use of undeclared identifier 'beamlength'
ERROR: 0:69: Use of undeclared identifier 'lightposition'
ERROR: 0:69: Use of undeclared identifier 'beamDir'
ERROR: 0:69: Use of undeclared identifier 'neardist'
ERROR: 0:70: Use of undeclared identifier 'lightDir'
ERROR: 0:70: Use of undeclared identifier 'nearest'
ERROR: 0:71: Use of undeclared identifier 'dist'
ERROR: 0:71: Use of undeclared identifier 'lightDir'
ERROR: 0:72: Use of undeclared identifier 'dist'
ERROR: 0:75: Use of undeclared identifier 'lightDir'
ERROR: 0:75: Use of undeclared identifier 'dist'
ERROR: 0:76: Use of undeclared identifier 'lightDir'
ERROR: 0:77: Use of undeclared identifier 'half_vec'
ERROR: 0:78: Use of undeclared identifier 'lightDir'
ERROR: 0:78: Use of undeclared identifier 'attenuation'
ERROR: 0:79: Use of undeclared identifier 'NdotHV'
ERROR: 0:79: Use of undeclared identifier 'attenuation'

ERROR! Unable to create fragment shader!
  Shader in_error!  Disabling GLSL model rendering!

  Compiling post-processing shader 1 ...
   Loading built-in default shader for: post-v.sdr
   Loading built-in default shader for: post-f.sdr
  Compiling post-processing shader 2 ...
   Loading built-in default shader for: post-v.sdr
   Loading built-in default shader for: blur-f.sdr
  Compiling post-processing shader 3 ...
   Loading built-in default shader for: post-v.sdr
   Loading built-in default shader for: blur-f.sdr
  Compiling post-processing shader 4 ...
   Loading built-in default shader for: post-v.sdr
   Loading built-in default shader for: brightpass-f.sdr
  Compiling post-processing shader 5 ...
   Loading built-in default shader for: fxaa-v.sdr
   Loading built-in default shader for: fxaa-f.sdr
  Compiling post-processing shader 6 ...
   Loading built-in default shader for: post-v.sdr
   Loading built-in default shader for: fxaapre-f.sdr
  Compiling post-processing shader 7 ...
   Loading built-in default shader for: post-v.sdr
   Loading built-in default shader for: ls-f.sdr
  Compiling post-processing shader 8 ...
   Loading built-in default shader for: shadowdebug-v.sdr
   Loading built-in default shader for: shadowdebug-f.sdr

  Max texture units: 8 (16)
  Max elements vertices: 1048575
  Max elements indices: 150000
  Max texture size: 16384x16384
  Max render buffer size: 16384x16384
  Can use compressed textures: YES
  Texture compression available: YES
  Post-processing enabled: YES
  Using bilinear texture filter.
  OpenGL Shader Version: 1.20
... OpenGL init is complete!
Size of bitmap info = 816 KB
Size of bitmap extra info = 48 bytes
ANI cursorweb with size 24x24 (25.0% wasted)
GRAPHICS: Initializing default colors...
Game Settings Table: Using Standard Loops For SEXP Arguments
Game Settings Table: Using standard event chaining behavior
Game Settings Table: External shaders are DISABLED
SCRIPTING: Beginning initialization sequence...
SCRIPTING: Beginning Lua initialization...
LUA: Opening LUA state...
LUA: Initializing base Lua libraries...
LUA: Beginning ADE initialization
ADE: Initializing enumeration constants...
ADE: Assigning Lua session...
SCRIPTING: Beginning main hook parse sequence....
Wokka!  Error opening file (scripting.tbl)!
TABLES: Unable to parse 'scripting.tbl'!  Error code = 5.
TBM  =>  Starting parse of 'mv_flak-sct.tbm' ...
TBM  =>  Starting parse of 'mv_dbrs-sct.tbm' ...
TBM  =>  Starting parse of 'mv_exp-sct.tbm' ...
TBM  =>  Starting parse of 'bp2-turretHotkey-sct.tbm' ...
TBM  =>  Starting parse of 'bp2-trigger-sct.tbm' ...
TBM  =>  Starting parse of 'bp2-tcard-sct.tbm' ...
TBM  =>  Starting parse of 'bp2-stupid-sct.tbm' ...
TBM  =>  Starting parse of 'bp2-equip-sct.tbm' ...
TBM  =>  Starting parse of 'bp2-debrisgrav-sct.tbm' ...
TBM  =>  Starting parse of 'bp2-csc-sct.tbm' ...
TBM  =>  Starting parse of 'bp2-betty-sct.tbm' ...
SCRIPTING: Inititialization complete.
SCRIPTING: Splash screen overrides checked
SCRIPTING: Splash hook has been run
SCRIPTING: Splash screen conditional hook has been run
Using high memory settings...
Wokka!  Error opening file (interface.tbl)!
WMCGUI: Unable to parse 'interface.tbl'!  Error code = 5.
TBM  =>  Starting parse of 'mv_effects-sdf.tbm' ...
TBM  =>  Starting parse of 'bp-sdf.tbm' ...
Dutifully ignoring the extra sound values for retail sound 36, 'l_hit.wav'...
Dutifully ignoring the extra sound values for retail sound 37, 'm_hit.wav'...
No joysticks found
Current soundtrack set to -1 in event_music_reset_choices
TBM  =>  Starting parse of 'mv_music-mus.tbm' ...
TBM  =>  Starting parse of 'bp-mus.tbm' ...
TBM  =>  Starting parse of 'bp2-mus.tbm' ...
TABLES => Starting parse of 'colors.tbl'...
TBM  =>  Starting parse of 'mv_effects-mfl.tbm' ...
TBM  =>  Starting parse of 'bp-mfl.tbm' ...
TBM  =>  Starting parse of 'bp2-mfl.tbm' ...
Wokka!  Error opening file (armor.tbl)!
TABLES: Unable to parse 'armor.tbl'!  Error code = 5.
TBM  =>  Starting parse of 'mv_effects-amr.tbm' ...
TBM  =>  Starting parse of 'bp2-amr.tbm' ...
TBM  =>  Starting parse of 'bp-aip.tbm' ...
TBM  =>  Starting parse of 'bp2-aip.tbm' ...
Warning: "$perform less checks for death screams" flag is deprecated in favor of "$perform fewer checks for death screams"
Warning: "$allow primary link delay" flag is deprecated in favor of "$allow primary link at mission start"
TBM  =>  Starting parse of 'mv_effects-wxp.tbm' ...
TBM  =>  Starting parse of 'bp-wxp.tbm' ...
TBM  =>  Starting parse of 'bp2-wxp.tbm' ...
BMPMAN: Found EFF (exp20.eff) with 75 frames at 20 fps.
BMPMAN: Found EFF (ExpMissileHit1.eff) with 92 frames at 20 fps.
BMPMAN: Found EFF (exp04.eff) with 49 frames at 22 fps.
BMPMAN: Found EFF (exp05.eff) with 93 frames at 20 fps.
BMPMAN: Found EFF (exp06.eff) with 92 frames at 22 fps.
BMPMAN: Found EFF (capflash.eff) with 40 frames at 10 fps.
BMPMAN: Found EFF (Maxim_Impact.eff) with 23 frames at 30 fps.
ANI Lamprey_Impact with size 80x80 (37.5% wasted)
BMPMAN: Found EFF (explo3.eff) with 48 frames at 22 fps.
BMPMAN: Found EFF (HFlakExp.eff) with 48 frames at 22 fps.
BMPMAN: Found EFF (exp06b.eff) with 92 frames at 22 fps.
BMPMAN: Found EFF (bomb_flare.eff) with 69 frames at 20 fps.
BMPMAN: Found EFF (exp50.eff) with 92 frames at 30 fps.
TBM  =>  Starting parse of 'mv_core-wep.tbm' ...
TBM  =>  Starting parse of 'mv_effects-wep.tbm' ...
TBM  =>  Starting parse of 'mv_assets-wep.tbm' ...
TBM  =>  Starting parse of 'bp-wep.tbm' ...
TBM  =>  Starting parse of 'bp2-wep.tbm' ...
Ignoring free flight speed for weapon 'Trebuchet#Aegis'
TBM  =>  Starting parse of 'mv_effects-obt.tbm' ...
TBM  =>  Starting parse of 'bp2-obt.tbm' ...
TBM  =>  Starting parse of 'mv_core-shp.tbm' ...
TBM  =>  Starting parse of 'radar-shp.tbm' ...
TBM  =>  Starting parse of 'mv_effects-shp.tbm' ...
TBM  =>  Starting parse of 'mv_assets-shp.tbm' ...
TBM  =>  Starting parse of 'bp-shp.tbm' ...
TBM  =>  Starting parse of 'bp2-shp.tbm' ...
The "primary_bank" animation type name is deprecated.  Specify "primary-bank" instead.
The "primary_bank" animation type name is deprecated.  Specify "primary-bank" instead.
The "primary_bank" animation type name is deprecated.  Specify "primary-bank" instead.
The "primary_bank" animation type name is deprecated.  Specify "primary-bank" instead.
The "primary_bank" animation type name is deprecated.  Specify "primary-bank" instead.
The "primary_bank" animation type name is deprecated.  Specify "primary-bank" instead.
The "primary_bank" animation type name is deprecated.  Specify "primary-bank" instead.
The "primary_bank" animation type name is deprecated.  Specify "primary-bank" instead.
The "primary_bank" animation type name is deprecated.  Specify "primary-bank" instead.
Particle effect for impact spew disabled on ship 'Moon Landscape'.
Particle effect for damage spew disabled on ship 'Moon Landscape'.
Particle effect for impact spew disabled on ship 'The GRID'.
Particle effect for damage spew disabled on ship 'The GRID'.
TBM  =>  Starting parse of 'mv_core-hdg.tbm' ...
TBM  =>  Starting parse of 'mv_root-hdg.tbm' ...
ANI support1 with size 108x24 (25.0% wasted)
ANI damage1 with size 148x25 (21.9% wasted)
ANI wingman1 with size 71x53 (17.2% wasted)
ANI wingman2 with size 35x53 (17.2% wasted)
ANI wingman3 with size 14x53 (17.2% wasted)
ANI toggle1 with size 57x20 (37.5% wasted)
ANI head1 with size 164x132 (48.4% wasted)
ANI weapons1 with size 126x20 (37.5% wasted)
ANI weapons1_b with size 150x20 (37.5% wasted)
ANI objective1 with size 149x21 (34.4% wasted)
ANI energy1 with size 12x41 (35.9% wasted)
ANI targetview1 with size 137x156 (39.1% wasted)
ANI targetview2 with size 4x96 (25.0% wasted)
ANI targetview3 with size 7x20 (37.5% wasted)
ANI 2_radar1 with size 209x170 (33.6% wasted)
ANI 2_energy2 with size 86x96 (25.0% wasted)
ANI 2_reticle1 with size 40x24 (25.0% wasted)
ANI targhit1 with size 31x21 (34.4% wasted)
ANI 2_leftarc with size 103x252 (1.6% wasted)
ANI 2_rightarc1 with size 103x252 (1.6% wasted)
ANI 2_toparc2 with size 35x24 (25.0% wasted)
ANI 2_toparc3 with size 41x29 (9.4% wasted)
ANI netlag1 with size 29x30 (6.2% wasted)
ANI 2_lead1 with size 26x26 (18.8% wasted)
ANI 2_lock1 with size 56x53 (17.2% wasted)
ANI 2_lockspin with size 100x100 (21.9% wasted)
ANI time1 with size 47x23 (28.1% wasted)
BMPMAN: Found EFF (BPstealthgauge.eff) with 3 frames at 30 fps.
BMPMAN: Found EFF (viewfinder.eff) with 1 frames at 30 fps.
BMPMAN: Found EFF (BPsignalgaugetop.eff) with 1 frames at 30 fps.
BMPMAN: Found EFF (BPsignalgauge.eff) with 11 frames at 30 fps.
TBM  =>  Starting parse of 'mv_effects-str.tbm' ...
TBM  =>  Starting parse of 'bp-str.tbm' ...
TBM  =>  Starting parse of 'bp2-str.tbm' ...
loading animated cursor "cursor"
TBM  =>  Starting parse of 'bp-main-hall.tbm' ...
TBM  =>  Starting parse of 'bp2-main-hall.tbm' ...
MediaVPs: Flaming debris script loaded!
MediaVPs: Explosions script loaded!
Ships.tbl is : VALID
Weapons.tbl is : VALID
cfile_init() took 1413
Compiling video-processing shader ...
   Loading built-in default shader for: video-v.sdr
   Loading built-in default shader for: video-f.sdr
Got event GS_EVENT_GAME_INIT (49) in state NOT A VALID STATE (0)
SOUND: /Users/rhyskidd/Documents/Coding/fs2open/antipodes/projects/Xcode4/../../code/sound/ds.cpp:693 - OpenAL error = 'Invalid Name'
PLR => Verifying 'Alpha 1.plr' with version 1...
PLR => Parsing:  Flags...
PLR => Verifying complete!
PLR => Verifying 'Eagle 1oh7.plr' with version 1...
PLR => Parsing:  Flags...
PLR => Verifying complete!
PLR => Verifying 'Omega 1.plr' with version 0...
PLR => Parsing:  Flags...
PLR => Verifying complete!
PLR => Verifying 'Skull 1.plr' with version 0...
PLR => Parsing:  Flags...
PLR => Verifying complete!
Got event GS_EVENT_MAIN_MENU (0) in state GS_STATE_INITIAL_PLAYER_SELECT (37)
PLR => Loading 'Omega 1.plr' with version 0...
PLR => Parsing:  Flags...
PLR => Parsing:  Info...
PLR => Parsing:  Scoring...
PLR => Parsing:  ScoringMulti...
PLR => Parsing:  HUD...
PLR => Parsing:  Variables...
PLR => Parsing:  Multiplayer...
PLR => Parsing:  Controls...
PLR => Parsing:  Settings...
Someone passed an extension to bm_load for file 'hammer1.pcx'
PLR => Loading complete!
CSG => Loading 'Omega 1.bp2-p2.csg' with version 0...
CSG => Parsing:  Flags...
CSG => Parsing:  Info...
CSG => Parsing:  Missions...
CSG => Parsing:  Techroom...
CSG => Parsing:  Loadout...
CSG => Parsing:  Scoring...
CSG => Parsing:  RedAlert...
CSG => Parsing:  HUD...
CSG => Parsing:  Variables...
CSG => Parsing:  Settings...
CSG => Parsing:  Controls...
CSG => Parsing:  Cutscenes...
CSG => Loading complete!
CSG => Loading 'Omega 1.bp2-p2.csg' with version 0...
CSG => Parsing:  Flags...
CSG => Parsing:  Info...
CSG => Parsing:  Missions...
CSG => Parsing:  Techroom...
CSG => Parsing:  Loadout...
CSG => Parsing:  Scoring...
CSG => Parsing:  RedAlert...
CSG => Parsing:  HUD...
CSG => Parsing:  Variables...
CSG => Parsing:  Settings...
CSG => Parsing:  Controls...
CSG => Parsing:  Cutscenes...
CSG => Loading complete!
Got event GS_EVENT_QUIT_GAME (5) in state GS_STATE_MAIN_MENU (1)
PLR => Saving 'Omega 1.plr' with version 0...
PLR => Saving:  Flags...
PLR => Saving:  Info...
PLR => Saving:  Scoring...
PLR => Saving:  ScoringMulti...
PLR => Saving:  HUD...
PLR => Saving:  Variables...
PLR => Saving:  Multiplayer...
PLR => Saving:  Controls...
PLR => Saving:  Settings...
PLR => Saving complete!
CSG => Saving 'Omega 1.bp2-p2.csg' with version 0...
CSG => Saving:  Flags...
CSG => Saving:  Info...
CSG => Saving:  Missions...
CSG => Saving:  Techroom...
CSG => Saving:  Loadout...
CSG => Saving:  Scoring...
CSG => Saving:  RedAlert...
CSG => Saving:  HUD...
CSG => Saving:  Variables...
CSG => Saving:  Settings...
CSG => Saving:  Controls...
CSG => Saving:  Cutscenes...
CSG => Saving complete!
Freeing all existing models...
... Log closed, Sun Jun 30 22:32:10 2013

 

Offline The E

  • He's Ebeneezer Goode
  • Global Moderator
  • 213
  • Nothing personal, just tech support.
    • Steam
    • Twitter
Re: The BP Compatibility package
Code: [Select]
Initializing OpenGL graphics device at 1680x1050 with 32-bit color...
  Initializing SDL...
  Requested SDL Video values = R: 8, G: 8, B: 8, depth: 24, stencil: 8, double-buffer: 1, FSAA: 32
  Actual SDL Video values    = R: 8, G: 8, B: 8, depth: 24, stencil: 8, double-buffer: 1, FSAA: 8
  OpenGL Vendor    : ATI Technologies Inc.
  OpenGL Renderer  : AMD Radeon HD 6770M OpenGL Engine
  OpenGL Version   : 2.1 ATI-7.32.12

That can't be right. That GPU can support OpenGL up to version 4 with proper drivers (read: Windows and closed-source Linux/Unix). If you can, I would suggest updating; as it is, you will need to use the BP compatibility pack and the official 3.7.0RC build of FSO.
Let there be light
Let there be moon
Let there be stars and let there be you
Let there be monsters and let there be pain
Let us begin to feel again
--Devin Townsend, Genesis

 
Re: The BP Compatibility package
Code: [Select]
Initializing OpenGL graphics device at 1680x1050 with 32-bit color...
  Initializing SDL...
  Requested SDL Video values = R: 8, G: 8, B: 8, depth: 24, stencil: 8, double-buffer: 1, FSAA: 32
  Actual SDL Video values    = R: 8, G: 8, B: 8, depth: 24, stencil: 8, double-buffer: 1, FSAA: 8
  OpenGL Vendor    : ATI Technologies Inc.
  OpenGL Renderer  : AMD Radeon HD 6770M OpenGL Engine
  OpenGL Version   : 2.1 ATI-7.32.12

That can't be right. That GPU can support OpenGL up to version 4 with proper drivers (read: Windows and closed-source Linux/Unix). If you can, I would suggest updating; as it is, you will need to use the BP compatibility pack and the official 3.7.0RC build of FSO.

Oh yeah, I'm running OSX Lion, last I checked my hardware drivers are up-to-date.