Author Topic: 32-Bit Video Depth - Resolution Problem  (Read 1323 times)

0 Members and 1 Guest are viewing this topic.

32-Bit Video Depth - Resolution Problem
Hello,
Did quite a bit of searching, but no joy.

The display of FreeSpace Open is larger than the my actual monitor whenever I have 32-bit Video Depth selected. Hard to explain so I attached a picture where you can see the game is larger than my monitor with most of it cut out.

This happens regardless of the resolution set in the launcher option 1920 x 1080 (my native display), 1600 x 900 etc. It only displays properly if I select 16-bit Video Depth. This happens all with FS2 / Diaspora / Wing Commander.

Using Directx instead of OpenGL also fixes the issue, but Diaspora and WC only run with OpenGL AFAIK. Wing Commander doesn't even have an option for 16-bit Video Depth, so I can't run it.

How can I run with 32-bit Video Depth selected and have proper display?

Using a Geforce 570 with latest drivers in Win 7.

Thanks for any help!






[attachment deleted by ninja]
« Last Edit: September 29, 2013, 10:30:47 pm by Capt. Crunch »

 

Offline niffiwan

  • 211
  • Eluder Class
Re: 32-Bit Video Depth - Resolution Problem
Please post your fs2_open.log file.  Instructions on how to do this can be found in this post.
Creating a fs2_open.log | Red Alert Bug = Hex Edit | MediaVPs 2014: Bigger HUD gauges | 32bit libs for 64bit Ubuntu
----
Debian Packages (testing/unstable): Freespace2 | wxLauncher
----
m|m: I think I'm suffering from Stockholm syndrome. Bmpman is starting to make sense and it's actually written reasonably well...

 
Re: 32-Bit Video Depth - Resolution Problem
Busy at work today, but here is the log. Thanks for taking a look!



[attachment deleted by ninja]

 

Offline niffiwan

  • 211
  • Eluder Class
Re: 32-Bit Video Depth - Resolution Problem
No worries :)

Could you try removing these two command line options in the launcher?

Code: [Select]
  -mipmap
  -window

-mipmap isn't required anymore and can even cause issues on certain systems.
-window may be what's causing your problem, if you want a run in a window at your monitors native resolution I'd suggest trying -fullscreen_window

If removing them doesn't work, can you post another log, this time with 32bit colour selected in the launcher?
Creating a fs2_open.log | Red Alert Bug = Hex Edit | MediaVPs 2014: Bigger HUD gauges | 32bit libs for 64bit Ubuntu
----
Debian Packages (testing/unstable): Freespace2 | wxLauncher
----
m|m: I think I'm suffering from Stockholm syndrome. Bmpman is starting to make sense and it's actually written reasonably well...

 
Re: 32-Bit Video Depth - Resolution Problem
Hi again niffiwan ,

I had the window setting on as that's what it described to do in the post yoy linked to generate a fs2_open.log file. Regardless, I removed it and mipmapping, as well as selected 32 bit. Sorry. I thought I had 32 bit selected previously. doh!

I really appreciate the help. Long time Freespace fan and just only now trying Diaspora. Even in 16-bit it plays great with Trackir!

P.s. If you ever need help with the DCS World sim let me know, and I will return the troubleshooting help :)

[attachment deleted by ninja]

 
Re: 32-Bit Video Depth - Resolution Problem
Bump for any help. Thanks

 

Offline jg18

  • A very happy zod
  • 210
  • can do more than spellcheck
Re: 32-Bit Video Depth - Resolution Problem
I'm not an expert with reading debug logs or FS2 Open graphics in general, but some thoughts:

- I take it that you have Windows configured in the Control Panel to use 32-bit color?

- Get the Diaspora 1.0.4 patch. Unlikely to help, but couldn't hurt.

- Does the "display too big" problem occur when you're in a mission, not just when you're looking at the in-game menus? I figure the answer is "yes" but it never hurts to double-check.

- Do you have a multi-monitor setup? If so, make sure to set the primary monitor (the one where the taskbar/start button appear) to the one you want to use for playing. You may even want to consider unplugging the other monitors for the purposes for playing, just to make sure that's not causing the problem.

- The debug log's checksum for your Diaspora movies.vp file doesn't match mine (0x10d8b681). I wonder if your download is corrupt. Try getting MD5 and SHA1 checksums of your Diaspora installer .exe and compare them to the official checksums in the first post of the release thread. I'm not too familiar with Windows utilities, but there's one from Microsoft that's command line only, if you're comfortable with the command line. I know it works on Windows 7 because I just tested it. Use the -both command line option with fciv.exe to get both MD5 and SHA1 checksums. Also make sure that the size of your installer file matches the size listed in the release thread with the checksums. Then again, if the issue occurs with FS2 retail as well, file corruption probably isn't the cause.

- If none of those help, maybe try unchecking all of the flags in the launcher's advanced settings page to make sure that none of those are causing the problem. You may need to change the selected option in the lighting presets box from "Diaspora recommended" to "Presets off".

Hope this helps.

 

Offline jr2

  • The Mail Man
  • 212
  • It's prounounced jayartoo 0x6A7232
    • Steam
Re: 32-Bit Video Depth - Resolution Problem
For the hash generation, if you don't want to bother with command line, use Hash Tab (Windows and Mac OSX).

http://implbits.com/HashTab.aspx

 
Re: 32-Bit Video Depth - Resolution Problem
This is a weird issue to be sure. Wish I could figure it out. The thing is this happens to my installs of Freespace 2, Wing Commander and Diaspora, so I don't believe the issue is related to corrupt files.

This "display too big" problem happens in the menu and in game. Thanks for help, but I am stumped.

 

Offline Yarn

  • 210
Re: 32-Bit Video Depth - Resolution Problem
Double-check that your desktop resolution is set to 1920x1080. It's possible that your desktop resolution is lower and that your system is not changing the resolution properly in 32-bit color mode.

While the game is running in 32-bit mode, open your monitor's menu and check the resolution. Does it say "1920x1080"? Also make sure that your monitor is using a digital video connection (i.e., anything other than VGA) if possible.
"Your fighter is running out of oil.  Please check under the hood and add more if necessary"
--strings.tbl, entry 177

"Freespace is very tired.  It is shutting down to get some rest."
--strings.tbl, entry 178

 
Re: 32-Bit Video Depth - Resolution Problem
Thanks again for all the suggestions and trying to help!

I found the issue was with having a DPI setting in Win7 of greater than 100%. I had this set higher as I use my 59" Plasma from the couch sometimes. Using the compatibility setting in Win7 by right clicking on the shortcut for the launcher and selecting the option, 'Disable display scaling on high DPI settings' fixed the issue.

I actually found the solution in these forums when I searched for another issue I had, the Play button in the launcher disappearing.

I am so glad their is this forum, community and modders that keep this alive. Since there is not one space sim that offers this gameplay. Thanks to every one here!!! Time to frag some toasters!