Author Topic: - Reporting Numerous Bugs and Issues!  (Read 833 times)

0 Members and 1 Guest are viewing this topic.

- Reporting Numerous Bugs and Issues!
( I think this bug report thread should be place here )

Hi. I'm having another play run on the Age of Aquarius campaign. And I'm encountering lots of bugs that I didn't encounter on other playthrough.

So first bug:
Universal Truth
bp-21.fs2

I just completed this mission, and I think it was about when it showed the last cutscene where Shiva jumps out after being told Shiva was banished from the great council formed in the first time, the game crashed and I got this information.
I'm running this on fs2_open_3_7_1_SSE2_BP.exe
It's impossible for me to start the next mission now since it always crashes now.

Red Alert: asked to delete ship (Alpha 4) with invalid ship state (0)
ntdll.dll! ZwWaitForSingleObject + 21 bytes
KERNEL32.dll! WaitForSingleObjectEx + 67 bytes
KERNEL32.dll! WaitForSingleObject + 18 bytes
fs2_open_3_7_1_SSE2_BP.exe! <no symbol>
fs2_open_3_7_1_SSE2_BP.exe! <no symbol>
fs2_open_3_7_1_SSE2_BP.exe! <no symbol>
ntdll.dll! RtlDetermineDosPathNameType_U + 386 bytes


Second Issue:
On all the cutscenes in Age of Aquarius, i have HUGE framerate loss. Probably 1-2 fps and sometimes it freezes for 1-2 seconds. I've never had this before. I have quadcore cpu at 3.5ghz with 6950 1gb and 6gb RAM. I never have framerate drops. Never below 30fps.
Furthermore, the framerate only seem to drop like this at the cutscenes when I see the new capital ships from the GTD. Raynor, Titan class, etc.
I have most graphical features on maximum. Only these custom flags: -ambient_factor 5 -spec_exp 15 -spec_point 1.2 -spec_static 1.7 -spec_tube 1.5 -ogl_spec 50
And the graphics related flags I've got turned on are :
Apply Lightning to Missles
Enable 3D shockwaves
Enable post processing
Enable soft particles
Enable FXAA Anti-aliasing
Enable 3D Warp
Enable flash upon warp

Bug 3: The picture explains it all. Is there a fix for this? I know the flags to turn on this are "use 3D models for weapon selection" and by turning it off, sure. it's a "fix". But not really is it? I like to have it on, so is there an actual fix?


 

Offline The E

  • He's Ebeneezer Goode
  • 213
  • Nothing personal, just tech support.
    • Steam
    • Twitter
Re: - Reporting Numerous Bugs and Issues!
You can and should use the compatibility pack and regular nightly builds.
If I'm just aching this can't go on
I came from chasing dreams to feel alone
There must be changes, miss to feel strong
I really need lifе to touch me
--Evergrey, Where August Mourns

 

Offline General Battuta

  • Poe's Law In Action
  • 214
  • i wonder when my postcount will exceed my iq
Re: - Reporting Numerous Bugs and Issues!
Yeah, most of those will be solved by using a new build and the compatibility pack. First one sounds like it might be pilot corruption, alas.

 
Re: - Reporting Numerous Bugs and Issues!
OK. I will try nightly builds and compatibility pack, as well as creating a new pilot for the corrupted mission. And report back.

For the record, should I go to these threads then and download these nightly builds and compatibility packs?
http://www.hard-light.net/forums/index.php?topic=87233.0
http://www.hard-light.net/forums/index.php?topic=83606.0

 
Re: - Reporting Numerous Bugs and Issues!
I'm happy to announce that installing the compatibility pack, latest nightly build and creating a new pilot. All these issues were fixed.
The only thing I noticed changed after installing this were, in the menus and in-game HUD, my screen is no forced to 4:3 resolution so I got big black brackets at the sides. I guess before on the other build the menus and in-game HUD was forced to widescreen. So I guess 4:3 is correct. In-game 3D resolution is still correct resolution.

Thank you for your great work and help :)