Author Topic: wxlauncher unhandled error  (Read 3076 times)

0 Members and 1 Guest are viewing this topic.

wxlauncher unhandled error
When I set everything up in wxlauncher and hit play, I get this error at the bottom "Unhandled error in setting HKLM key in registry! Access is denied".  I tried going to the wxlauncher folder and hit the registry_helper.exe and it reads in a windows error panel "the resquired parameter '<operation>' was not specified". After I hit ok on that another registry_helper message panel says "wxlauncher registry tool usage: registry_helper.exe <operation> <file>".  Since I am computer brain dead, I have no idea what any of this means.  I did uninstall and reinstall.  Any help would be appreciated.  :confused:

 
Re: wxlauncher unhandled error
I forgot to mention I have windows8.1. I got it working by by going to wxlauncher.exe properties and running compatability, one of the options that i checked was "the program requires additional permissions".  I feel like this is kind of janky and there is probably a better way of going about this, but at least it works.

 

Offline jr2

  • The Mail Man
  • 212
  • It's prounounced jayartoo 0x6A7232
    • Steam
Re: wxlauncher unhandled error
Erm... run the wxlauncher as administrator (right-click > run as administrator) once, and that should allow wxlauncher to set the registry key.  Then after it's set you should be fine.

 

Offline zheega

  • 22
Re: wxlauncher unhandled error
I also get the same error all of a sudden. Yesterday all was well, but today I keep getting "unhanded error in setting HKLM in registry", even if I run wxlauncher as an administrator. I'm on Win10.

 

Offline The E

  • He's Ebeneezer Goode
  • Global Moderator
  • 213
  • Nothing personal, just tech support.
    • Steam
    • Twitter
Re: wxlauncher unhandled error
From the Support FAQ:

Launcher gives an error message "Cannot write to registry" (Launcher 5.5g) or "Unhandled error in setting HKLM key" (wxLauncher)
This error can happen on Windows 10. Here's how to fix it:

  • Step 1. Run the fs2.reg file from the steam version. If you do not have it, copy the following text into notepad and save it as fs2.reg, then doubleclick on it.
Code: [Select]
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Volition]

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Volition\FreeSpace2]
"EregCount"=dword:00000003
"Videocard"=hex(2):44,00,69,00,72,00,65,00,63,00,74,00,20,00,33,00,44,00,20,00,\
  2d,00,20,00,50,00,72,00,69,00,6d,00,61,00,72,00,79,00,20,00,44,00,69,00,73,\
  00,70,00,6c,00,61,00,79,00,20,00,44,00,72,00,69,00,76,00,65,00,72,00,20,00,\
  28,00,33,00,32,00,20,00,62,00,69,00,74,00,29,00,20,00,28,00,31,00,30,00,32,\
  00,34,00,78,00,37,00,36,00,38,00,29,00,00,00
"CmdLineOptions"=hex(2):00,00
"Interlaced Movies"=dword:00000000
"Movie Fast Clear"=dword:00000000
"D3DFast"=dword:00000000
"D3DTextureOrigin"=dword:00000001
"ForceWFOG"=dword:00000000
"Detect Glide"=dword:00000000
"Detect D3D"=dword:00000001
"DisableZbias"=dword:00000000
"Soundcard"=hex(2):44,00,69,00,72,00,65,00,63,00,74,00,53,00,6f,00,75,00,6e,00,\
  64,00,00,00
"LauncherSoundEnabled"=dword:00000001
"EnableJoystickFF"=dword:00000000
"EnableHitEffect"=dword:00000001
"ComputerSpeed"=dword:00000002
"NetworkConnection"=hex(2):4c,00,41,00,4e,00,00,00
"ConnectionSpeed"=hex(2):46,00,61,00,73,00,74,00,00,00
"SkipVerify"=dword:00000000
"PXOBanners"=dword:00000001
"ForcePort"=dword:00000000
"Language"=hex(2):45,00,6e,00,67,00,6c,00,69,00,73,00,68,00,00,00
"StraightToSetup"=dword:00000000
"Gamma"="1.80"
"LastPlayer"=""

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Volition\FreeSpace2\Version]
"Major"=dword:00000001
"Minor"=dword:00000014
"Build"=dword:00000000
    [/li]

  • Step 2. Open regedit (Windows-R, enter "regedit", press return)
    Go to HKEY_CURRENT_USER\SOFTWARE\Classes\VirtualStore\MACHINE\SOFTWARE\Wow6432Node\
    You should have a key named "Volition" there.
  • Step 3. Right-click on it, and select "Permissions".
    When I did this, the "Group or user names" field was blank. If it is, click "Add".
    In the dialogue that now pops up, Enter "ALL APPLICATION PACKAGES" into the "Enter the object names" field.
    Click OK. The dialogue should now be populated.
  • Step 4. Go to the FreeSpace2 subkey under the Volition entry. Check permissions as above, and if necessary, fix as above.
Let there be light
Let there be moon
Let there be stars and let there be you
Let there be monsters and let there be pain
Let us begin to feel again
--Devin Townsend, Genesis

 

Offline zheega

  • 22
Re: wxlauncher unhandled error
Wow, thanks very much. I have no idea why this suddenly happened, but now it works again :)

 
Re: wxlauncher unhandled error
Sorry to bump this but just want to say I got this issue straight after the Windows 10 anniversary update had been completed. The E's fix worked, in my case "ALL APPLICATION PACKAGES" was listed in the permissions but "Full Control" was not ticked. Now launches without issue. :)

 
Re: wxlauncher unhandled error
I have experienced the same problem after install Windows 10 Anniversary Update on 8/18/2016.

The previous posts correctly identify that the problem is that the 'ALL APPLICATION PACKAGES' group or user name needs to be set to "Full Control".

If you follow the previous instructions, you will be able to save the profile, but will receive the HKLM error message when you hit the Play button.

By looking into the vxLauncher source code, I found that they also update a KEY branch related with the virtual store. This virtual registry contains entries at each user level. Every HKEY_USER is different, assigned at the time that the user account was created in your machine. For example, the path to my account registry looks like:

[HKEY_USERS\S-1-5-21-2661013439-162139277-486847506-1001_Classes\VirtualStore\MACHINE\SOFTWARE\Wow6432Node\Volition]

[HKEY_USERS\S-1-5-21-2661013439-162139277-486847506-1001_Classes\VirtualStore\MACHINE\SOFTWARE\Wow6432Node\Volition\Freespace2]

Update both keys to  'ALL APPLICATION PACKAGES' -> "Full Control", and after that, the play button will work as expected.