Author Topic: Saitek ST290 Pro Joystick not recognized in-game  (Read 2964 times)

0 Members and 1 Guest are viewing this topic.

Saitek ST290 Pro Joystick not recognized in-game
I just installed FreeSpace Open on my computer, and upon starting a FreeSpace 2 game (no mod), using WX Launcher, I found that my Saitek ST290 Pro joystick is not working in-game. I checked the settings in wxlauncher, and the stick is detected, and calibrates OK. Initially, I ran FS2 no-mod under FS Open 3.7.2 RC5. I tried to run it under 3.7.2 RC5 SSE and 3.7.2 RC5 NO-SSE and same result. tried using my old, semi-functioning Wingman Extreme 3D in place of the Saitek, and it works in-game. I am running FS Open on a Gateway SX2110G computer running Windows 8.1, with an AMD E1-1500 APU, integrated Nvidia HD7310 graphics and 6GB of DDR3 ram. Other than the joystick issue, FS Open runs great on the box. any suggestions/recommendations/solutions would be most appreciated.
« Last Edit: February 24, 2015, 08:19:50 pm by davespurlock »


Offline deathspeed

  • 29
  • i can't think of a good avatar
    • Steam
Re: Saitek ST290 Pro Joystick not recognized in-game
I had something similar happen, but mine was because I started the launcher before the joystick was plugged in. 

You might try setting the Saitek as the preferred device.  I don't know how to (or even if you can) with Windows 8.1, but here is how I did it in Windows 7:

Start > Devices and Printers
Right click on the Saitek joystick and select Game Controller Settings
Select Advanced
Choose it as the Preferred Device in the drop-down and click OK
Maybe someday God will give you a little pink toaster of your own.

Re: Saitek ST290 Pro Joystick not recognized in-game
Thanks, I'll try that