Author Topic: visual issue when playing WIH  (Read 2468 times)

0 Members and 1 Guest are viewing this topic.

Offline CT27

  • 211
visual issue when playing WIH
I just started playing the BPC version of War In Heaven.  I have a recent nightly build and ran the installer recently so things should be up to date.

This is in the first mission (where you're defending a UEF convoy).

The various colored lights that extend out from the gate (and on the cruisers)...are the balls supposed to have 'squares' around them?  The balls flash but the solid square around them stays solid.

 

Offline eicca

  • 26
Re: visual issue when playing WIH
I see this issue too, also occured in Freespace Blue. Not sure if it's an error with the BP releases or the FSO app itself.

 

Offline niffiwan

  • 211
  • Eluder Class
Re: visual issue when playing WIH
It doesn't sound right, so please post your fs2_open.log file.  Instructions on how to do this can be found in this post.

Does the issue also occur when viewing the two Sanctus Cruisers in the techroom?
Creating a fs2_open.log | Red Alert Bug = Hex Edit | MediaVPs 2014: Bigger HUD gauges | 32bit libs for 64bit Ubuntu
----
Debian Packages (testing/unstable): Freespace2 | wxLauncher
----
m|m: I think I'm suffering from Stockholm syndrome. Bmpman is starting to make sense and it's actually written reasonably well...

 

Offline CT27

  • 211
Re: visual issue when playing WIH
I'll post a log later but for now I can say I did see the issue in the techroom too.

 

Offline CT27

  • 211
Re: visual issue when playing WIH
Here is the log I made.

[attachment DELETED!! by Strong Bad]

 

Offline niffiwan

  • 211
  • Eluder Class
Re: visual issue when playing WIH
I can't see anything obviously wrong at a quick glance.  I'd suggest rerunning the installer again just to be sure you have the absolutely latest copy of BP.

Also, eicca, do you have a similar graphics card to this one?

Code: [Select]
Initializing OpenGL graphics device at 1920x1080 with 32-bit color...
  Initializing WGL...
  Requested WGL Video values = R: 8, G: 8, B: 8, depth: 24, stencil: 8, double-buffer: 1
  Actual WGL Video values    = R: 8, G: 8, B: 8, depth: 24, stencil: 8, double-buffer: 1
  OpenGL Vendor    : ATI Technologies Inc.
  OpenGL Renderer  : AMD Radeon HD 6770
  OpenGL Version   : 4.5.13399 Compatibility Profile Context 15.201.1001.0
Creating a fs2_open.log | Red Alert Bug = Hex Edit | MediaVPs 2014: Bigger HUD gauges | 32bit libs for 64bit Ubuntu
----
Debian Packages (testing/unstable): Freespace2 | wxLauncher
----
m|m: I think I'm suffering from Stockholm syndrome. Bmpman is starting to make sense and it's actually written reasonably well...

 
Re: visual issue when playing WIH
Strange, I see it too. Squares around glow points are visible if I disable soft particles. I don't see this in mvps 2014, only in BP.

Example:


BP:


BP with soft particles enabled:


mod (not BP) with MVPs 2014:


I have similar hw:
Code: [Select]
Initializing OpenGL graphics device at 1366x768 with 32-bit color...
  Initializing WGL...
  Requested WGL Video values = R: 8, G: 8, B: 8, depth: 24, stencil: 8, double-buffer: 1
  Actual WGL Video values    = R: 8, G: 8, B: 8, depth: 24, stencil: 8, double-buffer: 1
  OpenGL Vendor    : ATI Technologies Inc.
  OpenGL Renderer  : AMD Radeon 6600M and 6700M Series
  OpenGL Version   : 4.5.13399 Compatibility Profile Context 16.201.1151.1007
« Last Edit: February 17, 2016, 05:29:57 pm by tomimaki »

 

Offline niffiwan

  • 211
  • Eluder Class
Re: visual issue when playing WIH
very interesting... CT27 can you test if enabling soft particles (and probably post-processing) "fixes" this issue for you?
Creating a fs2_open.log | Red Alert Bug = Hex Edit | MediaVPs 2014: Bigger HUD gauges | 32bit libs for 64bit Ubuntu
----
Debian Packages (testing/unstable): Freespace2 | wxLauncher
----
m|m: I think I'm suffering from Stockholm syndrome. Bmpman is starting to make sense and it's actually written reasonably well...

 

Offline CT27

  • 211
Re: visual issue when playing WIH
How do I do that?

 

Offline niffiwan

  • 211
  • Eluder Class
Re: visual issue when playing WIH
They're both in the launcher;

Advanced Settings -> Enable PostProcessing
Advanced Settings -> Enable soft particles
Creating a fs2_open.log | Red Alert Bug = Hex Edit | MediaVPs 2014: Bigger HUD gauges | 32bit libs for 64bit Ubuntu
----
Debian Packages (testing/unstable): Freespace2 | wxLauncher
----
m|m: I think I'm suffering from Stockholm syndrome. Bmpman is starting to make sense and it's actually written reasonably well...

 
Re: visual issue when playing WIH
I've had this issue before. But it was on my other PC which I have given to a relative after I got a new one.

 

Offline Solatar

  • 211
Re: visual issue when playing WIH
I noticed the same thing. I just opened a few glows (green_glow.dds, etc) from the bpc-visuals1.vp and the MV_assets.vp, and they're not the same image file. The one from blueplanet is lower resolution and doesn't actually fade to pure black on the edges, although I think with dark lighting settings (that people play blueplanet on) you might not notice. So, the MediaVPs one looks better because it's a different image.

 

Offline Darius

  • Moderator
  • 211
Re: visual issue when playing WIH
Huh.

I wonder if this is leftover from the glow point lighting experiments from before.

May as well use the MVP ones.

 

Offline CT27

  • 211
Re: visual issue when playing WIH
I am using BPC and the mod.ini says MVPs 2014 are being used so shouldn't I be getting that third smaller picture tomimaki posted?

 
Re: visual issue when playing WIH
Not necessarily, the assets present in the BP modpack would override those in the mediaVPs.

 
Re: visual issue when playing WIH
Third pic is just for comparison. Yes, ship is from BP, just "mod" is not BP. :P

 

Offline CT27

  • 211
Re: visual issue when playing WIH
They're both in the launcher;

Advanced Settings -> Enable PostProcessing
Advanced Settings -> Enable soft particles

Good news and bad news:

Good-Enabling those two things did get me the second of tomimaki's smaller picture so that's good (a solid circlee makes more sense than a solid square).


Bad-It took away some of the 'clouds' in the background so the screen seemed a lot darker.  The stars were still there though.  I still wasn't able to get the third of tomitaki's smaller pictures. 


Thank you all for your help though.

 

Offline eicca

  • 26
Re: visual issue when playing WIH
I can't see anything obviously wrong at a quick glance.  I'd suggest rerunning the installer again just to be sure you have the absolutely latest copy of BP.

Also, eicca, do you have a similar graphics card to this one?

Code: [Select]
Initializing OpenGL graphics device at 1920x1080 with 32-bit color...
  Initializing WGL...
  Requested WGL Video values = R: 8, G: 8, B: 8, depth: 24, stencil: 8, double-buffer: 1
  Actual WGL Video values    = R: 8, G: 8, B: 8, depth: 24, stencil: 8, double-buffer: 1
  OpenGL Vendor    : ATI Technologies Inc.
  OpenGL Renderer  : AMD Radeon HD 6770
  OpenGL Version   : 4.5.13399 Compatibility Profile Context 15.201.1001.0

My GFX card is an older Intel HD3000 integrated unit in a MacBook Prop from 2011.