Author Topic: Problem With FSO 3.7.4  (Read 3500 times)

0 Members and 1 Guest are viewing this topic.

Offline The E

  • He's Ebeneezer Goode
  • Global Moderator
  • 213
  • Nothing personal, just tech support.
    • Steam
    • Twitter
Re: Problem With FSO 3.7.4
Yes, it absolutely is. There's noone on the team willing to support it, and even if there was, its usefulness is strictly limited. wardog here is the only person out of the FSO userbase that actually meets the conditions (as in, absolutely zero budget for anything that could qualify as a gaming PC). That makes it an eminently cuttable feature, and given that it's likely broken by now, cutting it is the logical choice.
Let there be light
Let there be moon
Let there be stars and let there be you
Let there be monsters and let there be pain
Let us begin to feel again
--Devin Townsend, Genesis

 

Offline wardog300k

  • 28
  • I'm a FREDder
Re: Problem With FSO 3.7.4
Do you have an expansion slot open?  What kind (AGP, PCI, PCI-E)?  What's your system specs and what PSU is it using?

No expansion slots open, PCI, Intel 2 Duo E4500 2.2GHz.
Crush the NTF-Conflict Zone
One last war, one last hope, one last survival-Final Destination On Delay
Set free from the GTVA-Liberation Wars On Delay

 

Offline Cyborg17

  • 29
  • A-1 Supar
Re: Problem With FSO 3.7.4
I meant confirmed that it was broken, not whether it was being cut.

 

Offline AdmiralRalwood

  • 211
  • The Cthulhu programmer himself!
    • Skype
    • Steam
    • Twitter
Re: Problem With FSO 3.7.4
I meant confirmed that it was broken, not whether it was being cut.
It takes less than a minute to confirm it. I haven't done an exhaustive check to see which version it broke in, but it definitely hasn't worked since I joined the SCP. You get the HUD (not terribly surprising that 2D drawing works fine), but behind the HUD you just get a black screen.

If somebody wanted to do an exhaustive binary search to find the exact commit that broke it, it might possibly lead to the feature being restored. Otherwise, nobody has the time or inclination to work on it.
Ph'nglui mglw'nafh Codethulhu GitHub wgah'nagl fhtagn.

schrödinbug (noun) - a bug that manifests itself in running software after a programmer notices that the code should never have worked in the first place.

When you gaze long into BMPMAN, BMPMAN also gazes into you.

"I am one of the best FREDders on Earth" -General Battuta

<Aesaar> literary criticism is vladimir putin

<MageKing17> "There's probably a reason the code is the way it is" is a very dangerous line of thought. :P
<MageKing17> Because the "reason" often turns out to be "nobody noticed it was wrong".
(the very next day)
<MageKing17> this ****ing code did it to me again
<MageKing17> "That doesn't really make sense to me, but I'll assume it was being done for a reason."
<MageKing17> **** ME
<MageKing17> THE REASON IS PEOPLE ARE STUPID
<MageKing17> ESPECIALLY ME

<MageKing17> God damn, I do not understand how this is breaking.
<MageKing17> Everything points to "this should work fine", and yet it's clearly not working.
<MjnMixael> 2 hours later... "God damn, how did this ever work at all?!"
(...)
<MageKing17> so
<MageKing17> more than two hours
<MageKing17> but once again we have reached the inevitable conclusion
<MageKing17> How did this code ever work in the first place!?

<@The_E> Welcome to OpenGL, where standards compliance is optional, and error reporting inconsistent

<MageKing17> It was all working perfectly until I actually tried it on an actual mission.

<IronWorks> I am useful for FSO stuff again. This is a red-letter day!
* z64555 erases "Thursday" and rewrites it in red ink

<MageKing17> TIL the entire homing code is held up by shoestrings and duct tape, basically.

 

Offline jr2

  • The Mail Man
  • 212
  • It's prounounced jayartoo 0x6A7232
    • Steam
Re: Problem With FSO 3.7.4
No expansion slots open, PCI, Intel 2 Duo E4500 2.2GHz.

Nuts.

 
 

Offline Yarn

  • 210
Re: Problem With FSO 3.7.4
Do you have any expansion slots at all, occupied or not? If so, what cards are plugged into them? And are you actually using all those cards?
« Last Edit: March 25, 2016, 11:02:13 pm by Yarn »
"Your fighter is running out of oil.  Please check under the hood and add more if necessary"
--strings.tbl, entry 177

"Freespace is very tired.  It is shutting down to get some rest."
--strings.tbl, entry 178