Author Topic: Changing language to French  (Read 1806 times)

0 Members and 1 Guest are viewing this topic.

Offline Saig

  • 22
Changing language to French
Hi !
I have installed the French pack for Freespace port, but i have only cinematics + voice in French.
I have read that to modify the language, I need to go in the FreeSpace 2 registry. But: it is in the registry Editor of Windows or other place ?

Thanks in advance =S

 

Offline Goober5000

  • HLP Loremaster
  • 214
    • Goober5000 Productions
Re: Changing language to French
I am moving your post to the support forum where it will get more visibility.  I'm not entirely sure myself how to change the language.  However, I can tell you that "the registry" refers to the Windows registry, which is accessed by regedit.

Could you link to the instructions you found to change the language?  Maybe they could be clarified.

 

Offline Saig

  • 22
Re: Changing language to French
Thanks for the move ;)

I have read this :S

I believe it is necessary to set your language in the FreeSpace 2 registry.  I'm not sure how to do this, but it has been discussed on HLP so you might be able to search for it.

Yarn handled the translation packs, so he should be able to provide a better answer when he sees your question.

 

Offline Novachen

  • 29
  • The one and only capella supernova
    • Twitter
Re: Changing language to French
For languages like german and french, so to speak official retail languages, a registry entry is not needed anymore. The language is set by the used font01.vf in FSO.

If you have a font file from the french version, you should be have french language in the game.

Even a language entry in the registry have still the priority, though. To have the best compatibilty, especially with mods with own fonts, you should delete and play without it.

You can find it in HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432\Volition\FreeSpace2 on x64 systems. On 32-Bit it should be the same without the WOW6432 key.
Female FreeSpace 2 pilot since 1999.
Former Global moderator in the German FreeSpace Galaxy Forum.

Is one of my releases broken or not working? Please send a PM here or on Twitter, a public tweet @NovachenFS2 or write a reply in my own release threads here on HLP, because these are the only threads i am still participating in.

 

Offline Yarn

  • 210
Re: Changing language to French
You can find it in HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432\Volition\FreeSpace2 on x64 systems. On 32-Bit it should be the same without the WOW6432 key.
Nope. The real location is found on this page, in the "Registry" section: http://www.hard-light.net/wiki/index.php/Getting_started_with_FreeSpace_2#Registry
"Your fighter is running out of oil.  Please check under the hood and add more if necessary"
--strings.tbl, entry 177

"Freespace is very tired.  It is shutting down to get some rest."
--strings.tbl, entry 178

 

Offline Novachen

  • 29
  • The one and only capella supernova
    • Twitter
Re: Changing language to French
You can find it in HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432\Volition\FreeSpace2 on x64 systems. On 32-Bit it should be the same without the WOW6432 key.
Nope. The real location is found on this page, in the "Registry" section: http://www.hard-light.net/wiki/index.php/Getting_started_with_FreeSpace_2#Registry

Thats interesting, because i did not have this one on Win10.  :wtf:
Female FreeSpace 2 pilot since 1999.
Former Global moderator in the German FreeSpace Galaxy Forum.

Is one of my releases broken or not working? Please send a PM here or on Twitter, a public tweet @NovachenFS2 or write a reply in my own release threads here on HLP, because these are the only threads i am still participating in.

 

Offline Saig

  • 22
Re: Changing language to French
Thanks for your help :)

I have delete this key (Freespace 2) in regedit (Windows 10 x64) but I have only French audio, not the text... like before :/


EDIT: I have also found & read this, but... I have not found the [Default] section (and what .ini file ? setttings.ini of fsport ? :S)
http://www.hard-light.net/wiki/index.php/Manually_Installing_FreeSpace_2_Open#Language_Setup
« Last Edit: February 18, 2017, 05:02:27 pm by Saig »

 

Offline Yarn

  • 210
Re: Changing language to French
Font files themselves cannot specify languages. Rather, the game calculates the hash of the first font (usually font01.vf) and sets the language based on that. However, this only works for English, German, and Polish (because FS2 was never actually released in French), and it doesn't work with custom-made fonts (because they would have different hashes). Of course, if a language is specified in the registry, then that is used instead.

I'm pretty sure that Novachen meant to suggest that you delete the Language value, not the whole Freespace2 key! Since you did that, you need to start the game, close it, then check the registry to ensure that the Freespace2 key has been recreated. If it has, then add a string value (highlight the Freespace2 key, then in an empty part of the area that has things like LastPlayer and SoundDeviceOAL, right-click -> New -> String Value, assuming it's in English) and name it Language. Then, set its data to French (you might need the capital F).


You can find it in HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432\Volition\FreeSpace2 on x64 systems. On 32-Bit it should be the same without the WOW6432 key.
Nope. The real location is found on this page, in the "Registry" section: http://www.hard-light.net/wiki/index.php/Getting_started_with_FreeSpace_2#Registry

Thats interesting, because i did not have this one on Win10.  :wtf:
Oh, right, that's another location where the settings can be stored (except WOW6432 is really Wow6432Node). I'll add it to the wiki shortly. EDIT: Done!
« Last Edit: February 18, 2017, 05:31:01 pm by Yarn »
"Your fighter is running out of oil.  Please check under the hood and add more if necessary"
--strings.tbl, entry 177

"Freespace is very tired.  It is shutting down to get some rest."
--strings.tbl, entry 178

 

Offline Saig

  • 22
Re: Changing language to French
It's work perfectly fine, thanks to you ;)

Font files themselves cannot specify languages. Rather, the game calculates the hash of the first font (usually font01.vf) and sets the language based on that. However, this only works for English, German, and Polish (because FS2 was never actually released in French), and it doesn't work with custom-made fonts (because they would have different hashes). Of course, if a language is specified in the registry, then that is used instead.

I'm pretty sure that Novachen meant to suggest that you delete the Language value, not the whole Freespace2 key! Since you did that, you need to start the game, close it, then check the registry to ensure that the Freespace2 key has been recreated. If it has, then add a string value (highlight the Freespace2 key, then in an empty part of the area that has things like LastPlayer and SoundDeviceOAL, right-click -> New -> String Value, assuming it's in English) and name it Language. Then, set its data to French (you might need the capital F).


You can find it in HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432\Volition\FreeSpace2 on x64 systems. On 32-Bit it should be the same without the WOW6432 key.
Nope. The real location is found on this page, in the "Registry" section: http://www.hard-light.net/wiki/index.php/Getting_started_with_FreeSpace_2#Registry

Thats interesting, because i did not have this one on Win10.  :wtf:
Oh, right, that's another location where the settings can be stored (except WOW6432 is really Wow6432Node). I'll add it to the wiki shortly.

 

Offline Rajive

  • 22
Re: Changing language to French
Sorry to up this thread, but since my question is about the same subject I though it was better to ask here than creating a new one.

I got voice & cinematic in french but not texte.
I've tried to change "Language" in "French", "french" "fr"... in registery but it failed.

I've installed FS Port a countless time and never had trouble before. But before I was using "FreeSpaceOpenInstaller.jar" to instal FSO.
Now I'm trying Knossos which got a "language" setting in "voice".

When I put it in "french" I got most of my texte in FS Port in french. However there is a little (fr) before some of it, and notably in flight before auto-speed setting.
I got the same (fr) when playing FS2O, even if I know FS2 never had an official translation in french (I haven't try the fan made one yet).

On a side note, I wanted to take some screenshots to show you how it was. But even if I use print key I got no screenshot saved on FS2 folder, and go a black screen on paint and fraps.

Thanks in advance