Author Topic: TrackIR not working in recent builds  (Read 1373 times)

0 Members and 1 Guest are viewing this topic.

Offline m!m

  • 211
Re: TrackIR not working in recent builds
Hello there.  It seems at some point in the new builds TrackIR x64 stopped working again.

I have the 5/17/17 dll in place but no TrackIR any longer.  It would be great to get that back :D

Thanks!
Please post your fs2_open.log file.  Instructions on how to do this can be found in this post.

 
Re: TrackIR not working in recent builds
I am running a customized build testing various things, though it was working fine last year with the older builds.  If needed I can go back and try and find when/where it quit working.

 

Offline m!m

  • 211
Re: TrackIR not working in recent builds
Unfortunately, that log does not reach the point where FSO tries to start TrackIR. You need to let the game initialize completely.

 
Re: TrackIR not working in recent builds
Here you go, this one is all the way until I was in mission and launched.

Padlock still works but no TrackIR.




Initializing head tracking...
Failed to load library 'scptrackir64.dll': 'Failed loading scptrackir64.dll: The specified module could not be found.
'
TrackIR Init Failed - -1
    Failed to initialize 'TrackIR': Failed to initialize TrackIR.
Found FreeTrack provider 'FreeTrack' with version 1.0.0.0.
    Successfully initialized 'FreeTrack'
Creating player for movie


That's not the name of the DLL from last year, it's scptrackir.dll.  I'll try renaming it.


*That was easy.  Sorry to bother.  Works fine when it's named scptrackir64.dll.
« Last Edit: May 02, 2018, 05:20:40 am by Nightstorm »

 

Offline m!m

  • 211
Re: TrackIR not working in recent builds
Quote
Failed loading scptrackir64.dll: The specified module could not be found.
Just to make sure we didn't miss anything obvious here, are you sure that scptrackir64.dll is in the right location?

 
Re: TrackIR not working in recent builds
Sorry I updated my previous post, in the release last year the x86 and x64 dll's were named the same.  The new build was looking for it to have 64 on the end of the name.  Simply renaming the dll resolved the issue.

The debug log pointed out exactly what the issue was.  I should have checked there first.

Thanks,

 

Offline m!m

  • 211
Re: TrackIR not working in recent builds
The 3.8 release post has the new DLLs with the correct names so you can use that instead of manually renaming the DLLs.