Author Topic: Release: 3.8.0  (Read 61556 times)

0 Members and 1 Guest are viewing this topic.

Offline Colonol Dekker

  • HLP is my mistress
  • 213
  • Aken Tigh Dekker
    • My old squad sub-domain
Could the command lines for most pleasing light be added to the OP?

Thanks AdmiralRalWood, I actually discovered this last night, but obviously I was asleep whenever you posted.  Here is how I managed to fix it:

Disabling my second monitor, disabling display scaling in the compatability options and switching my resolution both on the desktop and for the game to run at 2560 x 1440 worked just fine for me.  It isn't 4k, but considering it is a 20-year-old engine at this point I am impressed that it runs at 1440p with no issues.


Offline ksotar

  • 26
alas, this is a known issue with resolutions above 1080p that is difficult to diagnose due to HUD coders not having monitors that big

Actually, it is usually possible to create "custom" resolution for monitor, that could be bigger than its real one. At least Nvidia and Intel video drivers have that setting in their control panels. Just note.


Offline m!m

  • 211
I tried that with the AMD equivalent of that option but it still didn't show the bugged behavior so it's probably an issue with either display scaling or some sort of weird interaction with an actual 4K display.


Offline ksotar

  • 26
Suddenly I realized, that joystick doesn't work in 3.8.0 (while it did in 3.7.2).

I have it detected OK:

But it just don't work. And wxLauncher detects something strange, it shows three devices, while in reality there are two:

But neither of them works in FSO. I could imagine that it may be a problem with wxLauncher, but for 3.7.2 it detects two just fine. I can't distinguish between them, and only one of them works, but it works at least:

Actually, this problem exists with the current master branch too.
« Last Edit: December 09, 2017, 10:45:56 am by ksotar »


Offline AdmiralRalwood

  • 211
  • The Cthulhu programmer himself!
    • Skype
    • Steam
    • Twitter
I could imagine that it may be a problem with wxLauncher, but for 3.7.2 it detects two just fine.
It's still most likely a problem with wxLauncher; try again with wxLauncher 0.12.0-rc.2.
Ph'nglui mglw'nafh Codethulhu GitHub wgah'nagl fhtagn.

schrödinbug (noun) - a bug that manifests itself in running software after a programmer notices that the code should never have worked in the first place.

When you gaze long into BMPMAN, BMPMAN also gazes into you.

"I am one of the best FREDders on Earth" -General Battuta

<Aesaar> literary criticism is vladimir putin

<MageKing17> "There's probably a reason the code is the way it is" is a very dangerous line of thought. :P
<MageKing17> Because the "reason" often turns out to be "nobody noticed it was wrong".
(the very next day)
<MageKing17> this ****ing code did it to me again
<MageKing17> "That doesn't really make sense to me, but I'll assume it was being done for a reason."
<MageKing17> **** ME

<MageKing17> God damn, I do not understand how this is breaking.
<MageKing17> Everything points to "this should work fine", and yet it's clearly not working.
<MjnMixael> 2 hours later... "God damn, how did this ever work at all?!"
<MageKing17> so
<MageKing17> more than two hours
<MageKing17> but once again we have reached the inevitable conclusion
<MageKing17> How did this code ever work in the first place!?

<@The_E> Welcome to OpenGL, where standards compliance is optional, and error reporting inconsistent

<MageKing17> It was all working perfectly until I actually tried it on an actual mission.

<IronWorks> I am useful for FSO stuff again. This is a red-letter day!
* z64555 erases "Thursday" and rewrites it in red ink

<MageKing17> TIL the entire homing code is held up by shoestrings and duct tape, basically.


Offline ksotar

  • 26
I'm using just that. Strangely, I haven't find a way to see wxLauncher version, but I double-checked the installer file I've used.

Strangest issue ever: I just upgraded to this, from 3.7.something, and now...

Ships with the "Show Ship" flag no longer show up. Some ships (Dragon, Manticore, and Bellerophon) kind of need this when you make them player-flyable, because they have firepoints waaaay in front of the eyepoint. If you can't see the hull, it looks like your guns & beams are spawning out of empty space.

(Player-flyable Dragons, Bellerophons, and Manticores are awesome.)
"Obviously the meson bomb is a form of cat-toast-device, with the buttered toast inverted, so that the cat and toast both fly in the direction of gravity much faster than expected. By introducing artificial gravity, a pair of cat-toast perpetual motion accelerator units can be made to collide with one another, and they produce an unimaginably devastating explosion. Both cats are named 'Meson'."

 - Wikileaks 2383


Offline m!m

  • 211
I fixed that bug and opened a pull request with the changes:


Offline LoneFan

  • 26
It is my understanding that the 64-bit build will have more memory. Or should I say access to more system memory allowing it to handle more.
Is this right?


Offline m!m

  • 211
Yes, if you have a 64-bit OS then you should use the 64-bit build to avoid memory issues.

Is there any chance of getting multi USB's to work? I have a X-55, flight pedals, and a few other USB devices that can't be used.
(can't remember how to resize smaller)

As of right now the only way to do that is with 3rd party software like Vjoy and UCR. You can combine all of your devices into one virtual device and then map it with UCR(universal control remapper).

However, you'll still be limited to only 5 axes(axis-es?) in game. You can map the unusable axes to a button in UCR and use them that way though.
[19:31] <MatthTheGeek> you all high up on your mointain looking down at everyone who doesn't beam everything on insane blindfolded


Offline Mongoose

  • Rikki-Tikki-Tavi
  • Global Moderator
  • 212
  • This brain for rent.
    • Minecraft
    • Steam
    • Something
IANACoder, but the implementation of SDL means it's now theoretically possible for engine support to be added for additional axes and multiple controllers.  Obviously actually developing that support is non-trivial.