Author Topic: FSO on Ultrabook + External Monitor Fullscreen Issue  (Read 558 times)

0 Members and 1 Guest are viewing this topic.

Offline PETC

  • 22
FSO on Ultrabook + External Monitor Fullscreen Issue
Just another n00b here with a question. First off: I checked the FAQ and my issue was not covered. I also did a pretty extensive Google search and went through threads that had similar issues, none exactly like mine and none of the solutions posted helped me fix the problem.

I have FSO installed and working flawlessly on my machine (3.8.0 + wxLauncher 0.12.0-rc.2).

I wrote some instructions for a friend to do the same and they are the ones having problems. The good news is: The game works fine on their machine. The bad news is, it only displays in the upper left hand corner of the screen. It displays completely, but only in the upper left hand corner.

The computer is a laptop plugged into an external 1920x1080 monitor and that monitor is acting as the only display, (Display only on Monitor 2 selected in the Windows resolution settings). The laptop screen itself has a native resolution of 1920x1080, same as the monitor, but is not active/on. In wxLauncher he has the resolution set at 1920x1080 and in the Advanced Settings tab under Custom Flags he also has the "-res 1920x1080" flag added.

Under Dev Tools selecting "Run in window" at least makes the problem better, by moving the game to the middle of the screen, but it's still not full screen.  Selecting "Run in full screen window" results in the same improvement. Removing the "-res 1920x1080" tag under custom tags has no effect. Changing the resolution in the launcher/custom flag only serves to change the monitors resolution, but still runs the game in a borderless windows either in the upper left hand corner of the screen or the middle of the screen depending on Dev Tools boxes checked.

If he unplugs the external monitor and runs the game on the laptops onboard display (at 1920x1080) the game runs in full screen.

I have plugged a monitor into my computer to see if I could duplicate the problem and no matter what I do (monitor plugged in and not displaying, monitor plugged in and extending my desktop) I cannot recreate the issue.

Quite the puzzler.  :banghead: Any help would be keen. Obviously the problem can be solved by simply unplugging the external monitor, but I'd ideally like to find a solution to the problem that does not require having him do that.

Thanks for any and all time you may have to spend on me.


[attachment stolen by Russian hackers]
« Last Edit: September 19, 2017, 10:30:09 pm by PETC »

Re: FSO on Ultrabook + External Monitor Fullscreen Issue
In properties for FSO 3.8.0 disable display scaling on high dpi settings.


Offline PETC

  • 22
Re: FSO on Ultrabook + External Monitor Fullscreen Issue
I'll have him give that a shot and see if it works. Can't believe I didn't try that...



Offline PETC

  • 22
Re: FSO on Ultrabook + External Monitor Fullscreen Issue
 :D Yep. That worked. Thanks a lot! Kicking myself for not trying that but I'm just glad the problem is solved. Now if I could only find a way to play through the single player campaign co-op with my buddy.

Oh well, there's always The Gauntlet.