Author Topic: PUBLIC BETA: Knossos 0.14.1 (combined launcher/installer)  (Read 156807 times)

0 Members and 2 Guests are viewing this topic.

Offline PIe

  • 28
  • GTVA POLICE
    • freespace3.com
Re: PUBLIC BETA: Knossos 0.8.0 (combined launcher/installer)
"Shivans" is not playable, because it does not have any exe configuration in the mods.json by default. So it requires a user configuration before.
Try deleting and redownloading it.  I believe that issue was fixed some time ago.
[6:23 PM] PIe: why do I have the feeling that I shouldn't be able to give orders to 22nd armored hq
[6:24 PM] Axem: 22nd armored hq, i order you to get me a cup of coffee
[6:24 PM] PIe: and donuts
[6:24 PM] PIe: BECAUSE THIS IS THE GTVA POLICE
[6:25 PM] Axem: :O
[6:25 PM] Axem: am i under arrest
[6:26 PM] [`_`]/: no, just please step out of the myrmidon
[6:26 PM] [`_`]/: you have so much to fred for

[9:50 PM] Sottises: wait did you do vassago's verge?
[9:50 PM] Sottises: .. dirge?
[9:50 PM] Axem: yes
[9:50 PM] Sottises: ohh
[9:50 PM] Sottises: well I have that and JAD too
[9:50 PM] Axem: :)
[9:50 PM] Sottises: what a contrast of themes lmao
[9:50 PM] Axem: isnt it
[9:51 PM] Axem: super grimdark thriller about unknowable alien intelligence and over the top colorful action about friendship
[9:51 PM] PIe: jad is grimdark???
[9:51 PM] Axem: :skull:

 

Offline ngld

  • Administrator
  • 29
  • Knossos dev
Re: PUBLIC BETA: Knossos 0.8.0 (combined launcher/installer)
Looks like the Voice selection issue was caused by a packaging problem (some generated code for COM interaction is missing =/). Will be fixed in the next version!

The Nebula should work fine again, there was an issue with the database server.

 

Offline Rae2005

  • 22
Re: PUBLIC BETA: Knossos 0.8.0 (combined launcher/installer)
Go to settings (the cog icon in the upper-right corner), open the speech section, check the appropriate boxes next to "Use Speech In" and press the big save button at the top. The setting is global and should apply to all mods.

My 'Voice' drop down menu has no selections (I have IVONA 2 Amy installed and it works fine with the wxLauncher)
excactly my issue  well hopefully this will be fixed in the next update. :mad:

 

Offline ngld

  • Administrator
  • 29
  • Knossos dev
Re: PUBLIC BETA: Knossos 0.8.1 (combined launcher/installer)
0.8.1 has been released. It fixes CPU feature detection (AVX, SSE, etc.), verifies dependencies during mod upload, implements a fix for macOS builds (which will only work once the metadata has been updated) and should have fixed the voice selection. However, the CI failed to generate the necessary code (if I build it locally, everything works) and I currently don't have the necessary time to figure out why.
« Last Edit: February 08, 2018, 12:27:48 am by ngld »

 

Offline Rae2005

  • 22
Re: PUBLIC BETA: Knossos 0.8.0 (combined launcher/installer)
nope still no voice do i need to download one or something?
« Last Edit: February 08, 2018, 12:05:44 am by Rae2005 »

 

Offline ngld

  • Administrator
  • 29
  • Knossos dev
Re: PUBLIC BETA: Knossos 0.8.0 (combined launcher/installer)
Sorry, I wasn't clear enough. I tried to fix the bug but that didn't work due to the way the CI builds the releases. I'll have to think of another solution to the problem (probably generating the necessary code at runtime).

 

Offline Rae2005

  • 22
Re: PUBLIC BETA: Knossos 0.8.1 (combined launcher/installer)
I see, well good luck, i guess.

 

Offline oljo

  • 23
Re: PUBLIC BETA: Knossos 0.8.1 (combined launcher/installer)
Hi.

I have tried Knossos on ubuntu 16.04 and kubuntu 17.10 but when i start it up after installasion i get a error, that its has stopped working, what to do? 

 

Offline ngld

  • Administrator
  • 29
  • Knossos dev
Re: PUBLIC BETA: Knossos 0.8.1 (combined launcher/installer)
Can you please run KN_DEBUG=1 knossos in a terminal and post the output?

 

Offline oljo

  • 23
Re: PUBLIC BETA: Knossos 0.8.1 (combined launcher/installer)
Traceback (most recent call last):
  File "/usr/bin/knossos", line 10, in <module>
    load_entry_point('knossos==0.6.0', 'gui_scripts', 'knossos')()
  File "/usr/lib/python3/dist-packages/pkg_resources/__init__.py", line 542, in load_entry_point
    return get_distribution(dist).load_entry_point(group, name)
  File "/usr/lib/python3/dist-packages/pkg_resources/__init__.py", line 2569, in load_entry_point
    return ep.load()
  File "/usr/lib/python3/dist-packages/pkg_resources/__init__.py", line 2229, in load
    return self.resolve()
  File "/usr/lib/python3/dist-packages/pkg_resources/__init__.py", line 2235, in resolve
    module = __import__(self.module_name, fromlist=['__name__'], level=0)
  File "/usr/share/knossos/knossos/launcher.py", line 41, in <module>
    from . import center
  File "/usr/share/knossos/knossos/center.py", line 103, in <module>
    from . import util # noqa
  File "/usr/share/knossos/knossos/util.py", line 30, in <module>
    import semantic_version
ImportError: No module named 'semantic_version'



heres the file

 

Offline ngld

  • Administrator
  • 29
  • Knossos dev
Re: PUBLIC BETA: Knossos 0.8.1 (combined launcher/installer)
I guess that's from your Ubuntu 16.04 system? The version you have (0.6.0) is outdated but the latest version (0.8.1) isn't available for Ubuntu 16.04 because a dependency (python3-pyqt5.qtwebengine) is missing there. I think you currently need at least Ubuntu 17.10 to install Knossos. Sorry.
I had hoped Ubuntu would backport or adopt the package much quicker than it has because the software has been available elsewhere literally for years (Qt 5 which introduced WebEngine was released in 2012).

So... yeah. Your only choice at this point is to update to 17.10 or wait until 18.04 releases and update to that.

 

Offline Rae2005

  • 22
Re: PUBLIC BETA: Knossos 0.8.1 (combined launcher/installer)
 Sometimes I get error: The application was unable to start correctly. 0xc000007b  error when trying to run any game from Knossos.


 System specs as far as I know.

Windows 7 home premium (x64) SP1
 Processor: AMD FX-6300
Ram: 4GB


My FS2 installation is from GOG if that changes anything
« Last Edit: February 10, 2018, 12:36:25 am by Rae2005 »

 
Re: PUBLIC BETA: Knossos 0.8.1 (combined launcher/installer)
Sometimes I get error: The application was unable to start correctly. 0xc000007b  error when trying to run any game from Knossos.


 System specs as far as I know.

Windows 7 home premium (x64) SP1
 Processor: AMD FX-6300
Ram: 4GB


My FS2 installation is from GOG if that changes anything
I had the same message until I reinstalled (or installed) the Open AI. May be that will be your problem too.

 

Offline jr2

  • The Mail Man
  • 212
  • It's prounounced jayartoo 0x6A7232
    • Steam
Re: PUBLIC BETA: Knossos 0.8.1 (combined launcher/installer)
Sometimes I get error: The application was unable to start correctly. 0xc000007b  error when trying to run any game from Knossos.


 System specs as far as I know.

Windows 7 home premium (x64) SP1
 Processor: AMD FX-6300
Ram: 4GB


My FS2 installation is from GOG if that changes anything
I had the same message until I reinstalled (or installed) the Open AI. May be that will be your problem too.

Open AL

Open AI in FreeSpace would be really cool, though.

 

Offline Novachen

  • 29
  • The one and only capella supernova
    • Twitter
Re: PUBLIC BETA: Knossos 0.8.1 (combined launcher/installer)
Maybe another project for Bryan See or woutersmits?  :lol:
Female FreeSpace 2 pilot since 1999.
Global moderator in the German FreeSpace Galaxy Forum.

 
Re: PUBLIC BETA: Knossos 0.8.1 (combined launcher/installer)
Better not. They already have so much stuff to do...

 

Offline jr2

  • The Mail Man
  • 212
  • It's prounounced jayartoo 0x6A7232
    • Steam
Re: PUBLIC BETA: Knossos 0.8.1 (combined launcher/installer)
Maybe another project for Bryan See or woutersmits?  :lol:
Better not. They already have so much stuff to do...

You don't understand.  You don't take Open AI and put Open AI in FreeSpace.  Open AI takes you and puts itself in FreeSpace.  You just have to follow directives.  Never mind that they look like nuclear launch codes and the coordinates to every place Elon Musk has been spotted over the last 24 hours...

 

Offline Novachen

  • 29
  • The one and only capella supernova
    • Twitter
Re: PUBLIC BETA: Knossos 0.8.1 (combined launcher/installer)
Maybe another project for Bryan See or woutersmits?  :lol:
Better not. They already have so much stuff to do...

You don't understand.  You don't take Open AI and put Open AI in FreeSpace.  Open AI takes you and puts itself in FreeSpace.
Well, i know that. But somebody have to play Freespace very much to create a very good OpenAI profile :).

Maybe they can even use OpenAI with FRED2 to create Generated Campaigns.
Or.. well.. three of the four ambitions mod projects by Bryan See can also be finished by OpenAI, if he is able to finish one of them during OpenAIs recording  :D
Female FreeSpace 2 pilot since 1999.
Global moderator in the German FreeSpace Galaxy Forum.

 
Re: PUBLIC BETA: Knossos 0.8.1 (combined launcher/installer)
Guys, let's not derail another thread with Bryan-snarking, please?

 

Offline ngld

  • Administrator
  • 29
  • Knossos dev
Re: PUBLIC BETA: Knossos 0.8.1 (combined launcher/installer)
Let's get back to the original problem...

@Rae2005: That error in general means that a 64bit application is trying to load a 32bit DLL (or the other way round). In this case your 64bit FSO is probably trying to load the 32bit OpenAL DLL packaged with Knossos. If you install OpenAL from Creative or put OpenAL Soft's DLL in the FSO directory, your problem should be solved. The latest nightlies and the next FSO release will include the OpenAL DLL as well so this should more or less fix itself in the future. I could add a warning if the OpenAL DLL is missing though...