Author Topic: Installation Problems - Freespace Port  (Read 484 times)

0 Members and 1 Guest are viewing this topic.

Installation Problems - Freespace Port
Installation Problems - Freespace 1 Campaign /with screenshot

1. I got both games. Freespace 1 original, i was missing an CD of Freespace 2 so i bought it again over steam.

2. Installed FS1 in C:/Games/Freespace1, and Freespace 2 over Steam into C:/Games/Freespace2.

3. Then i ran the installer to C:/Games/Freespace2 (as mentioned in the manual instructions)

4. Everything seems to work fine, i could start the Freespace 2 campaign without any problems.

5. But i am struggling with the Freespace 1 campaign.

Please check the picture in attachment, im not getting beyond these errors.

I hope someone out there can help, thank you


[attachment stolen by Russian hackers]
« Last Edit: November 18, 2017, 09:54:33 pm by ReaperTR »

 

Offline AdmiralRalwood

  • 211
  • The Cthulhu programmer himself!
    • Skype
    • Steam
    • Twitter
Re: Installation Problems - Freespace Port
It just says it failed without saying why; a screenshot of the final summary might be more helpful, or an archive of the installer's log folder.

Alternatively, there may just have been a temporary server hiccup; if you run the installer again, does it still fail?
Ph'nglui mglw'nafh Codethulhu GitHub wgah'nagl fhtagn.

schrödinbug (noun) - a bug that manifests itself in running software after a programmer notices that the code should never have worked in the first place.

When you gaze long into BMPMAN, BMPMAN also gazes into you.

"I am one of the best FREDders on Earth" -General Battuta

<Aesaar> literary criticism is vladimir putin

<MageKing17> "There's probably a reason the code is the way it is" is a very dangerous line of thought. :P
<MageKing17> Because the "reason" often turns out to be "nobody noticed it was wrong".
(the very next day)
<MageKing17> this ****ing code did it to me again
<MageKing17> "That doesn't really make sense to me, but I'll assume it was being done for a reason."
<MageKing17> **** ME
<MageKing17> THE REASON IS PEOPLE ARE STUPID
<MageKing17> ESPECIALLY ME

<MageKing17> God damn, I do not understand how this is breaking.
<MageKing17> Everything points to "this should work fine", and yet it's clearly not working.
<MjnMixael> 2 hours later... "God damn, how did this ever work at all?!"
(...)
<MageKing17> so
<MageKing17> more than two hours
<MageKing17> but once again we have reached the inevitable conclusion
<MageKing17> How did this code ever work in the first place!?

<@The_E> Welcome to OpenGL, where standards compliance is optional, and error reporting inconsistent

<MageKing17> It was all working perfectly until I actually tried it on an actual mission.

<IronWorks> I am useful for FSO stuff again. This is a red-letter day!
* z64555 erases "Thursday" and rewrites it in red ink

<MageKing17> TIL the entire homing code is held up by shoestrings and duct tape, basically.

 
Re: Installation Problems - Freespace Port
Thank you for your reply, it still fails:
I did not get a final summary, i tried it several times for about 3 hours and waited at least 10 minutes but at some point it stopped to install. While the "next" button is still greyed out i could close with "x" top right.
Thats all i could do. Also tried to manually install "http://www.hard-light.net/forums/index.php?topic=89121.0" (Topic: FreeSpace Port 3.5 + FSPort Media VPs Release!  (Read 31365 times)) but struggling without having an .exe and no clue where to find the launcher, the noted wx launcher didnt show up in my Freespace2 folder. So im kind of stuck, failed on both - installing, and trying to work around the error. ;)

 

Offline jr2

  • The Mail Man
  • 212
  • It's prounounced jayartoo 0x6A7232
    • Steam
Re: Installation Problems - Freespace Port
wx launcher installs to program files (x86)

 

Offline Goober5000

  • HLP Loremaster
  • Administrator
  • 214
    • Goober5000 Productions
Re: Installation Problems - Freespace Port
5. But i am struggling with the Freespace 1 campaign.

Please check the picture in attachment, im not getting beyond these errors.

I just tested the FSPort installation and it works for me.  Can you zip up your "logs" folder and post it as an attachment?  You can find this in the same directory as FreeSpaceOpenInstaller.jar.