Author Topic: cant install fso executables.  (Read 742 times)

0 Members and 1 Guest are viewing this topic.

Offline antsa

  • 25
cant install fso executables.
Ive had this problem for a while and i cant install executables with the fso installer but it seems to work(?) when using manual install but i can only install some versions trough manual installation, or i apparently cant find them. any ideas how to fix this?

The following errors were encountered:

FreeSpace Open 3.8.0 Win64 Standard: The hash value for 'avcodec-57.dll' did not agree with the expected value.  This could indicate a corrupted download or a problem with the mod.  If this problem persists over multiple attempts, contact the mod author for assistance.
Additionally, the installer was unable to delete the file.  Please delete the file yourself and do not open it.
FreeSpace Open 3.8.0 Win64 AVX: The hash value for 'avformat-57.dll' did not agree with the expected value.  This could indicate a corrupted download or a problem with the mod.  If this problem persists over multiple attempts, contact the mod author for assistance.  The file has been deleted.
FreeSpace Open 3.8.0 Win64 AVX: The hash value for 'avutil-55.dll' did not agree with the expected value.  This could indicate a corrupted download or a problem with the mod.  If this problem persists over multiple attempts, contact the mod author for assistance.  The file has been deleted.
FreeSpace Open 3.8.0 Win64 AVX: The hash value for 'SDL2.dll' did not agree with the expected value.  This could indicate a corrupted download or a problem with the mod.  If this problem persists over multiple attempts, contact the mod author for assistance.  The file has been deleted.
FreeSpace Open 3.8.0 Win64 AVX: The hash value for 'swresample-2.dll' did not agree with the expected value.  This could indicate a corrupted download or a problem with the mod.  If this problem persists over multiple attempts, contact the mod author for assistance.
Additionally, the installer was unable to delete the file.  Please delete the file yourself and do not open it.
FreeSpace Open 3.8.0 Win64 AVX: The hash value for 'swscale-4.dll' did not agree with the expected value.  This could indicate a corrupted download or a problem with the mod.  If this problem persists over multiple attempts, contact the mod author for assistance.  The file has been deleted.
FreeSpace Open 3.8.0 Win32 AVX: The hash value for 'avcodec-57.dll' did not agree with the expected value.  This could indicate a corrupted download or a problem with the mod.  If this problem persists over multiple attempts, contact the mod author for assistance.  The file has been deleted.


 

Offline Novachen

  • 29
  • The one and only capella supernova
    • Twitter
Re: cant install fso executables.
Well, you actually have to select only ONE of the builds.

The dlls have the same name for every build, but the dlls that are needed for a Win32 build are different to the Win64 ones.

If you install a Win64 build it expect the hashes for the 64-bit dlls of course... but if the 32-Bit DLLs are already present they are checked and then they are not to be as expected (because they're the 32-Bit ones).

So you have to decide if you want to use Win32 or Win64... both versions in the same folder are not possible.
« Last Edit: May 03, 2018, 08:06:29 am by Novachen »
Female FreeSpace 2 pilot since 1999.
Global moderator in the German FreeSpace Galaxy Forum.

Responsible for the german translation project FreiRaum - FreeSpace auf Deutsch.
Also responsible for the Nova Upgrade Project, which upgrades and fix older campaigns to make them play- and solveable again with current builds and MediaVPs.

Release List:
German Translations:
Awakenings, Between the Ashes 1, Deneb III, FreeSpace 2 (in development), FreeSpace Port, Silent Threat: Reborn & The Destiny of Peace

Nova Upgrades:
A Walk in the Sun, Into the Halls of Valhalla, Luyten Civil War, Renegade Resurgence, Revenge: Final Conflict (in development), Rogues!, Shadow Genesis (de-facto), Storm Front Saga, The Deuterium Connection, Venice Mirror & What If: Another Great War

 

Offline antsa

  • 25
Re: cant install fso executables.
Well, you actually have to select only ONE of the builds.

The dlls have the same name for every build, but the dlls that are needed for a Win32 build are different to the Win64 ones.

If you install a Win64 build it expect the hashes for the 64-bit dlls of course... but if the 32-Bit DLLs are already present they are checked and then they are not to be as expected (because they're the 32-Bit ones).

So you have to decide if you want to use Win32 or Win64... both versions in the same folder are not possible.
installer forces me to select both 32-bit and 64-bit executables with their contents, any way to avert that?
EDIT: apparently this happens because installer detects these both

 

Offline antsa

  • 25
Re: cant install fso executables.
So installer is still forcing me to install 32-bit and 64-bit executables even if i try an clean install.
Any ideas?


[attachment stolen by Russian hackers]
« Last Edit: May 03, 2018, 09:21:58 am by antsa »

 

Offline PIe

  • 28
  • GTVA POLICE
    • freespace3.com
Re: cant install fso executables.
Delete fsoinstaller.properties from your home folder.
[9:50 PM] Sottises: wait did you do vassago's verge?
[9:50 PM] Sottises: .. dirge?
[9:50 PM] Axem: yes
[9:50 PM] Sottises: ohh
[9:50 PM] Sottises: well I have that and JAD too
[9:50 PM] Axem: :)
[9:50 PM] Sottises: what a contrast of themes lmao
[9:50 PM] Axem: isnt it
[9:51 PM] Axem: super grimdark thriller about unknowable alien intelligence and over the top colorful action about friendship
[9:51 PM] PIe: jad is grimdark???
[9:51 PM] Axem: :skull:

[6:23 PM] PIe: why do I have the feeling that I shouldn't be able to give orders to 22nd armored hq
[6:24 PM] Axem: 22nd armored hq, i order you to get me a cup of coffee
[6:24 PM] PIe: and donuts
[6:24 PM] PIe: BECAUSE THIS IS THE GTVA POLICE
[6:25 PM] Axem: :O
[6:25 PM] Axem: am i under arrest
[6:26 PM] [`_`]/: no, just please step out of the myrmidon
[6:26 PM] [`_`]/: you have so much to fred for

 

Offline antsa

  • 25
Re: cant install fso executables.
Delete fsoinstaller.properties from your home folder.
that seems to do the trick, cheers!