Author Topic: [Solved] Trackir5 not working in FSO 3.8.0  (Read 164 times)

0 Members and 1 Guest are viewing this topic.

[Solved] Trackir5 not working in FSO 3.8.0
Hoping someone here can help (sorry for the long post). Just installed the following and cannot get Trackir5 to work:

* Freespace 2 (via GoG Galaxy Client)
* Knossos 0.13.3 (with MediaVPs)
* FSO 3.8.0 (installed via Knossos)
* both scptrackir.dll and scptrackir64.dll from this 3.8.0 release thread:  [**https://tinyurl.com/ybxxfek5**](https://tinyurl.com/ybxxfek5)
* wxlauncher 0.12.0-rc2.exe (but there is a problem with this, see below)

Here's what I did: I installed the game via the GoG Galaxy client; then installed FSO via the Knossos interface, and added the MediaVPs as well. I then downloaded the two .dlls above and copied them in several locations to be sure - they are currently in:

* the default Freespace 2 directory for GoG (where the FS2.exe file is)
* the Games/FreespaceOpen directory (I don't think they need to be here)
* Games/FreespaceOpen/FS2
* my user folder in windows/HardlightProductions/FreeSpaceOpen
* and as above but ../FreeSpaceOpen\FS2

I launch the game via Knossos, and it all runs beautifully, except no trackir.

So I've tried putting the .DLLs (both of them) every where they will fit basically. So am I missing something here?

Should it just work as soon as I go into a mission? (I'm only in training missions at this point).

I've scoured the config settings in game and I can't see anything relevant. I've tried activating freelook via the binding, but it doesn't do anything. Is it supposed to be configured? Or is it supposed to just work?

Note: I got this far and realised I hadn't downloaded and installed the wxlauncher because I didn't think I needed it. I tried, but couldn't set it up because it apparently couldn't find a supported exe file, but I found info to suggest I still don't need it so unless someone tells me I do need it I'm just going to forget about it.

So I have no idea right now what's going on.

Any ideas?

Thanks.

EDIT: If it matters, I have my drive partitioned and install everything on my D: drive. Also, the core game, installed under GoG is within the D:\\Program Files (x86) directory, if that has a baring on anything (I know that is a conflict for some older games).
« Last Edit: December 22, 2018, 04:43:23 pm by FlatStick »

 
Re: Trackir5 not working in FSO 3.8.0
Maybe try pasting these into FreespaceOpen/bin/FSO<build you want to use>/windows/x86 or /x64?
Mito [PL] - Today at 8:52 PM
I was supposed to make a short presentation about basics of optical fibers and here I am, listening to Eurobeat while reading about quantum cryptography.

 
Re: Trackir5 not working in FSO 3.8.0
Yes that was it! Working now, thank you so much!

Which leaves me with the question of why isn't that specific folder mentioned in the instructions for those dll files in the FSO release notes? It just says paste them into the root folder for your installation.

Maybe I'm dumb, but I wouldn't have thought you'd get those specific folders from that instruction. Hopefully in future they add that info in.

In any case, thank you again! :)

 
Re: [Solved] Trackir5 not working in FSO 3.8.0
The instructions don't seem to be updated for Knossos, just that. Actually, a question to someone who's more or less in charge, what's against just throwing TrackIR libraries into FSO build folders in Knossos by default as a part of FSO install?

The issue was that the instructions are meant for a wxLauncher based FSO installation, where every FSO executable is just thrown in the main FSO folder. Knossos has its FSO executables structured into different folders ect. as you might have noticed, and .dll files go in the same directory as the .exe file that is supposed to use them.
(Having different versions of FSO with their respective libraries also caused problems with the old wxLauncher method, i.e. files got overwritten)
Mito [PL] - Today at 8:52 PM
I was supposed to make a short presentation about basics of optical fibers and here I am, listening to Eurobeat while reading about quantum cryptography.