Author Topic: Graphical Issue - Black Bars covering entire screen  (Read 294 times)

0 Members and 1 Guest are viewing this topic.

Graphical Issue - Black Bars covering entire screen
Whenever launching 3.8.0, the intro video plays fine and then as soon as I get into the pilot select and main menu, theres a strange black bar covering up about 1/3 of the screen horizontally, and as I move my mouse around, it gets bigger and moves around. It's rendering the game completely unplayable. I'm on a fresh install of Freespace 2 and Freespace Open as of today, and I haven't even been able to play the game yet because of this. I'm also getting the following errors on launch:

Error: game_settings.tbl(line 2):
Error: Missing required token: [#END]. Found [$Target Version:] instead.

File: parselo.cpp
Line: 290


Error: game_settings.tbl(line 3):
Error: Missing required token: [#END]. Found [+Major: 3] instead.

File: parselo.cpp
Line: 290


Error: game_settings.tbl(line 4):
Error: Missing required token: [#END]. Found [+Minor: 8] instead.

File: parselo.cpp
Line: 290


Error: game_settings.tbl(line 5):
Error: Missing required token: [#END]. Found [+Build: 1] instead.

File: parselo.cpp
Line: 290


Error: game_settings.tbl(line 7):
Error: Missing required token: [#END]. Found [#CAMPAIGN SETTINGS] instead.

File: parselo.cpp
Line: 290


Any help would be greatly appreciated. This is beyond my paygrade.

 
Re: Graphical Issue - Black Bars covering entire screen
Update

Got it working just fine (turns out it was as simple as running it in a window), but now I am having trouble with the HUD scaling. After browsing the forums, I'm still unable to find a proper HUD scale for  playing in 4k. All hud elements are tiny and unreadable.

 
Re: Graphical Issue - Black Bars covering entire screen
It's a known bug, but since none of the coders has 4k hardware they can't reproduce/fix it.

 

Offline m!m

  • 211
Re: Graphical Issue - Black Bars covering entire screen
The errors you are seeing are because you are using a build that is too old for the mod you are playing which requires a 3.8.1 nightly build. To play that mod you will need to update to a nightly build which you can get from the SCP subforum or by using Knossos which will handle that for you automatically.