Author Topic: Refresh Rate  (Read 737 times)

0 Members and 1 Guest are viewing this topic.

Offline AV8R

  • 28
So I got my tax return back and decided to blow some $$ on my PC (which had been neglected for years). I moved from an x86 OS to an x64 OS. I bumped my RAM up to 4GB (from 2GB), upped my video card to a 4GB nVidia 1050 Ti-based card (from a 1GB 750 Ti card) and upgraded my 23" LCD monitor to an MSI 24" curved monitor with 144hz capability. While I love the super-fast refresh rate the new monitor is capable of on most of my games, with FSOpen, there are some issues.

First is the frame cap at 120hz (which is really good performance for what's expected of this engine). But for some reason this rate gives me a lot of judder when large objects (cap ships, stations) turn quickly in view. Everything else moves very fluid (starfields, planets, nebulae, small ships) at 120hz. If I force the refresh rate down to 60hz, EVERYTHING is as smooth as glass when passing by - even during quick turns. I have tried enabling and disabling V-Sync and even shut off every possible extra at 120hz so as not to strain the video card in any way, but in every instance, for absolute frame smoothness, V-Sync on at 60hz still looks beautiful.

With one exception - at 60hz while turning with large objects in view on the screen (again, cap ships, stations) the white or lighter textures will blur significantly with motion (motion-blur). Is this a setting that can be adjusted or turned off?

Also, is there a way to run FreeSpace at a specific refresh rate (a command-line or other option)? I'd like to run it at 60hz since it's smoother, but want to avoid having to go into Windows settings and forcing the refresh down to 60hz before running FSOpen every time.
« Last Edit: April 24, 2019, 08:06:33 pm by AV8R »


Offline CP5670

  • Dr. Evil
  • Global Moderator
  • 212
  • 142857
I've seen this skipping effect at 120hz too. In general, the FSO engine struggles to maintain high framerates on any hardware, especially when there are a lot of ships in the mission. I just play it at 60hz these days, since my monitor (LG OLED TV) lets me use either 1080p at 120hz or 4K at 60hz, and the higher resolution is really worth it in games like FS with long viewing distances.

There is a registry flag called OGL_RefreshRate that let you force a refresh rate at one point, but I'm not sure if it does anything today.
« Last Edit: April 25, 2019, 07:41:54 pm by CP5670 »

It's nothing that is limited to high end mods; but can occur with mods like Homesick (though I haven't played this one myself, only was told that from a reliable source). It came in at some point maybe 1 or 2 years ago and seems like some sort of bug or atleast an issue as it doesn't error or anything despite freezing the game for half a second or so.

2000 posts yay!


Offline AV8R

  • 28
I certainly don't mind playing FSO at 60hz - I did so for years with all of my old monitors and FSO plays just fine at that rate. The best thing now is the card is powerful enough to hold a SOLID 60fps at 60hz with v-sync on no matter what is going on in-game (and this is with every bell and whistle enabled AND AA and AF turned all the way to 16x - it's awesome).

So, I'm guessing there's no switch (or even a registry hack?) to force FSO to run at 60hz?

According to the command line reference on the wiki there doesn't seem to be such a thing.


Offline AdmiralRalwood

  • 211
  • The Cthulhu programmer himself!
    • Skype
    • Steam
    • Twitter
There's a config value (registry if you use old launchers, fs2_open.ini if you use new launchers) called "MaxFPS" that accepts values between 15 and 120 and sets the framerate cap to that value. So if you edit your fs2_open.ini and add "MaxFPS=60" under "[Default]" you should be good to go.

(The reason we cap framerate at 120 FPS has to do with bugs with timers if framerate gets too high.)
Ph'nglui mglw'nafh Codethulhu GitHub wgah'nagl fhtagn.

schrödinbug (noun) - a bug that manifests itself in running software after a programmer notices that the code should never have worked in the first place.

When you gaze long into BMPMAN, BMPMAN also gazes into you.

"I am one of the best FREDders on Earth" -General Battuta

<Aesaar> literary criticism is vladimir putin

<MageKing17> "There's probably a reason the code is the way it is" is a very dangerous line of thought. :P
<MageKing17> Because the "reason" often turns out to be "nobody noticed it was wrong".
(the very next day)
<MageKing17> this ****ing code did it to me again
<MageKing17> "That doesn't really make sense to me, but I'll assume it was being done for a reason."
<MageKing17> **** ME

<MageKing17> God damn, I do not understand how this is breaking.
<MageKing17> Everything points to "this should work fine", and yet it's clearly not working.
<MjnMixael> 2 hours later... "God damn, how did this ever work at all?!"
<MageKing17> so
<MageKing17> more than two hours
<MageKing17> but once again we have reached the inevitable conclusion
<MageKing17> How did this code ever work in the first place!?

<@The_E> Welcome to OpenGL, where standards compliance is optional, and error reporting inconsistent

<MageKing17> It was all working perfectly until I actually tried it on an actual mission.

<IronWorks> I am useful for FSO stuff again. This is a red-letter day!
* z64555 erases "Thursday" and rewrites it in red ink

<MageKing17> TIL the entire homing code is held up by shoestrings and duct tape, basically.


Offline AV8R

  • 28
Thanks, but it's not the FPS I'm trying to limit, but I'm trying to change the refresh rate of the monitor itself from 144hz to 60hz at FSOpen startup. Some of my older games give you this option (choose the resolution you want to run the game in AND the monitor's refresh rate - ie: [email protected] or [email protected]). How the games are coded to do it, I don't know. Others can do it with registry hacks or external software launchers.

I'll just manually set the monitor's refresh to 60hz before playing. Thanks for the suggestions.