Author Topic: sdl failure  (Read 1511 times)

0 Members and 1 Guest are viewing this topic.

Offline daggs

  • 22
Greetings,

I'm trying to get this mod working on a gentoo install with a rx560 card and I'm getting this error: Couldn't set video mode: Couldn't find matching GLX visualERROR: "Unable to initialize display device!" at graphics/gropengl.cpp:1958

is this fixable?

Thanks.

 

Offline ngld

  • Administrator
  • 29
  • Knossos dev
If you run "glxinfo | grep rendering", does it tell you that have direct rendering? If the answer is yes, please run "glxgears" and you should see a 3D animation with moving gears.
If you get an error that the command can't be found, you need to install the x11-apps/mesa-progs package.

If the command tells you that you don't have direct rendering, you need to follow this guide to get a working 3D driver.

 

Offline daggs

  • 22
Greetings,

I'm running flightgear at high resolution without any issues. I think it is pretty safe to say that I have direct rendering.
nonetheless, I've tried what you've suggested, glxinfo | grep rendering returns yes and glxgear works.
my libsdl is of version 1.2.15, libsdl2 is of version 2.0.9.
is there a maximum sdl version I need to use?

 

Offline ngld

  • Administrator
  • 29
  • Knossos dev
Not as far as I'm aware. Which build are you using?  I'm guessing based on the error message but you seem to have a pretty old one.
Try a recent nightly. Also, what launcher are you using?

 

Offline daggs

  • 22
not sure I follow, I wrote a script that does it, here:
Code: [Select]
#!/bin/bash -x

for file in {http://diaspora.fs2downloads.com/Diaspora_R1_Patch_1.1.1.tar.lzma,http://diaspora.fs2downloads.com/Diaspora_R1_Linux.tar.lzma,http://diaspora.fs2downloads.com/Diaspora_R1_Patch_1.1.tar.lzma,https://github.com/scp-fs2open/wxLauncher/archive/0.12.0-rc.3.tar.gz}; do wget ${file}; done
tar xf Diaspora_R1_Linux.tar.lzma
tar xf Diaspora_R1_Patch_1.1.tar.lzma
tar xf Diaspora_R1_Patch_1.1.1.tar.lzma
tar xf Patch_Files.1.1.tar -C Diaspora_R1_Linux/Diaspora/
tar xf Patch_Files.1.1.1.tar -C Diaspora_R1_Linux/Diaspora/
tar xf 0.12.0-rc.3.tar.gz
rm -rf Diaspora_R1_Linux/Diaspora/wxlauncher
mv wxLauncher-0.12.0-rc.3 Diaspora_R1_Linux/Diaspora/wxlauncher
cd Diaspora_R1_Linux/Diaspora/fs2_open/
./autogen.sh
make -j17
cp code/fs2_open_3.7.1 ../fs2_open_diaspora
cd ../
mkdir wxlauncher/build
cd wxlauncher/build
cmake -D USE_OPENAL=1   -D CMAKE_BUILD_TYPE=RelWithDebInfo   -D DEVELOPMENT_MODE=1 ../
make -j17

am I missing something?

 

Offline ngld

  • Administrator
  • 29
  • Knossos dev
3.7.1... That's ancient. We're up to 3.8.0 by now. Also, you're using wxLauncher from the looks of it.

Diaspora is a TC (Total Conversion) for the FSO engine. The downloads you're using are quite old (although they're technically still the official downloads). The engine has been further developed since then so using a newer version might already resolve your issue. A launcher is generally necessary to pass configuration and options to the engine. Form your script I'm guessing that wxLauncher is bundled with Diaspora.

Anyway, the easiest solution is probably to get Knossos. That will guide you through the necessary steps to download the latest version of the engine and Diaspora.
NOTE: You do NOT need Freespace2 to use Knossos and/or play Diaspora.

If you want to use the official download instead, you'll have to download the source code for the latest nightly and compile that or download a finished build and replace your fs2_open folder / the fs2_open_3.7.1 file with that.

 

Offline daggs

  • 22
konssos works ok, thanks.
I do wonder how the heck I'll be able to create an ebuild for that thought.

Thanks.

  

Offline ngld

  • Administrator
  • 29
  • Knossos dev
Here's the packaging script for ArchLinux. That might help.
The important parts are the depends array at the top (dependencies), the sources array (download link) and the package function which builds Knossos and copies the relevant files.