Author Topic: FSO Installer error on Mac OSX 10.14.5  (Read 1556 times)

0 Members and 1 Guest are viewing this topic.

Offline Goober5000

  • HLP Loremaster
  • Administrator
  • 214
    • Goober5000 Productions
Re: FSO Installer error on Mac OSX 10.14.5
The PM attachment worked. :yes:  Download this version and see if it's any better.

 
Re: FSO Installer error on Mac OSX 10.14.5
Hi Goob,

It does something a bit different, but I think it's hung up on something still. My guess looking at the log files is that it's trying to run 'innoextract-1.8-osx', but the extracted file from 'innoextract-1.8-osx.zip' that the installer downloads is 'innoextract'. It then spits out a 'file not found' error. Attached is the log. Maybe I have it wrong.

-dylan

 

Offline Goober5000

  • HLP Loremaster
  • Administrator
  • 214
    • Goober5000 Productions
Re: FSO Installer error on Mac OSX 10.14.5
Ugh.  No, you're exactly correct, and you may have spotted the actual cause of the problem -- not some weird quote style as I erroneously believed.  I couldn't see what was right in front of me. :)  Download this version and see if it works.

 
Re: FSO Installer error on Mac OSX 10.14.5
This FSO Installer appears to work (it gets through the install and reports no errors, but I can't get the game to run. I don't know if this is an issue with the installer or something else.

The installer creates two apps, "fs2_open_3_8_0_x64" and "fs2_open_3_8_0_x64-FASTDBG", and both fail to open, with the system dialog: "The application “fs2_open_3_8_0_x64” can’t be opened." I think I've seen these errors when the OS X dropped support for Universal binary apps (I think?).

The installer also installs a launcher, wxlauncher. This runs fine but it has the error: "FS2 Open did not generate a flag file", with no indication of how to resolve this. Perhaps this is a clue.

I'm not sure what's going on at this point. I don't know enough to be able to make guesses either, unfortunately.

Let me know if you'd like me to try anything.

-dylan

 

Offline Goober5000

  • HLP Loremaster
  • Administrator
  • 214
    • Goober5000 Productions
Re: FSO Installer error on Mac OSX 10.14.5
This FSO Installer appears to work (it gets through the install and reports no errors, but I can't get the game to run. I don't know if this is an issue with the installer or something else.

This means, at least, that the bug is now fixed.  I've also received independent confirmation that someone successfully used the Installer to extract the GOG files on Linux.  I'll post a new release momentarily.

Quote
The installer creates two apps, "fs2_open_3_8_0_x64" and "fs2_open_3_8_0_x64-FASTDBG", and both fail to open, with the system dialog: "The application “fs2_open_3_8_0_x64” can’t be opened." I think I've seen these errors when the OS X dropped support for Universal binary apps (I think?).

You might be right.  This is disappointing, but not a deal breaker.  There are OSX-supported apps in the 19-RC1 release thread which you should be able to use.  I'll make sure the Installer is updated to include them.

Quote
The installer also installs a launcher, wxlauncher. This runs fine but it has the error: "FS2 Open did not generate a flag file", with no indication of how to resolve this. Perhaps this is a clue.

This just means it wasn't able to launch FSO, due to the aforementioned app problem.

Quote
I'm not sure what's going on at this point. I don't know enough to be able to make guesses either, unfortunately.

You've already been extremely helpful.  Thanks!

 
Re: FSO Installer error on Mac OSX 10.14.5
Ok, so I did a bit more work. I tried the precompiled binary (19-RC1), and got a different error, but it similarly wasn't able to open. It says this binary was compiled in 10.11, and I'm running 10.14, so that's likely the issue.

So I went and got the source, to recompile it. Unfortunately, I had to install a bunch of dependencies to get it working, but was able to finally build a binary without error - it even runs!

Unfortunately, it throws the error that indicates I've not installed Freespace2! Which means that, while the FSOInstaller runs, it doesn't appear to do the job of installing freespace2 :(

Lastly, I simply used the innoextract in the command line to extract the gog setup file into the same directory as the newly created binary - this did the trick! I was able to load the game, I think. I clicked around a bit and checked out some of the menus etc., but didn't play anything for now. Hopefully this is the end of the saga of getting the install to work on my computer!

Thanks for you help, let me know if there's something I can do to improve the installer. Hopefully us lowly mac users won't need to go through all this to get it working in the future!

-dylan

 

Offline Goober5000

  • HLP Loremaster
  • Administrator
  • 214
    • Goober5000 Productions
Re: FSO Installer error on Mac OSX 10.14.5
Was the GOG setup file extracted anywhere?  The logs should be able to show you where.  In fact, could you zip up and attach the logs folder?

I've pinged the SCP group to see if anyone has insight on why your version was not supported.

 
Re: FSO Installer error on Mac OSX 10.14.5
I came back to check for replies, but it looks like my post never went through!  I'll try it again.

It didn't extract anywhere, no. It was certainly doing some work, maybe it extracted to the temporary folder, then it was removed?

Attached are the logs. The logs append, apparently, so only focus on the most recent install, on 10/6.

-dylan

P.S. I'd be happy to upload the MacOS binary that works for me, but I think trying to do so is what made the post never go through. Let me know how best to share it and I'd be happy to.

 
Re: FSO Installer error on Mac OSX 10.14.5
Hello all - I am sorry I have been away for such a long time.

Just wanted to see what has been happening...? Is there anything that is needed to be tested by me?

Thanks!

 

Offline Goober5000

  • HLP Loremaster
  • Administrator
  • 214
    • Goober5000 Productions
Re: FSO Installer error on Mac OSX 10.14.5
@WormPicker959 - sorry for the delay; been busy these past few days.  I'll check out the logs ASAP.  In the meantime, if you include the MacOS binary in a zip file, the attachment should work.

@ianvoyager - no worries, WormPicker has been helping a bunch.  I might be able to use your help once I examine his log files, but the main bug -- the out-of-date innoextract -- has been fixed.

 

Offline Goober5000

  • HLP Loremaster
  • Administrator
  • 214
    • Goober5000 Productions
Re: FSO Installer error on Mac OSX 10.14.5
I came back to check for replies, but it looks like my post never went through!  I'll try it again.

It didn't extract anywhere, no. It was certainly doing some work, maybe it extracted to the temporary folder, then it was removed?

Attached are the logs. The logs append, apparently, so only focus on the most recent install, on 10/6.

Ok, I just looked at this.  Check out fsoinstaller.log.  It looks like the files were successfully extracted to /Users/dylanrahe/FreeSpace2/471a56422d3243209263a434b0d020d3.  Then the files were moved to /Users/dylanrahe/FreeSpace2 (which isn't logged; I'll have to add logging statements).  Are there any files in that directory?

 

Offline Goober5000

  • HLP Loremaster
  • Administrator
  • 214
    • Goober5000 Productions
Re: FSO Installer error on Mac OSX 10.14.5
Actually wait.  It turns out that GOG changed the way they package up the application files.  I had to reconfigure the extraction procedure.  I tried it on Windows with the latest EXE version and it worked, so it should work on Mac as well.

Download this version and give it a try.

 
Re: FSO Installer error on Mac OSX 10.14.5
I'm trying to reply with the logs and macos binary attached that worked for me, but I don't think it's going through properly (I don't see the post showing up upon reloading). Not sure what the issue is. Is there another way to attach/send it to you? If you PM me your email I can send you a dropbox link, perhaps.

 

Offline Goober5000

  • HLP Loremaster
  • Administrator
  • 214
    • Goober5000 Productions
Re: FSO Installer error on Mac OSX 10.14.5
Ok.