Author Topic: Release: 19.0.0-RC1  (Read 2489 times)

0 Members and 1 Guest are viewing this topic.

Offline SirKnightly

  • George or Keira?
  • 211
It's finally here!

With this release we decided to drop the "3.Major_revision.Minor_revision" versioning scheme in favor of a year based scheme since the Major and Minor versions did not have much meaning anymore. Instead the scheme will now be "<year>.<number that is incremented every release>.0". The last 0 is still there because some of our systems expect that. It will be gone at some point.

Change log: (chronologically ordered)
  • Various OpenGL optimizations for better graphics performance:
    • Animations now use texture arrays
    • Model uniforms get sent to the GPU using uniform buffers for less overhead
    • Various other, minor changes/li]
  • After just 17 years, full Unicode text support! You can finally use non-ASCII characters without having to worry about special fonts and special characters. This is an opt-in mod flag.
  • Added various translation features for making it easier to only distribute one version of a mod which includes all languages.
  • OpenAL Soft is included by default in binary distributions of FSO now.
  • Added system for dynamically adding new SEXPs. With this a Lua script can expose functionality to the mission which can be used exactly the same as a standard SEXP with all the usual editing features in FRED.
  • Replaced Blinn-Phong BRDF with GGX BRDF
  • Added support for displaying decals on the surface of an object.
  • Refactored bitmap slot handling and removed the fixed upper limit on the number of bitmaps. No more bmpman corruption!
  • Exposed the movie player to the scripting API for advanced display features
  • Integrated support for the Discord Rich Presence API
  • Added new, markup based user interface system using libRocket.
  • Converted pilot files from custom binary format to JSON


Launchers, if you don't have one already:
All platforms: For every day use, we recommend Knossos, an integrated solution for downloading and launching mods.

Hidden Text: Alternative Launchers • Show
Cross-platform: wxLauncher 0.12.x Test Build (ongoing project for a unified launcher, you should upgrade to the latest RC/test build if you have not yet)
Important: For best compatibility with FSO 3.8 and later you should use at least wxLauncher 0.12.

Windows:  Launcher 5.5g (Mirror) (Mirror) Not compatible with Windows 8+, use wxLauncher above
OS X:  Soulstorm's OS X Launcher 3.0
Linux:  YAL or by hand or whatever you can figure out.

Windows (32/64-bit)
Compiled by Appveyor on Windows Server 2012 R2 64-bit, Visual Studio Community 2015 with Update 3

64-bit: fs2_open_19_0_0_RC1-builds-Win64.zip

32-bit: fs2_open_19_0_0_RC1-builds-Win32.zip
This one is based on the SSE2 Optimizations from the MSVC Compiler.

Hidden Text: Alternative builds • Show

64-bit AVX: fs2_open_19_0_0_RC1-builds-Win64-AVX.zip
This one is based on the AVX Optimizations from the MSVC Compiler.

32-bit AVX: fs2_open_19_0_0_RC1-builds-Win32-AVX.zip
This one is based on the AVX Optimizations from the MSVC Compiler (fastest build if your CPU supports AVX instructions).

What are those SSE, SSE2 and AVX builds I keep seeing everywhere?
Your answer is in this topic.
Don't want to deal with that? Use Knossos and it will download the best build specifically for your PC!


OS X Universal (32/64-bit Intel)
Compiled on OS X 10.11.4, Xcode 7.3 (Apple LLVM version cross-reference)

fs2_open_19_0_0_RC1-builds-MacOSX.tar.gz

Linux 64-bit
Compiled on Ubuntu 14.04.4 LTS 64-bit, GCC 5
fs2_open_19_0_0_RC1-builds-Linux.tar.gz

These builds use a mechanism called AppImage which should allow these builds to run on most Linux distributions. However, we recommend that you compile your own builds which will result in less issues.
Alternatively, if there is a package in your software repository then you should use that. If you are the maintainer of such a package for a distribution then let us know and we will include that here.

Hidden Text: Other Platforms, Source Code • Show

Hidden Text: TrackIR Users • Show
Important!!
An external DLL is required for FSO to use TrackIR functions.  The following DLL is simply unpacked in to your main FreeSpace2 root dir.
TrackIR is only supported on Windows.
TrackIR SCP DLL (Mirror) (Mirror)

Known issues:
« Last Edit: September 09, 2019, 11:07:04 am by SirKnightly »

 

Offline Nyctaeus

  • Betrayal is his middle name
  • 211
  • Your local priest of cheeki breeki!
    • Minecraft
    • Exile
Exile | Shadow Genesis | DA Profile | P3D Profile

Proud owner of NyctiShipyards. Remember - Nyx will fix it!

All of my assets including models, textures, skyboxes, effects may be used under standard CC BY-NC 4.0 license.

 
 :yes: :yes: :yes: :yes:

BTW why does the OP suggest every launcher except Knossos?

 
:yes: :yes: :yes: :yes:

BTW why does the OP suggest every launcher except Knossos?
Right?
"Any idiot can face a crisis; it is this day to day living that wears you out." – Anton Chekhov

 

Offline Mongoose

  • Rikki-Tikki-Tavi
  • Global Moderator
  • 212
  • This brain for rent.
    • Minecraft
    • Steam
    • Something
I believe the form text for the release post was written well before Knossos was a glimmer in anyone's eye.

 
It appears so. Also I'm pretty sure 64-bit builts are pretty common now because, well, I am one of the last people using the 32 ones. Did nobody bothered to check what Mr. Knightly was going to post?

 

Offline m!m

  • 211
The template was still around from the 3.8 release and we did not update the relevant parts for the new release. I'll try to write some new text this weekend and update the template for the next releases.

 
So uhh... release notes?

 

Offline m!m

  • 211
There, I added them. That was ... uh ... because of the forum downtime! Yes. That was the only reason why it took this long :nervous:

 
There are some great improvements and fixes in this build. Some little things like integrating the OpenAL library in the release package itself are welcome too. Good job for everyone involved!  :pimp:

I also like the change of version number to a year-based one although I hope that you also stick with your decision. On the MediaVP side there was too much flip-flopping (first MediaVP 3.6.12, then "MediaVP 2014" and then MediaVP 3.8.x).

 
I am very interested in trying this out.  I have a question, however.  I am a huge fan of Babylon 5, and I have always wanted to try out The Babylon Project mod for FS2.

I was wondering if the most current version of this mod would work with this installation?

The Babylon Project seems to have been largely abandoned, but there is a mod on this forum as of 2013, here:  https://www.hard-light.net/forums/index.php?topic=85449.0

The mod files can be accessed here:  https://www.moddb.com/games/the-babylon-project/downloads

The mod files state that they worked as of the 3.7.0 build.  I am not sure if they would still be compatible with 19.0.0-RC1?

I apologise for asking about a mod in this thread, but the latest post on that Zathras 2.8 discussion was in 2014 and I thought it would be too much Thread Necromancy to resurrect a thread that long dead.

 
 
TBP hasn't been abandoned: https://www.hard-light.net/forums/index.php?topic=92118.msg1887460#new

Awesome!  Thank you very much!  I guess I was looking at Zathras, and TBP had it's own thread.  Anyways, I am glad it isn't dead.

 

Offline AV8R

  • 28
This release candidate still crashes on startup for me as discussed here:

https://www.hard-light.net/forums/index.php?topic=95855.0

Member m!m located and fixed the joystick bug. Will the fix be rolled into RC2, perhaps?

 

Offline m!m

  • 211
RC2 will be based on the current master branch so it will contain the fix for that crash.

 

Offline AV8R

  • 28
Thank you for your reply, kind sir. :yes:

 

Offline SF-Junky

  • 29
  • Bread can mold, what can you do?
When I run this through wxLauncher, my Joystick is not working. It is not functioning throughout the game. I simply tried the MVPS-3.8.2 and ran the FS2 main campaign. The Joystick is, however, recognized by the launcher under "basic settings".

When I launch through Knossos everything works fine.

 

Offline Goober5000

  • HLP Loremaster
  • Administrator
  • 214
    • Goober5000 Productions
I think the wxLauncher joystick code, which hasn't been updated in a while, is not as robust as the Knossos joystick code.  Try unplugging and re-plugging it, re-selecting it, and re-starting the game.

 

Offline SF-Junky

  • 29
  • Bread can mold, what can you do?
This is not working.

I just saw that the problem has existed before: https://www.hard-light.net/forums/index.php?topic=93290.0

The solution proposed in that thread - "store config in portable location" - does not work either, though. When I enable that, I see the loading screen for a few seconds and then I go back the desktop screen.

I tried older nightly builds, with no effect. Went back to early 2016.

Guess I'll have to switch to Knossos...

 

Offline Novachen

  • 29
  • The one and only capella supernova
    • Twitter
Well, wxLauncher is using SDL2 2.0.3 by default. In my All-in-One Installer i always pack wxLauncher with the current SDL2 version, which is 2.0.10.
The problem with 2.0.3 is.. it assign different GUIDs than newer versions... so the game always expect another GUID than you get via wxLauncher.

Copy the 32-bit SDL from LibSDL into your wxlauncher/bin folder and it should work... as it use the same GUID as FSO's SDL2.
Female FreeSpace 2 pilot since 1999.
Global moderator in the German FreeSpace Galaxy Forum.

Responsible for the german translation project FreiRaum - FreeSpace auf Deutsch.
Also responsible for the Nova Upgrade Project, which upgrades and fix older campaigns to make them play- and solveable again with current builds and MediaVPs.

Release List:
German Translations:
Awakenings, Between the Ashes 1, Deneb III, FreeSpace 2 (in development), FreeSpace Port, Silent Threat: Reborn & The Destiny of Peace

Nova Upgrades:
A Walk in the Sun, Into the Halls of Valhalla, Luyten Civil War, Renegade Resurgence, Revenge: Final Conflict (in development), Rogues!, Shadow Genesis (de-facto), Storm Front Saga, The Deuterium Connection, Venice Mirror & What If: Another Great War