Author Topic: BP - Knossos says FSO is missing  (Read 149 times)

0 Members and 1 Guest are viewing this topic.

Offline darkdaej

  • 27
  • Wingmen: Useless buggers
BP - Knossos says FSO is missing
Hmm, interesting problem.

So I updated BP yesterday and tried launching it a few minutes ago.  Got an error message.  Other mods work fine.

If I leave FSO settings on Mod Default, I get a "I couldn't find an executable.  Aborted" error.

Now this is interesting...  If I manually select my FSO build (3.8.0-3) I get this:

"Blue Planet Complete" (1.0.5) requires "FSO" which is missing! (>=3.8.1-20190829)

So I'm thinking I need to update FSO.  No updates on Knossos...so I check here...and I don't see any release thread for 3.8.1...

So...what gives?  And what can I do to fix this?

EDIT: I did verify file integrity and no problems were detected.

 

Offline Colt

  • 27
  • Needs more dakka
    • Steam
Re: BP - Knossos says FSO is missing
I'll try my best to help until someone with more experience comes along.

Hmm. What "preferred engine stability" do you have? On my end I have nightlies on, and have those plus the newer release candidate available (FSO 19.0.0-RC1).

Also check the "modify" option on BP:C. Perhaps something is missing there that needs to be downloaded?

 

Offline darkdaej

  • 27
  • Wingmen: Useless buggers
Re: BP - Knossos says FSO is missing
I'll try my best to help until someone with more experience comes along.

Hmm. What "preferred engine stability" do you have? On my end I have nightlies on, and have those plus the newer release candidate available (FSO 19.0.0-RC1).

Also check the "modify" option on BP:C. Perhaps something is missing there that needs to be downloaded?

Well I use the latest stable build.  I don't really experiment with nightly builds all that much anymore :P

I checked the modify option.  I got FSO 19 RC1 (it's bundled with BP's newest version) and of course it reinstalled it again while I was checking.

I'll see if reinstalling fixed it in a few minutes...

 

Offline darkdaej

  • 27
  • Wingmen: Useless buggers
Re: BP - Knossos says FSO is missing
Well, hmm...this just got even more interesting.

Reinstalling allowed FSO to boot and I got the intro cutscene.

And then got the warning you can see in the attached file.

Seems FSBlue works.  Managed to start the first training mission without a hitch (are those new backgrounds for the mission briefing or is it just me?), but I couldn't even select Age of Aquarius of War in Heaven Part 1 in the campaign room.  Part 2 and the other warship campaign loaded but I got an error saying my pilot savefile was invalid.

 

Offline Colt

  • 27
  • Needs more dakka
    • Steam
Re: BP - Knossos says FSO is missing
Yeah I was able to replicate the attached problem with the 3.8.0 versions. Those are outdated.

What about the FSO mod itself? Check the "modify" and see if it allows you to download the newer RC. Perhaps changing the engine stability to RC might do the trick as well.

 

Offline darkdaej

  • 27
  • Wingmen: Useless buggers
Re: BP - Knossos says FSO is missing
There's no newer version available if I check Modify under the FSO mod.  It says the latest is 3.8.0-3, last updated sometime in 2018

 

Offline Colt

  • 27
  • Needs more dakka
    • Steam
Re: BP - Knossos says FSO is missing
I switched engine stability to "stable" and got everything you have. Switch it to RC's and FSO should download the new version.

 

Offline darkdaej

  • 27
  • Wingmen: Useless buggers
Re: BP - Knossos says FSO is missing
Ah, ok.  Fixed.  Thanks :P

 
Re: BP - Knossos says FSO is missing
You could also have checked in "FSO Settings" of the mod which build it's trying to use. Just a small note, FYI.
Mito [PL] - Today at 8:52 PM
I was supposed to make a short presentation about basics of optical fibers and here I am, listening to Eurobeat while reading about quantum cryptography.