Author Topic: Invisible Ships  (Read 156 times)

0 Members and 1 Guest are viewing this topic.

Hello again

This is on Knossos 0.13.3

Problem: Ships are mostly invisible. The lights are blinking, but the rest of the ship is not present. This problem is consistent across all mods.

Debug log: https://fsnebula.org/log/5da3a8abcb0d3320a6dd818d

MediaVP version: 3.8
FSO: 19.00

Driver:  AMD Radeon HD 5900 Series
OS: Windows 7 (64 bit)
 CPU Brand:  Intel(R) Core(TM) i7 CPU  X 980  @ 3.33GHz

One final note: Every once in a while, everything will be fine. I'll launch the game and the models will be right there. If I exit the program and relaunch, it's back to invisibility.  :nervous:
« Last Edit: October 13, 2019, 06:11:58 pm by Bad_Horse »

 
Code: [Select]
OpenGL Debug: Source:OpenGL Type:Error ID:2160 Severity:High Message:glDrawBuffer failed because '0x8ce4' is not a compatible or supported buffer type under the current framebuffer configuration (GL_INVALID_OPERATION)
OpenGL Debug: Source:OpenGL Type:Error ID:1000 Severity:High Message:glReadBuffer has generated an error (GL_INVALID_OPERATION)
OpenGL Debug: Source:OpenGL Type:Error ID:2160 Severity:High Message:glDrawBuffers failed because '0x8ce0' is not a compatible or supported buffer type under the current framebuffer configuration (GL_INVALID_OPERATION)
OpenGL Debug: Source:OpenGL Type:Error ID:2160 Severity:High Message:glDrawBuffer failed because '0x8ce0' is not a compatible or supported buffer type under the current framebuffer configuration (GL_INVALID_OPERATION)
OpenGL Debug: Source:OpenGL Type:Error ID:2160 Severity:High Message:glDrawBuffer failed because '0x8ce4' is not a compatible or supported buffer type under the current framebuffer configuration (GL_INVALID_OPERATION)
OpenGL Debug: Source:OpenGL Type:Error ID:2160 Severity:High Message:glDrawBuffer failed because '0x8ce0' is not a compatible or supported buffer type under the current framebuffer configuration (GL_INVALID_OPERATION)
OpenGL Debug: Source:OpenGL Type:Error ID:1000 Severity:High Message:glReadBuffer has generated an error (GL_INVALID_OPERATION)
OpenGL Debug: Source:OpenGL Type:Error ID:1000 Severity:High Message:glReadBuffer has generated an error (GL_INVALID_OPERATION)

Woah, that sounds like trouble. A question for SCP staff, is it possible that it's caused by some sort of driver error or conflict? (Updating your GPU drivers might be a good idea)
Mito [PL] - Today at 8:52 PM
I was supposed to make a short presentation about basics of optical fibers and here I am, listening to Eurobeat while reading about quantum cryptography.

 
I updated my drivers again, and did  a clean install. I installed Blue Planet, and the game ran just fine. I exited out and relaunched, and the problem was back again.

 

Offline Trivial Psychic

  • 212
  • Snoop Junkie
In my experience, earlier AMD cards do have issues with partial or completely invisible ships, or lighting issues.  I had a 5770 before and I had issues all the time.  Often I would boot up a new build and things would work properly, then close it, then boot it again and the problem would return.  Sometimes I could use a build for a few weeks before it failed.  A year ago I upgraded my entire hardware package, tower and all.  I replaced it with an RX 570 and the problem went away.
The Trivial Psychic Strikes Again!