Author Topic: Graphics problems (Knossos)  (Read 258 times)

0 Members and 1 Guest are viewing this topic.

Graphics problems (Knossos)
Hey,

so I recently reinstalled the game and mods with the new knossos launcher and got some questions about it. (also happens with the wxlauncher though)

1. Why do all the ships look kind of dull/washed out? In the command briefings the models got a nice, shiny metallic look to them like I remember back from the old mediavps but ingame they are looking like clay with some ships having "kind of" reflective surfaces. (happens across every mod and base game)

2. I do not remember such excessive stuttering. Everytime a big ship explodes, jumps in, scripted events happen or sometimes just randomly my frames drop from 120 all the way down to 70ish. That doesn't sound too bad, I know, but the game stutters for like half a second (neither gsync nor elmb adaptive sync prevent that and given my RTX2080ti/i9 9900K machine this really should not happen since I don't even have every demanding graphics option turned on)
Also occurs for every mod.

3. Sometimes I get audio stutter and/or missing sounds. This gets accompanied by the video stutter or just happens by itself.

Doy you guys have any tips for me? Would greatly appreciate any help because I love the games since I was a little kid :)

 
Re: Graphics problems (Knossos)
1. Sorry to ask but are you sure you have MVPs installed and active? In that case you should be seeing a FS-SCP logo and a Herc 2 as preloading screen before you come to pilot selection.

2. It's a known issue of FSO. These loading bumps somehow came into the programm; don't know why or how but they have been there for a while. It's not a problem on your side.

 

Offline wookieejedi

  • 28
  • Intensify Forward Firepower
Re: Graphics problems (Knossos)
2. Yeah, those are caused by the game's shaders being loaded for the first time a ship arrives. If a ship with the same textures and ship class is already in the mission then those lag spikes will be very minimal, to even non-existent.

 
Re: Graphics problems (Knossos)
1. Sorry to ask but are you sure you have MVPs installed and active? In that case you should be seeing a FS-SCP logo and a Herc 2 as preloading screen before you come to pilot selection.

2. It's a known issue of FSO. These loading bumps somehow came into the programm; don't know why or how but they have been there for a while. It's not a problem on your side.

Yeah, I got them installed. I heard somewhere that there was a downgrade in graphics quality with the recent FSO build. Could this be my problem? I mean, don't get me wrong, I have all the new models (geometrically) but the lighting and practically non existent metallic reflections on the ships ingame is just off. In briefing/tech room/ship and weapon selection it all works fine.

 
Re: Graphics problems (Knossos)
At some point PBR (physically based rendering) was introduced into FSO, which changed the reflective lighting from either based on sort of reflect or other type of maps to based on a separate roughness/metallicity texture, or something along the lines - I have no idea how it works in detail :D. What's important is that it lets models with properly crafted PBR maps to look much much better, while it doesn't really look as good for models without them. So one problem might be that you're playing with models without PBR maps which are still very numerous in MediaVPs.

On the other hand, a different complaint might be that lighting itself is dull and without variance, that's because FSO currently has got extremely high ambient lighting in the default lighting settings. I suggest trying out some lighting settings that might fix this. Some presets are here https://wiki.hard-light.net/index.php/Sample_Lighting_Settings and if you want to try and experiment with values, see explanations of the flags here https://wiki.hard-light.net/index.php/Command-Line_Reference#Lighting.

Watch out for -no_emissive_lighting and -emissive_lighting. The former is used in builds roughly before 19.0.0-RC2 (including 3.7.X, 3.8.X and 19.0.0-RC1) and it disables emissive lighting (which is on by default), while the latter is used in builds starting from the mentioned RC2 because there emissive lighting is off by default. I suggest forcing emissive lighting to off and having shadows turned on too for cool looks.

My personal setup is -ambient_factor 73 -spec_point 0.3 -spec_static 1.0 -spec_tube 0.4 -bloom_intensity 45 (with emissive lighting off).

Also note that you can experiment with lighting settings on the go - without relaunching FSO - in the Lab. Just press F3 in the main menu, select a ship and a background and try out some checkboxes and sliders. This lets you look at your ship of choice with the background of every mission available.
« Last Edit: January 17, 2020, 07:22:35 am by MitoPL »
Mito [PL] - Today at 8:52 PM
I was supposed to make a short presentation about basics of optical fibers and here I am, listening to Eurobeat while reading about quantum cryptography.

 
Re: Graphics problems (Knossos)
At some point PBR (physically based rendering) was introduced into FSO, which changed the reflective lighting from either based on sort of reflect or other type of maps to based on a separate roughness/metallicity texture, or something along the lines - I have no idea how it works in detail :D. What's important is that it lets models with properly crafted PBR maps to look much much better, while it doesn't really look as good for models without them. So one problem might be that you're playing with models without PBR maps which are still very numerous in MediaVPs.

On the other hand, a different complaint might be that lighting itself is dull and without variance, that's because FSO currently has got extremely high ambient lighting in the default lighting settings. I suggest trying out some lighting settings that might fix this. Some presets are here https://wiki.hard-light.net/index.php/Sample_Lighting_Settings and if you want to try and experiment with values, see explanations of the flags here https://wiki.hard-light.net/index.php/Command-Line_Reference#Lighting.

Watch out for -no_emissive_lighting and -emissive_lighting. The former is used in builds roughly before 19.0.0-RC2 (including 3.7.X, 3.8.X and 19.0.0-RC1) and it disables emissive lighting (which is on by default), while the latter is used in builds starting from the mentioned RC2 because there emissive lighting is off by default. I suggest forcing emissive lighting to off and having shadows turned on too for cool looks.

My personal setup is -ambient_factor 73 -spec_point 0.3 -spec_static 1.0 -spec_tube 0.4 -bloom_intensity 45 (with emissive lighting off).

Also note that you can experiment with lighting settings on the go - without relaunching FSO - in the Lab. Just press F3 in the main menu, select a ship and a background and try out some checkboxes and sliders. This lets you look at your ship of choice with the background of every mission available.

Thanks, I've managed to fix it^^ Though most ships in War in Heaven still look bad. Also in the freespace blue campaign the medal case is graphically bugged. The case is like badly cut out. Can see all the medals but the case is just not there. Is that just a problem with the mod in general or am I missing a file?

 
Re: Graphics problems (Knossos)
If you were missing some file you would probably either notice many other problems, I think it's just because the mix of a) how the medal menu works and b) that new backgrounds for menus were introduced and someone seems to not have bothered creating a specific background for the medal menu. But it's not like you get any medals in BP, except the Ace ones I think.

Also see if you have installed bp_advanced packages, they have higher quality effects and models/textures and are optional. Hover over the mod tile, extend the dropdown menu and select Modify, you can see selected packages there.
Mito [PL] - Today at 8:52 PM
I was supposed to make a short presentation about basics of optical fibers and here I am, listening to Eurobeat while reading about quantum cryptography.

 
Re: Graphics problems (Knossos)
If you were missing some file you would probably either notice many other problems, I think it's just because the mix of a) how the medal menu works and b) that new backgrounds for menus were introduced and someone seems to not have bothered creating a specific background for the medal menu. But it's not like you get any medals in BP, except the Ace ones I think.

Also see if you have installed bp_advanced packages, they have higher quality effects and models/textures and are optional. Hover over the mod tile, extend the dropdown menu and select Modify, you can see selected packages there.

Yeah, I do have the advanced packages. I actually managed to fix the medals by getting a file from mjn mixael.
Also I am using Herra Tohtori's settings for the lighting but it is giving me errors that the command line parameters -spec_exp and -ogl_spec are unrecognized. Any ideas why? Also what settings do you use for the knossos launcher? (graphics, gameplay, hud, etc....)

Thanks for the help btw, I greatly appreciate it :)

 
Re: Graphics problems (Knossos)
Quote
Deprecated lighting presets
Note: These settings are obsolete as of FSO 3.8.0
I think that explains it, there were multiple changes made. Modern lighting presets are at the top.

Also remember, you can tweak settings on your own. For a nice testing experience, use the Lab as I mentioned earlier. It lets you check how different values look like on the go so you can find your favourite values and input them into the commandline. The sliders let you try out different values of the ambient factor, stength of the light from suns and the intensity of bloom. Note that changes made in Lab won't carry over outside of it. Also in my opinion turning off emissive lighting and turning on shadows is a must.

As for my settings (from FSO 19.0.0-RC2):
Graphics: Disable motion debris, enable 3D shockwaves, enable post proccessing, enable soft particles, enable FXAA, enable framebuffer thrusters, enable framebuffer shockwaves, enable shadows - these flags are turned On. The rest forced to Off.
HUD: Everything but the last option turned On.
Gameplay: Everything On.
Ingame in graphics options everything to maximum (yes these settings matter too).
Mito [PL] - Today at 8:52 PM
I was supposed to make a short presentation about basics of optical fibers and here I am, listening to Eurobeat while reading about quantum cryptography.