Author Topic: Screen Tearing on FSPort (Knossos)  (Read 110 times)

0 Members and 1 Guest are viewing this topic.

Screen Tearing on FSPort (Knossos)
Hi guys, I apologize if there is an obvious solution to this; I can't seem to find it.  Basically FSPort has wicked screen tearing as launched through Knossos.  I suspect VSync isn't running.  Is there a flag to enable it?

I noticed there are command line arguments you can send to disable vsync, but that's the opposite of what I need.  Perhaps I can use the nvidia control panel to force vsync for this particular .exe, but I'm not sure what .exe is actually being executed when I launch FSPort through Knossos.

Thanks guys.

 
Re: Screen Tearing on FSPort (Knossos)
I just wanted to say that I seem to have fixed my issue.  :)

How I fixed the screen tearing with Nvidia control panel:

1.) Open Nvidia control panel
2.) Go to Manage 3D Settings link on the left
3.) Select the Program Settings tab
4.) Add a new program
5.) Go to your freespace installation folder. Mine was: C:\Games\FreespaceOpen\bin\FSO-19.0.0\windows\
6.) You'll notice there are four directories in there (x64, x64_avx, x86, x86_avx)
7.) Within the x64 folder, select the executable to add: fs2_open_19_0_0_x64_AVX.exe
8.) Once added, go down to the vsync setting and turn it ON.
9.) Do steps 4-8 with the other executables in x64_avx, x86, and x86_avx
10.) Hit apply then exit.

For good measure I'd just restart Knossos.  Now the screen tearing is gone and the gameplay is smooth  :)

  

Offline AV8R

  • 28
Re: Screen Tearing on FSPort (Knossos)
To make sure Knossos has VSync set for FSPort, from within Knossos:

1) Find the FSPort panel and hover your mouse cursor over it.
2) On the lower edge of the panel to the right slightly you'll see a downward-pointing arrow. Click on that and a menu will appear.
3) From the menu, select FSO Settings
4) From the Settings box that appears, select your EXE in the FSO Build field.
5) Under the Flag List Type field, select Game Speed.
6) Be sure Disable Vertical Sync is NOT checked (most FSO mods should have this setting off by default anyway).

Also, as an nVidia graphics card user, you can globally set VSync to be on for ALL games under the nVidia Control Panel 3D settings by setting Vertical Sync to "ON" instead of the default "Use the 3D application setting".

I use VSync for all games at 60hz (even though my nVidia card and monitor support 144hz) because its usually provides a better quality experience visually by preventing image tearing and frame-rate drop.