Author Topic: JOYSTICK will not bind (Could not, for the life of me find the solution_  (Read 150 times)

0 Members and 1 Guest are viewing this topic.

JOYSTICK will not bind (Could not, for the life of me find the solution_
I genuinely tried to find the solution to this problem before posting, and I could not find it anywhere. If anyone can link me to a relevant post about it that'd be fine.

My problem: I had already been playing FS2 open with a Logitech extreme pro 3d, I was able to bind all axis's and had no issues. I downloaded Knossos and wanted to play the Upgrade MediaVPs, but now I cannot bind anything on my joystick that isn't a button. (In this case, all I'm trying to do is bind banking and turning)

I've tried turning force feedback and direction hit on and off in the knossos launcher, to no luck.

Sorry, I feel like a noob for asking. I just picked this game up yesterday after not playing it for 15 years.

 

Offline deathspeed

  • 29
  • i can't think of a good avatar
    • Steam
Re: JOYSTICK will not bind (Could not, for the life of me find the solution_
Have you tried setting your joystick as the preferred controller in Windows?  In Windows 10, click start and search for "set up USB game controllers."  Select your joystick and click "advanced", and again select your controller and click OK.

You may have already checked, but there are several joystick/controller threads here: https://www.hard-light.net/forums/index.php?topic=91694.0

Good luck!!
Maybe someday God will give you a little pink toaster of your own.

 

Offline wookieejedi

  • 29
  • Intensify Forward Firepower
Re: JOYSTICK will not bind (Could not, for the life of me find the solution_
Also, just to check, does you Knossos settings page look like this? (Click the Gear icon to open the settings page. Also note that it should say Logitech 3D Pro.)




 
Re: JOYSTICK will not bind (Could not, for the life of me find the solution_
I have looked at that thread, couldn't find any answers.

Also my knossos looks like this. Still no luck. The problem I'm having is not that my Joystick is unresponsive, its that I can't bind banking/turning differently in options like I was able to prior to downloading knossos.

Hence my utter confusion.

 

Offline deathspeed

  • 29
  • i can't think of a good avatar
    • Steam
Re: JOYSTICK will not bind (Could not, for the life of me find the solution_
I don't think this response is for quite the same issue, but maybe it's worth a shot to check:

In the settings you want to set "Bank Axis" in the Ship tab (instead of Bank Left and Bank Right). Select that control, click "Bind" and then twist your joystick handle. It should say something like "Joystick Z Axis". Then click on the Accept button. You might need to do this for each campaign you play, you'll definitely need to do it for each pilot you create. Hope that helps!

Also, do you know which build you are using?  In Knossos under settings -> Knossos, I have my "preferred engine stability" set to "Nightly" to get the latest builds.  You might try "RCs" or "Stable" if you are already on "Nightlies."
Maybe someday God will give you a little pink toaster of your own.