Author Topic: Knossos Problem - Error pop up [Solved]  (Read 367 times)

0 Members and 1 Guest are viewing this topic.

Offline Frenzer

  • 22
Knossos Problem - Error pop up [Solved]
When I try to startup anything via the Knossos Launcher I get the attached error pop up.
I have tried to reinstall and even move directories of both Freespace 2, Knossos and the Freespace Open folder. The pop up still remains the same, and I have no idea how to fix it.
I am using the Steam version of Freespace 2, which runs fine on it's own without Knossos.
« Last Edit: December 08, 2020, 12:23:11 pm by Frenzer »

 
Re: Knossos Problem - Error pop up
Your username is the issue here, Knossos can't handle that fancy "A" you have in there. Uh, I think we somehow should figure out a way to force Knossos/FSO to use the public documents path instead?
Mito [PL] - Today at 8:52 PM
I was supposed to make a short presentation about basics of optical fibers and here I am, listening to Eurobeat while reading about quantum cryptography.

 

Offline Frenzer

  • 22
Re: Knossos Problem - Error pop up
Ok, that's weird since I've played Freespace Open with Knossos before and never had this problem.
If there's any workaround, I'd be happy to hear one.

 
Re: Knossos Problem - Error pop up
Now before anyone more knowledgeable on the subject jumps in, I might have an idea. What happens if you navigate to Knossos settings (gear symbol in topright corner), Global Flags section, List Type "Launcher" and force the "Store config in portable location" setting to "On" for all your builds, of course save the changes, and try again?
Mito [PL] - Today at 8:52 PM
I was supposed to make a short presentation about basics of optical fibers and here I am, listening to Eurobeat while reading about quantum cryptography.

 

Offline Frenzer

  • 22
Re: Knossos Problem - Error pop up
As soon as I select an FSO build (FSO 19.0.0 is the only one since I haven't installed any other mods yet) the same pop up message keeps appearing.
I can't change any of the setting as it keeps popping up either, unfortunately.

 

Offline jg18

  • A very happy zod
  • 210
  • can do more than spellcheck
Re: Knossos Problem - Error pop up
The error popup you are seeing is caused by FSO and not by Knossos.

The reason you see it whenever you select a build is that when you do that, Knossos automatically retrieves the global flags that that build supports, which in turn requires running FSO with a special -get_flags flag. Apparently, even when FSO runs in the -get_flags mode, the code that validates your FSO preferences path still runs, hence this error popup.

AFAIK there is no way to choose a custom FSO preferences path. This preferences folder is for storing your engine config (graphics etc.), save games, and other engine-related logs/data. It's completely separate from the path that Knossos uses for its own preferences.

Unfortunately, the only way around this issue may be to create a separate Windows user account whose name has only ASCII characters in it (that is, only English letters) and use that for Knossos/FSO-based games.

I wonder if the FSO GitHub issues page includes an issue for this.

 

Offline Frenzer

  • 22
Re: Knossos Problem - Error pop up
That is still very weird since I've played FSO both with and without Knossos (even though you say Knossos isn't at fault) on this very machine several times and have never had this problem before....
Is the path it's using some new addition or something?

 

Offline Frenzer

  • 22
Re: Knossos Problem - Error pop up
Ok, so I just went through the process of changing the name of my C:/Users folder, which has now solved the problem I was having.
Anyone will similar issues will likely have to do the same.

 

Offline jg18

  • A very happy zod
  • 210
  • can do more than spellcheck
Re: Knossos Problem - Error pop up
Cool, glad you got it working.

To answer your question:
Is the path it's using some new addition or something?
The relevant FSO code changes were merged in March 2016. I don't know offhand when the next official release after that was.