Author Topic: Endless spinning in freespace 2 open(knossos) using Logitech 3d pro  (Read 1154 times)

0 Members and 1 Guest are viewing this topic.

Endless spinning in freespace 2 open(knossos) using Logitech 3d pro
When I run freepace2 open in Knossos the throttle causes the screen to spin and the twist doesn't work. I tried to do what was suggested in another topic but couldn't because the in game options do not have any throttle or twist configurations and the Joystick setting in Knossos only lets you choose what Joystick your using and nothing else. I have Windows 10 64bit

I would suggest you add options for configuring the joystick throttle and twist in Knossos.

Any help would be appreciated.

 

Offline Solatar

  • 211
Re: Endless spinning in freespace 2 open(knossos) using Logitech 3d pro
In the in-game options, go to the Ship tab, then you may have to scroll down to "Bank Axis" and the other Axis binds. On my Logitech 3d Pro, I think by default when you start a new pilot, it has the Bank Axis mapped to the little throttle control on the stick. So if you have the throttle all the way up, it will make you spin in one direction. All the way down, and you start the mission spinning the other way.

In the in-game options, just bind the Bank Axis to you twisting the stick (Click it, click Bind, then twist the stick and it will say Z Axis), and bind the Absolute Throttle Axis to the little throttle slider if you want to use that, too.

Control settings are saved per pilot.

 

Offline Mongoose

  • Rikki-Tikki-Tavi
  • Global Moderator
  • 212
  • This brain for rent.
    • Minecraft
    • Steam
    • Something
Re: Endless spinning in freespace 2 open(knossos) using Logitech 3d pro
Also, make sure your throttle is set to the minimum before trying to bind another axis. If it's not at the minimum, it'll override any other axis you attempt to bind.