Author Topic: 2007-10-28 stable branch (Xt version)  (Read 58784 times)

0 Members and 1 Guest are viewing this topic.

Offline taylor

  • Super SCP/Linux Guru
  • Moderator
  • 212
    • http://www.icculus.org/~taylor
2007-10-28 stable branch (Xt version)
I wasn't really wanting to release this sort of build so soon, but so much has been changed/fixed over the past week that I wanted to get it out a bit earlier than originally intended.  This will likely be the last public build from me for a couple of weeks though.

Windows build
Linux build (32-bit, binaries only)
OS X build

Source tarball


Basic changelog:

  • fixed Mantis 1513 (crash when creating multi player pilot on clean install)
  • fixed Mantis 1378 (DirectSound capture working again, maybe, someone will have to confirm it)
  • fixed 2D Mission checkbox not being set properly after loading a 2D mission in FRED
  • fixed awacs settings for subsystems getting reset when using TBMs (thought this was fixed already, but apparently not)
  • fixed texture corruption bug that messed up the loading screen sometimes (will hopefully fix the loading bar too)
  • make sure that Warning() messages are sent to the debug log since it will no longer use popups (until the new in-game code is done)
  • fix subsystems memory handling, so that it's not just some freak of nature
  • fix texture memory leak that can happen with render targets
  • improve (slightly) texture state management handling
  • fix several memory leaks in the ships lab
  • sanity check $Closeup_zoom: tbl entry, it must be >0 to avoid screwing up the frustum setup
  • fix various bugs/slowdowns caused by not handling animated cursors properly
  • fix vertex-color settings (most noticeable in help screens)
  • minor performance enhancement to batcher (particles, weapons, etc.)
  • ~25% performance boost to basic drawing function (used for all interface stuff and certain in-game effects)
  • fix several small OpenGL memory leaks
  • fix ship/weapon loadout getting screwed up because of pilot file
  • fix a large number of things than Valgrind complained about
  • ... half dozen or so other bug fixes that I'm too lazy to list ...
  • ... plus some other crap that you probably don't care about ...

 

Offline ARSPR

  • Preys On Mantis
  • 29
Re: 2007-10-28 stable branch (Xt version)
Great Taylor  :yes: :yes:

Till now, the strange background and loading screen issues seem gone like the pilot "corruption" ones.

But the 2D laser bitmap issue is still present. I upload a simple test mission (which AGAIN uses Blue Planet MOD).

OTOH, what I really wanted to test with this mission was Missionary engine glows. As you can see in the also attached F3 screenshot, you can see them from (nearly) every direction as if the hull were transparent. I suppose it is just a defective pof and not a engine bug but please take a look if you can (it surpasses my knowledge about FS2).

[attachment deleted by ninja]
IF YOU HAVE TROUBLES WITH FS2:
  • Please, please, please, READ and UNDERSTAND the sticky threads in FreeSpace & FreeSpace Open Support board.
    A lot of people are willing to help you, but, as anyone can understand, seeing the very same "issues" repeated again and again can become quite depressing. Please, spend a bit of time trying to solve the issue by yourself.
    (Lobo deserves a monument).
  • Then, if you aren't still able to solve your issue, feel free to ask for help in that same board.
    FYI, most of the troubles are caused by wrong mod installations which lead to either missing data or undesired cross-effects between them. Always follow the mod installation instructions and keep a clean FS2 installation as explained in the sticky threads. Two additional links about how the game handles game data:
  • If you think that you've discovered a bug, mantis it.
    Provide as much info as you can, and try to narrow it down. A lonely "FS2 doesn't work" is not a good report.

Whoever Hanlon was: Never attribute to malice that which can be adequately explained by stupidity.
Albert Einstein: Two things are infinite: the universe and human stupidity; and I'm not sure about the the universe.

Dell Dimension 9200 - Vista 32-bit Ultimate
Core 2 Quad Q6600 @2.4GHz - RAM 2 GB DDR2
nvidia 8800 GTX - Integrated Sigmatel Audio

 

Offline DaBrain

  • Screensniper
  • 212
    • Shadows of Lylat board
Re: 2007-10-28 stable branch (Xt version)
Looks like there is some pretty neat stuff in that build.

I'll test it. ;)

Btw "vertex-color"? Now I'm curious.
--------------------------------------------------
SoL is looking for a sound effect artist
Please PM me in case you want to apply
---------------------------------
Shadows of Lylat - A Freespace 2 total conversion
(hosted by Game-Warden)
----------------------------------

 

Offline taylor

  • Super SCP/Linux Guru
  • Moderator
  • 212
    • http://www.icculus.org/~taylor
Re: 2007-10-28 stable branch (Xt version)
Btw "vertex-color"? Now I'm curious.
That's just the old-school vertex coloring.  Only a couple things in the code still use it at this point.  I mean, it's been broken for almost 6 months now and I no one (not even me) noticed it until now, so that tells you how much of the code makes use of it.  Mostly it's just used in non-HTL mode for applying lighting to models.

I did use the same thing for one of the initial normal map implementations, and I plan to add much improved support for it later on for extra lighting effects (since we would get those added effects without the need for a separate render pass).  For instance, we could use this old vertex coloring for lighting up models which are far away, and real lighting for models close up.  That would give us both maximum performance and maximum quality. It could also be used for lighting terrain, or anything else that needs lighting effects, but doesn't necessarily need the quality that real lights provide.

 

Offline wdarkk

  • 26
Re: 2007-10-28 stable branch (Xt version)
Huh. For some reason Safari forgot to tell me "YOU DOWNLOADED A PROGRAM FROM THE INTERNEST OMG VIRUSSSSS!!!!1!"

Anyway, I'll take a look and see if this finally kills the damn ATI x1900 problems (DIE DIE DIE).

PS - I think the bugs I was having earlier regarding mod dependencies were with the launcher.

 

Offline wdarkk

  • 26
Re: 2007-10-28 stable branch (Xt version)
WHOA.

Now EVERY ship has the problem. Or at least, all the ones I've tested so far.

Edit: Dangit, didn't get the screenshots properly. I'll edit them in in a bit. Anyway every ship I've tested so far is invisible except for glows.

Edit2: Printscreen/F13 doesn't seem to be taking screenshots.
« Last Edit: October 28, 2007, 06:16:07 pm by wdarkk »

 

Offline taylor

  • Super SCP/Linux Guru
  • Moderator
  • 212
    • http://www.icculus.org/~taylor
Re: 2007-10-28 stable branch (Xt version)
I added a little extra debugging info in there for OpenGL problems.  If you don't already have one, create a ~/Library/FS2_Open/data/debug_filter.cfg file, with at least "-parse" in it.  Then run a debug build and send me the fs2_open.log file.  Hopefully that will help point out what/where the problem might be.

You could also try running with the -no_glsl cmdline option, just in case you are having some strange GLSL issue.

 

Offline wdarkk

  • 26
Re: 2007-10-28 stable branch (Xt version)
I think the launcher is messing with my settings, but I'm not 100% because I forgot a bunch of stuff about how the ini and cfg files worked since last time.

This does fix all the problems except the old ones (and the nebula/background problem I've had in every xt build is still there).
Btw what's the difference between "+Parse" and "-parse" in the debug filter cfg?



[attachment deleted by ninja]

 

Offline taylor

  • Super SCP/Linux Guru
  • Moderator
  • 212
    • http://www.icculus.org/~taylor
Re: 2007-10-28 stable branch (Xt version)
Btw what's the difference between "+Parse" and "-parse" in the debug filter cfg?
It's not case sensitive, so the two are basically identical.  The important part is the +/-, which means that this particular debug info will be directed to the log (+), or that it will be suppressed (-).  The parse info is totally useless 99% of the time to 99.999999% of the people who use the game.  If it wasn't disabled then your log file would easily be several times larger than it is now.  Anything that you don't specifically "-" in that cfg file will default to enabled, so that's why I said to add at least that line. :)


But, the log did point out a couple of things, so I'll start looking into that when I get back home later tonight and see what I can come up with.  I'll likely get you another test build to try and narrow down the exact line that OpenGL is having trouble with.

 

Offline wdarkk

  • 26
Re: 2007-10-28 stable branch (Xt version)
Here's hoping we can kill this bug once and for all. BTW to clarify what I said before, something I/the launcher did (not sure what, since the launcher messed with my settings a bit) fixed the new problems, so we're back to the old problems now.

 

Offline taylor

  • Super SCP/Linux Guru
  • Moderator
  • 212
    • http://www.icculus.org/~taylor
Re: 2007-10-28 stable branch (Xt version)
Here's hoping we can kill this bug once and for all. BTW to clarify what I said before, something I/the launcher did (not sure what, since the launcher messed with my settings a bit) fixed the new problems, so we're back to the old problems now.
I wasn't completely clear on that, but figured that was what you meant.  I've been meaning to get with Soulstorm about the status of the OS X launcher, given the number of strange bugs that appear to be related to it lately, so that we can sort that stuff out.  I know that he was having trouble getting anything to commit at one point, but I'm pretty sure that problem was fixed on our side but I never heard one way or the other from him (that I can remember anyway).

I did PM you a build link to test with.  Hopefully that will get us on the right track to getting this crap fixed once and for all. :)

 

Offline ARSPR

  • Preys On Mantis
  • 29
Re: 2007-10-28 stable branch (Xt version)
In 10-22 build I posted a possible defective driver with Vista 32bit + 8800 GTX + ForceWare 169.01 (link here)

Well I've just tried with 169.02 and it's exactly the same. Moreover it really doesn't matter if GLSL is on or off. General rendering is just FUBAR. Take a look at this Herc II special chess version (you may need to adjust gamma for a brighter seeing)  :lol: :lol:

I hope, nVidia fixes it ...

EDIT: Another thing that can be a bug. Look that in the screenshot from F3 lab, menus don't appear (ships, render options, class variables ...). This also happens with "functional" drivers. Is this a design criterion? or is it a bug?

[attachment deleted by ninja]
« Last Edit: October 29, 2007, 03:16:27 pm by ARSPR »
IF YOU HAVE TROUBLES WITH FS2:
  • Please, please, please, READ and UNDERSTAND the sticky threads in FreeSpace & FreeSpace Open Support board.
    A lot of people are willing to help you, but, as anyone can understand, seeing the very same "issues" repeated again and again can become quite depressing. Please, spend a bit of time trying to solve the issue by yourself.
    (Lobo deserves a monument).
  • Then, if you aren't still able to solve your issue, feel free to ask for help in that same board.
    FYI, most of the troubles are caused by wrong mod installations which lead to either missing data or undesired cross-effects between them. Always follow the mod installation instructions and keep a clean FS2 installation as explained in the sticky threads. Two additional links about how the game handles game data:
  • If you think that you've discovered a bug, mantis it.
    Provide as much info as you can, and try to narrow it down. A lonely "FS2 doesn't work" is not a good report.

Whoever Hanlon was: Never attribute to malice that which can be adequately explained by stupidity.
Albert Einstein: Two things are infinite: the universe and human stupidity; and I'm not sure about the the universe.

Dell Dimension 9200 - Vista 32-bit Ultimate
Core 2 Quad Q6600 @2.4GHz - RAM 2 GB DDR2
nvidia 8800 GTX - Integrated Sigmatel Audio

 

Offline taylor

  • Super SCP/Linux Guru
  • Moderator
  • 212
    • http://www.icculus.org/~taylor
Re: 2007-10-28 stable branch (Xt version)
In 10-22 build I posted a possible defective driver with Vista 32bit + 8800 GTX + ForceWare 169.01 (link here)
Does the debug log show anything about the shaders not working?  I don't know that I'll do anything about it even if there are warnings/errors, since NVIDIA has broken GLSL before and then later fixed it.  But I can give it a look at least.

Regarding the missing resolution though: out or our hands.  The code merely lists what the drivers advertise, and if something is missing, it's because the driver says that it's not supported.  I assume that this is just a driver bug though.

Quote
EDIT: Another thing that can be a bug. Look that in the screenshot from F3 lab, menus don't appear (ships, render options, class variables ...). This also happens with "functional" drivers. Is this a design criterion? or is it a bug?
Yep, known bug.  I does save the screenshot with the FPS counter and the POF filename though, which is really all that I've ever been interested in, so I have been rather hesitant to fix it.  I have to say that I'm happy to leave it broken, but it is on my todo list to fix (though it's waaaaaaay at the bottom ;)).

 

Offline ARSPR

  • Preys On Mantis
  • 29
Re: 2007-10-28 stable branch (Xt version)
nVidia people are in rush hour. Today we have 169.04 which still doesn't work and also has missing resolutions (Taylor, confirmed that Windows Desktop doesn't have those resolutions either).

The debug spew with debug build is:

Code: [Select]
...

Initializing OpenGL graphics device at 1024x768 with 32-bit color...
  Initializing WGL...
  Requested WGL Video values = R: 8, G: 8, B: 8, depth: 32, double-buffer: 1
  Actual WGL Video values    = R: 8, G: 8, B: 8, depth: 32, double-buffer: 1
  OpenGL Vendor     : NVIDIA Corporation
  OpenGL Renderer   : GeForce 8800 GTX/PCI/SSE2
  OpenGL Version    : 2.1.2

  Using extension "GL_EXT_fog_coord".
  Using extension "GL_ARB_multitexture".
  Using extension "GL_ARB_texture_env_add".
  Using extension "GL_ARB_texture_compression".
  Using extension "GL_EXT_texture_compression_s3tc".
  Using extension "GL_EXT_texture_filter_anisotropic".
  Using extension "GL_ARB_texture_env_combine".
  Using extension "GL_EXT_compiled_vertex_array".
  Using extension "GL_EXT_draw_range_elements".
  Using extension "GL_ARB_texture_mirrored_repeat".
  Using extension "GL_ARB_texture_non_power_of_two".
  Using extension "GL_ARB_vertex_buffer_object".
  Using extension "GL_ARB_pixel_buffer_object".
  Using extension "GL_SGIS_generate_mipmap".
  Using extension "GL_EXT_framebuffer_object".
  Using extension "GL_ARB_texture_rectangle".
  Using extension "GL_EXT_bgra".
  Using extension "GL_ARB_texture_cube_map".
  Using extension "GL_EXT_texture_lod_bias".
  Using extension "GL_ARB_point_sprite".
  Using extension "GL_ARB_shading_language_100".
  Using extension "GL_ARB_shader_objects".
  Using extension "GL_ARB_vertex_shader".
  Using extension "GL_ARB_fragment_shader".
  Found special extension function "wglSwapIntervalEXT".

  Compiling shader ->  b-vert.sdr / b-frag.sdr ...
  Shader failed to link...
Link info
---------
Vertex attribute output count exceeds hardware limits.
  Shader in_error!  Disabling GLSL!
  Max texture units: 4 (4)
  Max elements vertices: 1048576
  Max elements indices: 1048576
  Max texture size: 8192x8192
  Can use compressed textures: YES
  Texture compression available: YES
  Using trilinear texture filter.
... OpenGL init is complete!
Size of bitmap info = 705 KB
Size of bitmap extra info = 40 bytes
ANI cursorweb with size 24x24 (25.0% wasted)
GRAPHICS: Initializing default colors

...

 :mad: Returning to 163.75 AGAIN
IF YOU HAVE TROUBLES WITH FS2:
  • Please, please, please, READ and UNDERSTAND the sticky threads in FreeSpace & FreeSpace Open Support board.
    A lot of people are willing to help you, but, as anyone can understand, seeing the very same "issues" repeated again and again can become quite depressing. Please, spend a bit of time trying to solve the issue by yourself.
    (Lobo deserves a monument).
  • Then, if you aren't still able to solve your issue, feel free to ask for help in that same board.
    FYI, most of the troubles are caused by wrong mod installations which lead to either missing data or undesired cross-effects between them. Always follow the mod installation instructions and keep a clean FS2 installation as explained in the sticky threads. Two additional links about how the game handles game data:
  • If you think that you've discovered a bug, mantis it.
    Provide as much info as you can, and try to narrow it down. A lonely "FS2 doesn't work" is not a good report.

Whoever Hanlon was: Never attribute to malice that which can be adequately explained by stupidity.
Albert Einstein: Two things are infinite: the universe and human stupidity; and I'm not sure about the the universe.

Dell Dimension 9200 - Vista 32-bit Ultimate
Core 2 Quad Q6600 @2.4GHz - RAM 2 GB DDR2
nvidia 8800 GTX - Integrated Sigmatel Audio

 
Re: 2007-10-28 stable branch (Xt version)
I'm getting a minor graphical oddity when I bring up the screen to quit an active mission, or the screen to exit the main hall.  The cursor essentially starts acting like I have mouse trails enabled on a laptop, only it's just drawing static copies of itself wherever you move it to.

VERY minor, since the only time this happens is when a window is opened on top of an existing screen instead of opening full screen, and I think the 2 exit screens are the only example of that behavior.  It goes away if you cancel out of those screens, and of course if you're bringing them up in the first place you're probably not going to be looking at it for long. :)

The 10/22 build didn't do this, and I haven't changed any settings or other files besides setting the launcher to use the 10/28 build.  Again, I don't think it's particularly important and if it stayed that way forever it wouldn't be a problem, but it certainly can't hurt to tell you (and it might be easy to fix).

Back to lurking I go.

Everything is better with monkeys.  Even pie.

That is the best first post I have ever seen.

 

Offline MP-Ryan

  • Makes General Discussion Make Sense.
  • Global Moderator
  • 210
  • Keyboard > Pen > Sword
    • Twitter
Re: 2007-10-28 stable branch (Xt version)
CRRRRRAAAAASH!

This commandline series causes the program to crash on launch.

C:\StrcApps\FreeSpaceOpen\fs2_open_3_6_10-20071028T.exe -mod Mods\mediavps -spec -glow -mipmap -nomotiondebris -normal -img2dds -no_vsync -cache_bitmaps -targetinfo -rearm_timer -ship_choice_3d -snd_preload -fps

EDIT:  Narrowed it down to either of the glowmaps or normal maps flags. (that is, if either is selected it crashes).  I have the normal maps installed.  My video card is a Radeon 9500Pro, so it SHOULD have GLSL support.  However, if I use your no_glsl flag, FSO runs normally... so perhaps this video card doesn't actually have support for that technology even though it says it does.  I'm running the latest Catalyst drivers too.

Very confusing.  And because the game crashes before even launching, I'm not getting an error log from FSO.  I do have the windows log, so I'm attaching it for your reading pleasure.

EDIT2:  AHA!  I got a debug spew.  Here it is:

==========================================================================
DEBUG SPEW: No debug_filter.cfg found, so only general, error, and warning
categories can be shown and no debug_filter.cfg info will be saved.
==========================================================================
FreeSpace version: 3.6.10
Passed cmdline options:
  -mipmap
  -glow
  -nomotiondebris
  -spec
  -normal
  -cache_bitmaps
  -img2dds
  -no_vsync
  -dualscanlines
  -rearm_timer
  -targetinfo
  -ship_choice_3d
  -snd_preload
  -mod Mods\mediavps
  -fps
Building file index...
Found root pack 'C:\strcapps\freespaceopen\Mods\mediavps\LSNebPlusFS2Missions.vp' with a checksum of 0x775e7c1b
Found root pack 'C:\strcapps\freespaceopen\Mods\mediavps\mp-710_effects.vp' with a checksum of 0xe22bdcc2
Found root pack 'C:\strcapps\freespaceopen\Mods\mediavps\mp-710_models.vp' with a checksum of 0x20b9069a
Found root pack 'C:\strcapps\freespaceopen\Mods\mediavps\mv_core.vp' with a checksum of 0xb6cb1f6a
Found root pack 'C:\strcapps\freespaceopen\Mods\mediavps\mv_effects.vp' with a checksum of 0x1986a43c
Found root pack 'C:\strcapps\freespaceopen\Mods\mediavps\mv_models.vp' with a checksum of 0x2f8a711a
Found root pack 'C:\strcapps\freespaceopen\Mods\mediavps\mv_music.vp' with a checksum of 0xcca92482
Found root pack 'C:\strcapps\freespaceopen\Mods\mediavps\mv_textures.vp' with a checksum of 0x2c43a80e
Found root pack 'C:\strcapps\freespaceopen\Mods\mediavps\nm_test.vp' with a checksum of 0x85a84b5b
Found root pack 'C:\strcapps\freespaceopen\FS2cutscenepack.vp' with a checksum of 0x84396e99
Found root pack 'C:\strcapps\freespaceopen\root_fs2.vp' with a checksum of 0xce10d76c
Found root pack 'C:\strcapps\freespaceopen\smarty_fs2.vp' with a checksum of 0xddeb3b1e
Found root pack 'C:\strcapps\freespaceopen\sparky_fs2.vp' with a checksum of 0x164fe65a
Found root pack 'C:\strcapps\freespaceopen\sparky_hi_fs2.vp' with a checksum of 0xa11d56f1
Found root pack 'C:\strcapps\freespaceopen\stu_fs2.vp' with a checksum of 0xd77da83a
Found root pack 'C:\strcapps\freespaceopen\tango1_fs2.vp' with a checksum of 0x4c25221e
Found root pack 'C:\strcapps\freespaceopen\tango2_fs2.vp' with a checksum of 0x86920b82
Found root pack 'C:\strcapps\freespaceopen\tango3_fs2.vp' with a checksum of 0x705e8d71
Found root pack 'C:\strcapps\freespaceopen\warble_fs2.vp' with a checksum of 0xd85c305d
Searching root 'C:\strcapps\freespaceopen\Mods\mediavps\' ... 45 files
Searching root pack 'C:\strcapps\freespaceopen\Mods\mediavps\LSNebPlusFS2Missions.vp' ... 198 files
Searching root pack 'C:\strcapps\freespaceopen\Mods\mediavps\mp-710_effects.vp' ... 91 files
Searching root pack 'C:\strcapps\freespaceopen\Mods\mediavps\mp-710_models.vp' ... 31 files
Searching root pack 'C:\strcapps\freespaceopen\Mods\mediavps\mv_core.vp' ... 88 files
Searching root pack 'C:\strcapps\freespaceopen\Mods\mediavps\mv_effects.vp' ... 580 files
Searching root pack 'C:\strcapps\freespaceopen\Mods\mediavps\mv_models.vp' ... 399 files
Searching root pack 'C:\strcapps\freespaceopen\Mods\mediavps\mv_music.vp' ... 15 files
Searching root pack 'C:\strcapps\freespaceopen\Mods\mediavps\mv_textures.vp' ... 1526 files
Searching root pack 'C:\strcapps\freespaceopen\Mods\mediavps\nm_test.vp' ... 72 files
Searching root 'C:\strcapps\freespaceopen\' ... 6 files
Searching root pack 'C:\strcapps\freespaceopen\FS2cutscenepack.vp' ... 10 files
Searching root pack 'C:\strcapps\freespaceopen\root_fs2.vp' ... 157 files
Searching root pack 'C:\strcapps\freespaceopen\smarty_fs2.vp' ... 10 files
Searching root pack 'C:\strcapps\freespaceopen\sparky_fs2.vp' ... 3027 files
Searching root pack 'C:\strcapps\freespaceopen\sparky_hi_fs2.vp' ... 1337 files
Searching root pack 'C:\strcapps\freespaceopen\stu_fs2.vp' ... 2355 files
Searching root pack 'C:\strcapps\freespaceopen\tango1_fs2.vp' ... 32 files
Searching root pack 'C:\strcapps\freespaceopen\tango2_fs2.vp' ... 15 files
Searching root pack 'C:\strcapps\freespaceopen\tango3_fs2.vp' ... 10 files
Searching root pack 'C:\strcapps\freespaceopen\warble_fs2.vp' ... 52 files
Found 21 roots and 10056 files.
AutoLang: Language auto-detection successful...
Setting language to English
Initializing OpenAL...
  Using 'Generic Software' as OpenAL sound device...
  OpenAL Vendor     : Creative Labs Inc.
  OpenAL Renderer   : Software
  OpenAL Version    : 1.1

... OpenAL successfully initialized!
Failed to init speech
GR_CPU: Family 6, MMX=Yes
Initializing OpenGL graphics device at 1024x768 with 32-bit color...
  Initializing WGL...
  Requested WGL Video values = R: 8, G: 8, B: 8, depth: 32, double-buffer: 1
  Actual WGL Video values    = R: 8, G: 8, B: 8, depth: 32, double-buffer: 1
  OpenGL Vendor     : ATI Technologies Inc.
  OpenGL Renderer   : RADEON 9500 PRO / 9700 x86/MMX/3DNow!
  OpenGL Version    : 2.0.6956 WinXP Release

  Using extension "GL_EXT_fog_coord".
  Using extension "GL_ARB_multitexture".
  Using extension "GL_ARB_texture_env_add".
  Using extension "GL_ARB_texture_compression".
  Using extension "GL_EXT_texture_compression_s3tc".
  Using extension "GL_EXT_texture_filter_anisotropic".
  Using extension "GL_ARB_texture_env_combine".
  Using extension "GL_EXT_compiled_vertex_array".
  Using extension "GL_EXT_draw_range_elements".
  Using extension "GL_ARB_texture_mirrored_repeat".
  Unable to find extension "GL_ARB_texture_non_power_of_two".
  Using extension "GL_ARB_vertex_buffer_object".
  Using extension "GL_ARB_pixel_buffer_object".
  Using extension "GL_SGIS_generate_mipmap".
  Using extension "GL_EXT_framebuffer_object".
  Using extension "GL_ARB_texture_rectangle".
  Using extension "GL_EXT_bgra".
  Using extension "GL_ARB_texture_cube_map".
  Using extension "GL_EXT_texture_lod_bias".
  Using extension "GL_ARB_point_sprite".
  Using extension "GL_ARB_shading_language_100".
  Using extension "GL_ARB_shader_objects".
  Using extension "GL_ARB_vertex_shader".
  Using extension "GL_ARB_fragment_shader".
  Found special extension function "wglSwapIntervalEXT".

  Compiling shader ->  b-vert.sdr / b-frag.sdr ...
  Shader linked with warnings...
 Link successful. The GLSL vertex shader will run in software due to the GLSL fragment shader running in software. The GLSL fragment shader will run in software - available number of constants exceeded.
  Compiling shader ->  b-vert.sdr / bg-frag.sdr ...




[attachment deleted by ninja]
« Last Edit: October 31, 2007, 12:25:36 am by MP-Ryan »
"In the beginning, the Universe was created.  This made a lot of people very angry and has widely been regarded as a bad move."  [Douglas Adams]

 

Offline taylor

  • Super SCP/Linux Guru
  • Moderator
  • 212
    • http://www.icculus.org/~taylor
Re: 2007-10-28 stable branch (Xt version)
EDIT:  Narrowed it down to either of the glowmaps or normal maps flags. (that is, if either is selected it crashes).  I have the normal maps installed.  My video card is a Radeon 9500Pro, so it SHOULD have GLSL support.  However, if I use your no_glsl flag, FSO runs normally... so perhaps this video card doesn't actually have support for that technology even though it says it does.  I'm running the latest Catalyst drivers too.
That crash problem has been reported several times, all with 9xxx series ATI cards.  It would just appear to be a driver bug, and there isn't really anything that can be done on our side to get around it.  Just make sure that you are using the newest drivers available and see if that helps at all.

 

Offline MP-Ryan

  • Makes General Discussion Make Sense.
  • Global Moderator
  • 210
  • Keyboard > Pen > Sword
    • Twitter
Re: 2007-10-28 stable branch (Xt version)
EDIT:  Narrowed it down to either of the glowmaps or normal maps flags. (that is, if either is selected it crashes).  I have the normal maps installed.  My video card is a Radeon 9500Pro, so it SHOULD have GLSL support.  However, if I use your no_glsl flag, FSO runs normally... so perhaps this video card doesn't actually have support for that technology even though it says it does.  I'm running the latest Catalyst drivers too.
That crash problem has been reported several times, all with 9xxx series ATI cards.  It would just appear to be a driver bug, and there isn't really anything that can be done on our side to get around it.  Just make sure that you are using the newest drivers available and see if that helps at all.

Sorry Taylor, check my post updates.  I managed to get a debug spew, says something about software mode?
"In the beginning, the Universe was created.  This made a lot of people very angry and has widely been regarded as a bad move."  [Douglas Adams]

 

Offline MP-Ryan

  • Makes General Discussion Make Sense.
  • Global Moderator
  • 210
  • Keyboard > Pen > Sword
    • Twitter
Re: 2007-10-28 stable branch (Xt version)
Alright, so I tried installing the latest Omega drivers (7.10-based), and they're doing the same thing.  Debug spew is identical.

So, that's both of the latest available drivers for ATI's video cards.  Anyone else find a driver set that actually works, or are we doomed to no GLSL support?
"In the beginning, the Universe was created.  This made a lot of people very angry and has widely been regarded as a bad move."  [Douglas Adams]

 

Offline castor

  • 29
    • http://www.ffighters.co.uk./home/
Re: 2007-10-28 stable branch (Xt version)
Here's something minor but curious.
If I go to tech room mission simulator and press Ctrl+shift+s (to list all FS2 missions) => the audio (music) starts to distort and the mouse pointer goes all laggy.
These "symptoms" go on until I exit the tech room, then they are gone..

Only happens with my "good" old SB Live!, but not with my Terratec audio card. The effect is not present with the FSO from stable branch (compiled on the same system, same settings). Running Linux.