Author Topic: Yes, it's 3.6!!  (Read 21620 times)

0 Members and 1 Guest are viewing this topic.

Offline karajorma

  • King Louie - Jungle VIP
  • Administrator
  • 214
    • Karajorma's Freespace FAQ
Quote
Originally posted by Warlock
Ok,...stupid question time ;)

I've not played my FS2 in a couple years now, not even had it installed for at least 9 months. Is the 3.6 ScP (and of course the offical patch) all I need to download to get going with all the new stuff?

Oh and..... with a 900 speed processor and 500 some odd meg Ram,.. how much of the ScP can I even use?

Thanks guys ;)


You will of course need to install FS2 Retail first. :)

Apart from that the only things you need is either 3.6 or a more recent build (reccomend the latter) and launcher 5.x (should be available from the 3.6 thread). That's all you need.

I reccomend you get some of the media.vp files too. You should be able to use shine mapping and glow maps at least with no problem. Media.vp files are completely optional but without them you won't notice much of a difference in the graphics (the new SEXP's etc will of course be there but most people don't notice stuff like that :D )
« Last Edit: July 25, 2004, 03:52:38 am by 340 »
Karajorma's Freespace FAQ. It's almost like asking me yourself.

[ Diaspora ] - [ Seeds Of Rebellion ] - [ Mind Games ]

 

Offline Beowulf

  • 27
Ohh god I'm so happy!
Never Forget

"It is always better to avenge dear ones than to induldge in mourning. For every one of us, living in this world means waiting for our end. Let whoever can win glory before death. When a warrior is gone, that will be his best and only bulwark."
                               --Beowulf


"... and no, real life sex is not just a myth. You just need to come out of your house once every while..." ~Tiara

YeeeeHoooooh! is the mood of the day. :p

 

Offline magatsu1

  • 210
--------------------------------------------------------------------------------
Originally posted by Goober5000 at the top of the first post in this thread
PLEASE NOTE: The "engine failure" bug is known and has been fixed in this build:
http://fs2source.warpcore.org/exes/...n_C06222004.zip
--------------------------------------------------------------------------------

is this link still good ? I've tried 3 times and the page won't open.
Blitzerland: Knows what he's talkin' about

 

Offline Goober5000

  • HLP Loremaster
  • Administrator
  • 214
    • Goober5000 Productions
I think warpcore.org is down.  Wait a while and try again.

Incidentally, don't quote the link and then try to click it.  It gets shortened and it won't work.

 

Offline magatsu1

  • 210
Yeah, I tried the quote and your original post. I'm gettin' a similar prob if I go through the SCP website too.
Blitzerland: Knows what he's talkin' about

 
Quote
Originally posted by Goober5000
PLEASE NOTE: The "engine failure" bug is known and has been fixed in this build:
http://fs2source.warpcore.org/exes/latest/fs2_open_C06222004.zip

We now return you to your regularly scheduled thread.

------------------------------------------------------------------------



Sorry to report a bug in the forum, but I just couldn't get the bug report page to work.

Now, using the above mentioned build, I get the following error after a maximum of 3 missions played in a row, along with a "Virtual Memory Too Low" notification from Windows.

Error: Out of memory.  Try closing down other applications, increasing your
virtual memory size, or installing more physical RAM.

File:.\globalincs\windebug.cpp
Line: 1474

Call stack:
------------------------------------------------------------------
    fs2_open_ex.exe 00465aa0()
    fs2_open_ex.exe 00465f0d()
    fs2_open_ex.exe 00466491()
    fs2_open_ex.exe 004690c8()
    fs2_open_ex.exe 00466746()
    fs2_open_ex.exe 004696f8()
    fs2_open_ex.exe 004c5979()
    fs2_open_ex.exe 005fd4cb()
    fs2_open_ex.exe 00602de9()
    fs2_open_ex.exe 0060464c()
    fs2_open_ex.exe 0060489d()
    fs2_open_ex.exe 005b751f()
    fs2_open_ex.exe 005d2ff5()
    fs2_open_ex.exe 00659a03()
    fs2_open_ex.exe 0064884b()
------------------------------------------------------------------


I guess this ought to happen when running FreeSpace with 16 MB of RAM, but I currently have 256 DDR, and 128 VRAM. Moreover, there are major slowdowns in-mission, when ships explode (yes, I am using the hi-res explosions, so that's understandable), and when any ships exit subspace.

My command line for running FreeSpace is:

D:\Games\FreeSpace2\fs2_open_ex.exe -spec -glow -pcx32 -jpgtga -d3dmipmap -phreak -ship_choice_3d -2d_poof -snd_preload

I'm running Windows XP SP1, Detonator v61.77, on a Duron 850 MHz, 256 DDR, MSI nForce 1, GeForce FX 5200. Pretty low-end, I know, but considering I just finished Splinter Cell 2 on it on best graphics settings without slowdowns, I guess FSSCP ought to run just fine...

 
I had the same problem, there was a memory leak in the build so try using this build: http://www.hard-light.net/forums/index.php/topic,25938.0.html
My Sytem

Wer das liest ist doof!

 

Offline Goober5000

  • HLP Loremaster
  • Administrator
  • 214
    • Goober5000 Productions
Yeah, that's probably the memory leak.

 
Loving 3.6. Absolutely no issues whatsoever, asides from FRED (duh), but I can survive :)

My frame rate sucks, but that is the fault of my stupid, worthless, no good, obsolete, ugly, stupid, slow, poorly-optimized, gerbil-powered, NVIDIA, smelly, holy-crappy video card of death, doom and decapitation.

Rrrrrr :mad:

 

Offline redmenace

  • 211
glad to hear it.
Government is the great fiction through which everybody endeavors to live at the expense of everybody else.
              -Frederic Bastiat

 

Offline avengre

  • 22
    • http://www.geocities.com/avengre
Noob question, FSO IS just a launcher?

I downloaded the 44.3 mb one and installed it an all.  The campaign dosent change... there are no other options in the campaign selection or the Mission simulator... have i done something wrong?

 

Offline karajorma

  • King Louie - Jungle VIP
  • Administrator
  • 214
    • Karajorma's Freespace FAQ
FSO is a new engine for the game. Campaigns which use the new engine are on their way but if you play FS2 again you'll notice a lot of differences. :)
Karajorma's Freespace FAQ. It's almost like asking me yourself.

[ Diaspora ] - [ Seeds Of Rebellion ] - [ Mind Games ]

 

Offline Hippo

  • Darth water-horse
  • 211
  • Grazing.
    • All Hands to War
Quote
Originally posted by Johnny B.
...16 ...256 ...128 totaling 400mb
My command line for running FreeSpace is:

D:\Games\FreeSpace2\fs2_open_ex.exe -spec -glow -pcx32 -jpgtga -d3dmipmap -phreak -ship_choice_3d -2d_poof -snd_preload




That is FAR from enough ram... And i mean FAR...









And on a second note, will someone just stick a HUGE disclaimer on the link to 3.6, since just about EVERY n00b question thats popping up has something to do with 3.6, and as we know, its a bit buggy... :rolleyes:
VBB Survivor -- 387 Posts -- July 3 2001 - April 12 2002
VWBB Survivor -- 100 Posts -- July 10 2002 - July 10 2004

AHTW

 

Offline Goober5000

  • HLP Loremaster
  • Administrator
  • 214
    • Goober5000 Productions
There is a huge disclaimer.
Quote
Originally posted by Goober5000
PLEASE NOTE: The "engine failure" bug is known and has been fixed in this build:
http://fs2source.warpcore.org/exes/latest/fs2_open_C06222004.zip

We now return you to your regularly scheduled thread.
It's been there for a while.  Nobody reads it. :rolleyes:

 

Offline Hippo

  • Darth water-horse
  • 211
  • Grazing.
    • All Hands to War
I meant a big warning right on or at the link, so that you have to read soething like, "WARNING: THIS BUILD IS OUTDATED. DO. NOT. USE. UNLESS. ABSOLUTELY. NESCESSARY."


... Or something... Most people see the link for the installer or the build itself, and just go to it before reading... I know i did, though that was before we found the bug...
VBB Survivor -- 387 Posts -- July 3 2001 - April 12 2002
VWBB Survivor -- 100 Posts -- July 10 2002 - July 10 2004

AHTW

 

Offline Goober5000

  • HLP Loremaster
  • Administrator
  • 214
    • Goober5000 Productions
No.

This build is the latest, stable, official build, and it's going to stay that way until 3.6.1.  We've said repeatedly that people use the more recent builds at their own risk.  We're happy to help people get started with 3.6, but if we supported every unofficial build that came out we wouldn't have any time left to code.  We hardly have time now as it is.

 

Offline Hippo

  • Darth water-horse
  • 211
  • Grazing.
    • All Hands to War
Okeydokie...
VBB Survivor -- 387 Posts -- July 3 2001 - April 12 2002
VWBB Survivor -- 100 Posts -- July 10 2002 - July 10 2004

AHTW

 

Offline karajorma

  • King Louie - Jungle VIP
  • Administrator
  • 214
    • Karajorma's Freespace FAQ
One thing though. How hard would it be for someone to roll back to the 3.6 version of the code, implement warp fix and upload that as 3.6.1?

Since that's just about the only thing wrong with 3.6 it would solve a lot of problems.
Karajorma's Freespace FAQ. It's almost like asking me yourself.

[ Diaspora ] - [ Seeds Of Rebellion ] - [ Mind Games ]

 

Offline Goober5000

  • HLP Loremaster
  • Administrator
  • 214
    • Goober5000 Productions
...Bah.  Forgot about the rollback option.  I suppose I could do that, but it would still be 3.6, not 3.6.1.  And since Fractux hasn't posted here recently, it wouldn't be part of the installation package.

 

Offline karajorma

  • King Louie - Jungle VIP
  • Administrator
  • 214
    • Karajorma's Freespace FAQ
Even still when posted directly underneath the 3.6 install links it would certain end the jump out bug problem.

TBP would probably be happy to see this. 3.6.1 might not be ready by the time they are in which case I'm sure they'd rather base their stand alone around 3.6 with the bug fix than a version without it.
Karajorma's Freespace FAQ. It's almost like asking me yourself.

[ Diaspora ] - [ Seeds Of Rebellion ] - [ Mind Games ]