Author Topic: Archived CVS Builds thread  (Read 25835 times)

0 Members and 1 Guest are viewing this topic.

Offline CaptJosh

  • 210
Ok, trying the 09/28/05 build I get this:

Error: pixels.tbl(7):
Error: Required token = [Traitor IFF:], found [$Traitor IFF: Traitor                                 ] .

File:C:\fs2_open\code\Parse\PARSELO.CPP
Line: 555
[This filename points to the location of a file on the computer that built this executable]

Call stack:
------------------------------------------------------------------
------------------------------------------------------------------

It appears to be having a problem with one of the files contained in one of the VPs. I'm guessing that you made things tighter about foul-ups like that?
CaptJosh

There are only 10 kinds of people in the world;
those who understand binary and those who don't.

 

Offline karajorma

  • King Louie - Jungle VIP
  • Administrator
  • 214
    • Karajorma's Freespace FAQ
That's cause of Goober's IFF changes. Nothing wrong with your system. Just use an earlier build till it's sorted.
Karajorma's Freespace FAQ. It's almost like asking me yourself.

[ Diaspora ] - [ Seeds Of Rebellion ] - [ Mind Games ]

 

Offline CaptJosh

  • 210
I know it's not on my system. I know it's a software glitch. And I AM using an earlier build. Specifically, the 3.6.7 official release.
CaptJosh

There are only 10 kinds of people in the world;
those who understand binary and those who don't.

 

Offline Goober5000

  • HLP Loremaster
  • Administrator
  • 214
    • Goober5000 Productions
Quote
Originally posted by CaptJosh
I know it's not on my system. I know it's a software glitch. And I AM using an earlier build. Specifically, the 3.6.7 official release.
No you're not, otherwise you wouldn't have gotten that message. :p

 

Offline CaptJosh

  • 210
I only got it once when I tested that build. When it didn't work, I switched back. Try using your head for more than a hat rack.
CaptJosh

There are only 10 kinds of people in the world;
those who understand binary and those who don't.

 

Offline Goober5000

  • HLP Loremaster
  • Administrator
  • 214
    • Goober5000 Productions
I misread your post and thought you said you got that message when you tried the official 3.6.7 build.  Apologies.  But please try to be polite when you post; insulting a SCP member (let alone an admin) seldom gets you far. :blah:

 

Offline CaptJosh

  • 210
I apologize. Got a headache. Tends to make me snappish.
CaptJosh

There are only 10 kinds of people in the world;
those who understand binary and those who don't.

 

Offline WMCoolmon

  • Purveyor of space crack
  • 213
Quote
It appears to be having a problem with one of the files contained in one of the VPs. I'm guessing that you made things tighter about foul-ups like that?


There's no/never has been a pixels.tbl in the mediaVPs, so if it is a bug, it's either something about the build, or some other mod you have installed.
-C

 

Offline CaptJosh

  • 210
The only VPs I have are the ones from the scp website.
CaptJosh

There are only 10 kinds of people in the world;
those who understand binary and those who don't.

 

Offline WMCoolmon

  • Purveyor of space crack
  • 213
What does the launcher show as your command line?
-C

 

Offline redmenace

  • 211
The root directory contains vps aswell. The problem is not with the vps though. It is strictly a code related issue.
Government is the great fiction through which everybody endeavors to live at the expense of everybody else.
              -Frederic Bastiat

 

Offline CaptJosh

  • 210
Quote
Originally posted by WMCoolmon
What does the launcher show as your command line?


Actually, I tested it without any options enabled. I wanted to make sure none of the fancy effects were at fault.
CaptJosh

There are only 10 kinds of people in the world;
those who understand binary and those who don't.

 

Offline redmenace

  • 211
Updated!
CVS as of 9/29/05

Some Important Comments:
  • IFF Parse error fixed.
  • Thruster bug that affects HTL models still present.
  • Fred Build also posted.
Government is the great fiction through which everybody endeavors to live at the expense of everybody else.
              -Frederic Bastiat

 

Offline CaptJosh

  • 210
Any chance that work has been done on an apparently large memory leak?
CaptJosh

There are only 10 kinds of people in the world;
those who understand binary and those who don't.

 

Offline redmenace

  • 211
what memory leak?
Government is the great fiction through which everybody endeavors to live at the expense of everybody else.
              -Frederic Bastiat

 

Offline CaptJosh

  • 210
The one that seems to crop up every time I restart a mission. When I first run it, the comms animations are smooth and control of my ship is good, but if I screw up and have to start over, or if I just want to see if I can get a better result, things start to hiccup. The game will freeze while it reloads the anmation, or worse still, jitter instead. It gets progressively worse for every repeat of a mission. I've got half a gig of PC3200 400MHz DDR RAM. I shouldn't be seeing stuff like that, IMO.
« Last Edit: September 29, 2005, 02:32:18 am by 2993 »
CaptJosh

There are only 10 kinds of people in the world;
those who understand binary and those who don't.

 

Offline redmenace

  • 211
can you give me a specific mission please?
Government is the great fiction through which everybody endeavors to live at the expense of everybody else.
              -Frederic Bastiat

 

Offline CaptJosh

  • 210
It's not mission specific. Any time I restart any mission, it starts to do this.
CaptJosh

There are only 10 kinds of people in the world;
those who understand binary and those who don't.

 

Offline redmenace

  • 211
I will take a look at it as time permits.
Government is the great fiction through which everybody endeavors to live at the expense of everybody else.
              -Frederic Bastiat

 

Offline CaptJosh

  • 210
I was thinking about this while I was convincing myself to get up this morning, and I realized it might not be the animations at all.

Last night when I was playing some more, using the new build, too, I made it to the final mission. I restarted that mission once, and the issue set in, but it wasn't just happening with communications animations on screen. I was getting a small jitter just as the beam sounds started.

Now, I have it set to preload mission sounds, so I'm wondering if there's another issue here, something with it not clearing the sounds out of memory before reloading everything? Or perhaps with it not preloading sounds correctly when a mission reloads to play again?
CaptJosh

There are only 10 kinds of people in the world;
those who understand binary and those who don't.