Author Topic: Corrupted pilot files after using the mission simulator?  (Read 1381 times)

0 Members and 1 Guest are viewing this topic.

Offline miskat

  • 27
Corrupted pilot files after using the mission simulator?
Alright... I'm not sure WHY this is happening... I assume it's a corrupted pilot file because playing on a new pilot fixes it... but this is the third time I've done that already.  ;_;

FSPort has been working fabulously (except that it doesn't seem to log cutscenes that have been viewed, for later access in the tech room... but who cares?  O.o)  But I've been having a major problem... it seems that every once in awhile, something will happen, and when I go to play the game again, things will bug out.

OK... that was a terrible description... bear with me.

1) By "something that happens" I mean that I'm really not sure.  However, I know thefirst time I saw something funny happen, I had completed a mission after failing a secondary objective.  While in the debriefing screen I chose the option to discard mission data and replay the mssion.  Next time I fire the game up, I play the mission fine, but it is not recognized by the tech room as having been a completed campaign mission.  Odd.  I start a new pilot and get up to and past that (without discarding any mission data like before) and all is well.

2) Until I load up a mission in the tech room.  (Now that I think about it... I remember loading a mission up in the tech room before as well to see if Icould kill the Ramses.  =/)  I play around in the mission and then leave it.  I then load up my campaign and... well... I'm on The Darkness and the Light and there is a problem.

-I seem to be able to choose from the proper ship classes.  (Apollo, Valkyrie, Ulysses, and Hercules... last one is new forme, never seen it before.  O.o)  But... well... I dunno... I guess the game colors ship icons blue for fighters and grey for bombers?  Or is that not normal?  Anyway, this seems OK.  Positng it 'cause I'm just not sure.  =/

-BIG problem: Alpha wing starts out with one Apollo set in the Alpha1 position with 2xML16 Lasers.  Those are the only weapons I have access to.  All other weapons show up (ML16, Disruptor, and Avenger primaries; MX-50 and the Fury secondaries.)

Anyway... is there ANY wat to correct this... or do I have to restart the campaign... again?  *sighs*

Help... please?  ;_;

  

Offline miskat

  • 27
Re: Corrupted pilot files after using the mission simulator?
This is bizarre!  Not sure WHAT happened or WHY  But its fixed.

What I noticed: After it was fixed, only two ships were available: the Apollo and the Valkyrie.

A New secondary weapon became available: the Interceptor.  All weapons now have the correct number of weapons available.

Anyway... I noticed the "reset" button on the ship and weapon loadout screens... hit that and everything is fine.  Go figure.  XD

 

Offline Snail

  • SC 5
  • 214
  • Posts: ☂
Re: Corrupted pilot files after using the mission simulator?
The Interceptor shouldn't be available IIRC... Which I probably did, since I've played the first act over twenty times.

 

Offline miskat

  • 27
Re: Corrupted pilot files after using the mission simulator?
You are correct, sir.  It's been a long night and confusion seeps into my brain easily.  =/