Author Topic: "You selected TCP/IP for multiplayer FS, but the TCP/IP protocol not detected.."  (Read 1348 times)

0 Members and 1 Guest are viewing this topic.

Offline TL

  • 22
"You selected TCP/IP for multiplayer FS, but the TCP/IP protocol not detected.."
Hello all,

I am trying to play Multiplayer, and can't continue due to this error:

"You have selected TCP/IP for multiplayer Freespace, but the TCP/IP protocol was not detected on your machine."

Happens when I try to start a server via command line option or by going to the hangar. Can't find any results via searching. Network settings are set to LAN/Direct Connection, T1/ADSL/...

This is on 3.6.9 or 3.6.10 beta, Launcher 5.5.

Any ideas?

 

Offline FUBAR-BDHR

  • Self-Propelled Trouble Magnet
  • Moderator
  • 212
  • Master Drunk
    • 165th Beer Drinking Hell Raisers
Re: "You selected TCP/IP for multiplayer FS, but the TCP/IP protocol not detecte
First are you using dial up.  If so set it to that.  If you are using DSL try dial up anyway.  There have been a few reports of certain DSL devices looking like dial up.  Also check to be sure you don't have another copy of FS2/TBP/BTRL/ETC process locked up and still running.
No-one ever listens to Zathras. Quite mad, they say. It is good that Zathras does not mind. He's even grown to like it. Oh yes. -Zathras

 

Offline TL

  • 22
Re: "You selected TCP/IP for multiplayer FS, but the TCP/IP protocol not detected.."
The TCP/IP error isn't indicative of any of that, but regardless:

No other FS2 processes were running. In fact, this happened the first time I fired up FS2.

I am using an always-on connection. No combination of settings gets rid of this error - selecting dialup or any of the other possible speeds still causes this error.

Manually setting an IP in the Launcher configuration throws this error.

This is probably being caused by something not obvious. :/
« Last Edit: March 28, 2008, 11:13:29 pm by TL »

 

Offline FUBAR-BDHR

  • Self-Propelled Trouble Magnet
  • Moderator
  • 212
  • Master Drunk
    • 165th Beer Drinking Hell Raisers
Re: "You selected TCP/IP for multiplayer FS, but the TCP/IP protocol not detecte
You shouldn't need to put an IP address in.  Do you have anything else that is using port 7808?  Are you running retail or FS2_Open?  What OS?
No-one ever listens to Zathras. Quite mad, they say. It is good that Zathras does not mind. He's even grown to like it. Oh yes. -Zathras