Author Topic: 3.6.10 Performance issues - resolved  (Read 1690 times)

0 Members and 1 Guest are viewing this topic.

3.6.10 Performance issues - resolved
A number of people were reporting problems with 3.6.10 "stuttering" when turning. http://www.hard-light.net/forums/index.php?topic=64555.0 I have the same problem and couldn't understand it; this machine isn't new but surely enough (Athlon 7850, 4 GB RAM, Geforce 260 GTX, Windows 7 x64).  Reported framerate remains high but visualy it looks like about 15 fps. Barely playable.
I stumbled upon a fix.
I went into the Nvidia control panel and set AA and AF to 8X each for 3.6.30(r). This sounds like a lot but I figured the hardware should be up to it. The difference was like night and day. When I run a build which does not have these features set, I'm stuttering and jerking as before; enable the features and the world universe is a whole better place.
I thought this was worth sharing.



 

 

Offline pecenipicek

  • Roast Chicken
  • 211
  • Powered by copious amounts of coffee and nicotine
    • Minecraft
    • Skype
    • Steam
    • Twitter
    • PeceniPicek's own deviantart page
Re: 3.6.10 Performance issues - resolved
unfortunately, no that is not a proper fix. if you are running the newer postprocessing stuff, you can write off AA and AF to hell, also, as a proud owner of a 260GTX i can tell you that you can crank it up to 16x both and it wont even bother it.


what you need to do properly is run debug builds and give us your logs. i had a similar "stutter" bug appear when testing something for my mod and the framerates dropping to 5 fps. it was related to a little thing in the ai table.


i am not saying it will be the case for you, but it is very possible that you have something somewhere that shouldnt be there. :)


so please, run debug builds, try out some of the nightlyies, and gives LOGS!
Skype: vrganjko
Ho, ho, ho, to the bottle I go
to heal my heart and drown my woe!
Rain may fall and wind may blow,
and many miles be still to go,
but under a tall tree I will lie!

The Apocalypse Project needs YOU! - recruiting info thread.

 
Re: 3.6.10 Performance issues - resolved
Well, I feel a bit silly posting this when I don't *seem* to have a problem, but if it helps:

I ran the nightly debug build from January 1,  AA and AF as described (16X per your comment), command line: C:\Games\Freespace2\fs2_open_3_6_11d-20100101_r5758.exe -mod WhatIf,StormFrontStock,fsport,fsportmediavps,mediavps -spec -glow -env -mipmap -nomotiondebris -missile_lighting -normal -3dshockwave -cache_bitmaps -orbradar -ship_choice_3d -weapon_choice_3d -3dwarp -warp_flash -snd_preload

There were some problems with the mod, but I could click through. I played most of the mission...then quit.

The fs2_open.log does indicate a problem but I have no idea what it means: Requested main shader not found: 0xe. I snipped about 300 pages of that...

[attachment deleted by admin]

 

Offline Jeff Vader

  • The Back of the Hero!
  • Moderator
  • 212
  • Bwahaha
    • Twitter
Re: 3.6.10 Performance issues - resolved
Code: [Select]
Initializing OpenGL graphics device at 1024x768 with 16-bit color...Protip: 32-bit colours. I don't think 16-bit colours cause performance issues, but occasionally they do cause other issues.
23:40 < achillion > EveningTea: ass
23:40 < achillion > wait no
23:40 < achillion > evilbagel: ass
23:40 < EveningTea > ?
23:40 < achillion > 2-letter tab complete failure

14:08 < achillion > there's too much talk of butts and dongs in here
14:08 < achillion > the level of discourse has really plummeted
14:08 < achillion > Let's talk about politics instead
14:08 <@The_E > butts and dongs are part of #hard-light's brand now
14:08 <@The_E > well
14:08 <@The_E > EvilBagel's brand, at least

01:06 < T-Rog > welp
01:07 < T-Rog > I've got to take some very strong antibiotics
01:07 < achillion > penis infection?
01:08 < T-Rog > Chlamydia
01:08 < achillion > O.o
01:09 < achillion > well
01:09 < achillion > I guess that happens
01:09 < T-Rog > at least it's curable
01:09 < achillion > yeah
01:10 < T-Rog > I take it you weren't actually expecting it to be a penis infection
01:10 < achillion > I was not

14:04 < achillion > Sometimes the way to simplify is to just have a habit and not think about it too much
14:05 < achillion > until stuff explodes
14:05 < achillion > then you start thinking about it

22:16 < T-Rog > I don't know how my gf would feel about Jewish conspiracy porn

15:41 <-INFO > EveningTea [[email protected]] has joined #hard-light
15:47 < EvilBagel> butt
15:51 < Achillion> yes
15:53 <-INFO > EveningTea [[email protected]] has quit [Quit: http://www.mibbit.com ajax IRC Client]

18:53 < Achillion> Dicks are fun

21:41 < MatthTheGeek> you can't spell assassin without two asses

20:05 < sigtau> i'm mining titcoins from now on

00:31 < oldlaptop> Drunken antisocial educated freezing hicks with good Internet == Finland stereotype

11:46 <-INFO > Kobrar [[email protected]] has joined #hard-light
11:50 < achtung> Surely you've heard of DVDA
11:50 < achtung> Double Vaginal Double ANal
11:51 < Kobrar> ...
11:51 <-INFO > Kobrar [[email protected]] has left #hard-light []

 

Offline pecenipicek

  • Roast Chicken
  • 211
  • Powered by copious amounts of coffee and nicotine
    • Minecraft
    • Skype
    • Steam
    • Twitter
    • PeceniPicek's own deviantart page
Re: 3.6.10 Performance issues - resolved
Among other things, reduce the number of your VP's loaded at the same time. I really dont believe that you need to have  absolutely all of them loaded.
Skype: vrganjko
Ho, ho, ho, to the bottle I go
to heal my heart and drown my woe!
Rain may fall and wind may blow,
and many miles be still to go,
but under a tall tree I will lie!

The Apocalypse Project needs YOU! - recruiting info thread.

 

Offline The E

  • He's Ebeneezer Goode
  • Global Moderator
  • 213
  • Nothing personal, just tech support.
    • Steam
    • Twitter
Re: 3.6.10 Performance issues - resolved
Doesn't Stormfront rely on the FSPort?
Let there be light
Let there be moon
Let there be stars and let there be you
Let there be monsters and let there be pain
Let us begin to feel again
--Devin Townsend, Genesis

 

Offline pecenipicek

  • Roast Chicken
  • 211
  • Powered by copious amounts of coffee and nicotine
    • Minecraft
    • Skype
    • Steam
    • Twitter
    • PeceniPicek's own deviantart page
Re: 3.6.10 Performance issues - resolved
Doesn't Stormfront rely on the FSPort?
that was more for testing out the reasons of his stuttering :p

but both whatif and stormfront at the same time?
Skype: vrganjko
Ho, ho, ho, to the bottle I go
to heal my heart and drown my woe!
Rain may fall and wind may blow,
and many miles be still to go,
but under a tall tree I will lie!

The Apocalypse Project needs YOU! - recruiting info thread.

 

Offline The E

  • He's Ebeneezer Goode
  • Global Moderator
  • 213
  • Nothing personal, just tech support.
    • Steam
    • Twitter
Re: 3.6.10 Performance issues - resolved
I don't know about that, but since others have reported seeing this problem using only the mediavps, I'd say that it is not a matter of how many VPs are being loaded.

It's just that giving people "advice" like that without knowing how knowledgable they are in terms of FSO modding is something I don't like to do. Leads only to chaos and breakage.
Let there be light
Let there be moon
Let there be stars and let there be you
Let there be monsters and let there be pain
Let us begin to feel again
--Devin Townsend, Genesis

 

Offline Duke.ek

  • 20
Re: 3.6.10 Performance issues - resolved
I tried to run fs2_open_3_6_10 with mediavps and without. There is always a stuttering while turning.

I switched back to fs2_open_3_6_9. No Stuttering

Then I disabled vertical sync for fs2_open_3_6_10 and the stuttering is gone. 

 
Re: 3.6.10 Performance issues - resolved, sort of but not really.
Jeff Vader:  I don't know where that 16 bit reference is coming from. Both the launcher and the desktop are set to 32 bit. Note that it proceeds to show "requested" as 16 bit but "actual" as 32 bit.
I don't know why it shows 1024X768 either, since I'm running at 1680X1050.

pecenipicek: those vp's are called by the mod.ini for the new (re-)release of What If. That's not StormFront the mod; it's StormFrontStock, which is what SF-Junky calls his models/maps/core/interface vps.

I found the post-processing checkbox - where did that come from? I'm sure it wasn't there yesterday. I will experiment with that. I don't know much about this - are the features that checkbox enables in 3.6.10 or just in more recent builds?

The E: Not all that knowledgeable! But I can follow clear instructions. :)

Duke.ek: Disabling v-sync seems to work for some but creates other issues.

Anyway, it does seem that what I thought was a fix isn't really, and a number of people are still struggling with it. Sorry to raise hopes falsely. Subject revised.


 

Offline The E

  • He's Ebeneezer Goode
  • Global Moderator
  • 213
  • Nothing personal, just tech support.
    • Steam
    • Twitter
Re: 3.6.10 Performance issues - resolved
Yes, the contents of the feature selection tabs are determined by the build selected, that is, if you select a 3.6.11 build, it'll display all the options .11 has. Post-processing is one of the big new features of .11.
Let there be light
Let there be moon
Let there be stars and let there be you
Let there be monsters and let there be pain
Let us begin to feel again
--Devin Townsend, Genesis

 
Re: 3.6.10 Performance issues - resolved
Thanks, The E.  I've tried it, looking very good!