Author Topic: Tutoral Help, cant activate nav points  (Read 1517 times)

0 Members and 1 Guest are viewing this topic.

Tutoral Help, cant activate nav points
Hi,

Feel a little crazy here, but in the tutorial it says to hit alt-n to activate nav points. This does nothing for me.


Under the keyboard settings i see cycle nav points is mapped to alt-n and toggle autopilot is mapped to alt-a.   I dont see an enable nav points setting.

any advice would be appreciated.

thanks,

Alex

 

Offline niffiwan

  • 211
  • Eluder Class
Re: Tutoral Help, cant activate nav points
I presume this is in the 1st playable mission.  What sort of keyboard (or keyboard layout/language) do you have?  Unfortunately the FSO engine currently doesn't handle non US keyboards that well, but we should be able to help you find a workaround.
Creating a fs2_open.log | Red Alert Bug = Hex Edit | MediaVPs 2014: Bigger HUD gauges | 32bit libs for 64bit Ubuntu
----
Debian Packages (testing/unstable): Freespace2 | wxLauncher
----
m|m: I think I'm suffering from Stockholm syndrome. Bmpman is starting to make sense and it's actually written reasonably well...

 
Re: Tutoral Help, cant activate nav points
wow amazin response time.

I have a USB logitech keyboard purchased here in the US. It is type k120.

I was able to resolve the issue by remapping what was set to alt-n to alt-z.

I was able to regret not paying attention to the fact one can hit f2 to change controls, and not need to do the tutorial 4 times to test the issue :-)

just finishing tutorial - really excited about trying multiplayer, seems like a great job.


 

Offline niffiwan

  • 211
  • Eluder Class
Re: Tutoral Help, cant activate nav points
glad that remapping the keys fixed the issue for you, I hope you enjoy the rest of the game :)
Creating a fs2_open.log | Red Alert Bug = Hex Edit | MediaVPs 2014: Bigger HUD gauges | 32bit libs for 64bit Ubuntu
----
Debian Packages (testing/unstable): Freespace2 | wxLauncher
----
m|m: I think I'm suffering from Stockholm syndrome. Bmpman is starting to make sense and it's actually written reasonably well...

 

Offline Trucutu

  • 21
Re: Tutoral Help, cant activate nav points
Interesting. I have a similar problem.
I play on Linux (Ubuntu 14.04) and use window mode with nograb flag (for mouse/keyboard) so that I can switch desktop and do something else if needed.
But in these modes none of the "alt-key" combos seem to work. I was stuck in the first mission unable to toggle "alt-H" command. I had to revert to playing in fullscreen.
I will give this a try and see if it works.

 

Offline Trucutu

  • 21
Re: Tutoral Help, cant activate nav points
I've tested this out. won't work for me.

Under "Advanced Settings > DevTool" I've selected:

  • Run in window
  • Don't grab mouse/keyboard in a window


The problem is that this disables the Alt key. Does anyone know how to get around this?

I'm using Ubuntu 14.04, Unity.
I'm trying to keep my ability to switch desktops on the fly, which is a handy feature of Linux. Normally done by pressing Ctrl+Alt+<arrow>

 

Offline niffiwan

  • 211
  • Eluder Class
Re: Tutoral Help, cant activate nav points
That's odd, when I do the same thing with Mint 17 (Cinnamon) I can still switch workspaces with ctrl-alt-arrow.  Maybe it's a Unity thing? Do you have any other windows managers installed that you could test with?
Creating a fs2_open.log | Red Alert Bug = Hex Edit | MediaVPs 2014: Bigger HUD gauges | 32bit libs for 64bit Ubuntu
----
Debian Packages (testing/unstable): Freespace2 | wxLauncher
----
m|m: I think I'm suffering from Stockholm syndrome. Bmpman is starting to make sense and it's actually written reasonably well...

 

Offline ngld

  • Administrator
  • 29
  • Knossos dev
Re: Tutoral Help, cant activate nav points
Ctrl+Alt+<arrow> doesn't work in fullscreen mode and never will until FSO starts using SDL 2.x.
The fact that it doesn't work with "-window -nograb" in newer Ubuntu versions is a Unity issue because it binds the Alt key to some function (HUD?).

This might help: http://askubuntu.com/questions/122209/how-do-i-modify-or-disable-the-huds-use-of-the-alt-key