Author Topic: Stuck in a small window  (Read 1279 times)

0 Members and 1 Guest are viewing this topic.

Offline Rhys

  • 26
Stuck in a small window
Weird issue that only popped up tonight. Whenever I load any FSO build, it doesn't run in 1920x1080, instead it starts in a small window on my desktop.

I've tried tinkering with the settings, running it in regular fullscreen, and regular windowed mode. No dice.

Wondering what causes this issue. Anyone else have this problem?

[attachment kidnapped by pirates]


Offline LHN91

  • 27
Re: Stuck in a small window
Looks like it's initializing at 1024x768 at 16bit colour?

What OS/Launcher are you using?


Offline Rhys

  • 26
Re: Stuck in a small window
wxLauncher. Funny enough, this only started being a problem after I updated Windows 8.1.


Offline AdmiralRalwood

  • 211
  • The Cthulhu programmer himself!
    • Skype
    • Steam
    • Twitter
Re: Stuck in a small window
Try running wxLauncher as an administrator.
Ph'nglui mglw'nafh Codethulhu GitHub wgah'nagl fhtagn.

schrödinbug (noun) - a bug that manifests itself in running software after a programmer notices that the code should never have worked in the first place.

When you gaze long into BMPMAN, BMPMAN also gazes into you.

"I am one of the best FREDders on Earth" -General Battuta

<Aesaar> literary criticism is vladimir putin

<MageKing17> "There's probably a reason the code is the way it is" is a very dangerous line of thought. :P
<MageKing17> Because the "reason" often turns out to be "nobody noticed it was wrong".
(the very next day)
<MageKing17> this ****ing code did it to me again
<MageKing17> "That doesn't really make sense to me, but I'll assume it was being done for a reason."
<MageKing17> **** ME

<MageKing17> God damn, I do not understand how this is breaking.
<MageKing17> Everything points to "this should work fine", and yet it's clearly not working.
<MjnMixael> 2 hours later... "God damn, how did this ever work at all?!"
<MageKing17> so
<MageKing17> more than two hours
<MageKing17> but once again we have reached the inevitable conclusion
<MageKing17> How did this code ever work in the first place!?

<@The_E> Welcome to OpenGL, where standards compliance is optional, and error reporting inconsistent

<MageKing17> It was all working perfectly until I actually tried it on an actual mission.

<IronWorks> I am useful for FSO stuff again. This is a red-letter day!
* z64555 erases "Thursday" and rewrites it in red ink

<MageKing17> TIL the entire homing code is held up by shoestrings and duct tape, basically.


Offline Rhys

  • 26
Re: Stuck in a small window
Well I'll be. That fixed it. Thanks!