Author Topic: Resolution  (Read 873 times)

0 Members and 1 Guest are viewing this topic.

Offline leoben

  • 26
Hey team - it's been a while! Also it's been a while since I turned on BP and FSO in general. I'm not sure if this has something to do with the updates msft rolled out in Win10, but whatever resolution I set with wxLauncher, it launches in a 4:3 resolution, if I had to guess it's 10x7. I have a 21:9 monitor, can do 3440x1440. I tried pretty much all resolution settings in wxlauncher, but it always launches in the same 10x7 crap. I tried borderless windowed and windowed modes, same thing. I'm sure I'm missing something...tried 3.7.3 and 3.7.4...thoughts? This may not have anythign to do with BP btw...

 

Offline leoben

  • 26
using custom flags in command line works btw...so i guess consider this a non-issue.

 

Offline AdmiralRalwood

  • 211
  • The Cthulhu programmer himself!
    • Skype
    • Steam
    • Twitter
Try running wxLauncher as administrator. If that doesn't work, try enabling -fix_registry.

If that still doesn't work, throw your hands up in the air and don't worry too much about it, because 3.8 will use an .ini file instead of the registry.
Ph'nglui mglw'nafh Codethulhu GitHub wgah'nagl fhtagn.

schrödinbug (noun) - a bug that manifests itself in running software after a programmer notices that the code should never have worked in the first place.

When you gaze long into BMPMAN, BMPMAN also gazes into you.

"I am one of the best FREDders on Earth" -General Battuta

<Aesaar> literary criticism is vladimir putin

<MageKing17> "There's probably a reason the code is the way it is" is a very dangerous line of thought. :P
<MageKing17> Because the "reason" often turns out to be "nobody noticed it was wrong".
(the very next day)
<MageKing17> this ****ing code did it to me again
<MageKing17> "That doesn't really make sense to me, but I'll assume it was being done for a reason."
<MageKing17> **** ME
<MageKing17> THE REASON IS PEOPLE ARE STUPID
<MageKing17> ESPECIALLY ME

<MageKing17> God damn, I do not understand how this is breaking.
<MageKing17> Everything points to "this should work fine", and yet it's clearly not working.
<MjnMixael> 2 hours later... "God damn, how did this ever work at all?!"
(...)
<MageKing17> so
<MageKing17> more than two hours
<MageKing17> but once again we have reached the inevitable conclusion
<MageKing17> How did this code ever work in the first place!?

<@The_E> Welcome to OpenGL, where standards compliance is optional, and error reporting inconsistent

<MageKing17> It was all working perfectly until I actually tried it on an actual mission.

<IronWorks> I am useful for FSO stuff again. This is a red-letter day!
* z64555 erases "Thursday" and rewrites it in red ink

<MageKing17> TIL the entire homing code is held up by shoestrings and duct tape, basically.

 
Huh. I thought it was already fixed in the latest wxLaucher beta? :nervous:

Anyway, could you just try to write -res 3440x1440 in your command line? It should do the trick... However, the HUD isn't really made for such huge resolutions and its elements *may* be too small to play the game comfortably, so you could also try out some smaller resolutions if it bothers you.
Mito [PL] - Today at 8:52 PM
I was supposed to make a short presentation about basics of optical fibers and here I am, listening to Eurobeat while reading about quantum cryptography.