Author Topic: Own "Mod" start with SSE2 fine, but debug brings report  (Read 561 times)

0 Members and 1 Guest are viewing this topic.

Own "Mod" start with SSE2 fine, but debug brings report
Hello. I'm working on my own campaign, started making missions and also started including ship models from I tried some models and deleted them after I found out I didn't need them. When I start my "mod" everything seems fine, no message that ship models are missing or so...

But when I start the debug I get this and have no idea how to fix it. I don't know if this might become a problem for other users if they would like to try my campaign later, so that's why I'm asking :)

Type of weapon RepairBeam entry does not agree with original entry type.
KERNELBASE.dll! WaitForSingleObjectEx + 182 bytes
KERNELBASE.dll! WaitForSingleObject + 18 bytes
fs2_open_3_7_4_SSE2-DEBUG.exe! SCP_DumpStack + 354 bytes
fs2_open_3_7_4_SSE2-DEBUG.exe! Warning + 491 bytes
fs2_open_3_7_4_SSE2-DEBUG.exe! parse_weapon + 918 bytes
fs2_open_3_7_4_SSE2-DEBUG.exe! parse_weaponstbl + 410 bytes
fs2_open_3_7_4_SSE2-DEBUG.exe! parse_modular_table + 331 bytes
fs2_open_3_7_4_SSE2-DEBUG.exe! weapon_init + 101 bytes
fs2_open_3_7_4_SSE2-DEBUG.exe! game_init + 1791 bytes
fs2_open_3_7_4_SSE2-DEBUG.exe! game_main + 524 bytes
fs2_open_3_7_4_SSE2-DEBUG.exe! WinMain + 328 bytes
fs2_open_3_7_4_SSE2-DEBUG.exe! invoke_main + 30 bytes
fs2_open_3_7_4_SSE2-DEBUG.exe! __scrt_common_main_seh + 346 bytes
fs2_open_3_7_4_SSE2-DEBUG.exe! __scrt_common_main + 13 bytes
fs2_open_3_7_4_SSE2-DEBUG.exe! WinMainCRTStartup + 8 bytes
KERNEL32.DLL! BaseThreadInitThunk + 36 bytes
ntdll.dll! RtlSubscribeWnfStateChangeNotification + 1081 bytes
ntdll.dll! RtlSubscribeWnfStateChangeNotification + 1028 bytes

I tried the GTDr Phidias and the GTDr 3301 models and I remember one of them had a "repairbeam". But I deleted them and now I'm curious why this still appears... Any Ideas what's happening here? Or can I maybe just ignore it?



Offline niffiwan

  • 211
  • Eluder Class
Re: Own "Mod" start with SSE2 fine, but debug brings report
I suspect that you haven't deleted everything that has the repairbeam defined. I guess you just need to check all the table files in your mod, and it's parents (does Windows have a grep equivalent?)
Creating a fs2_open.log | Red Alert Bug = Hex Edit | MediaVPs 2014: Bigger HUD gauges | 32bit libs for 64bit Ubuntu
Debian Packages (testing/unstable): Freespace2 | wxLauncher
m|m: I think I'm suffering from Stockholm syndrome. Bmpman is starting to make sense and it's actually written reasonably well...

Re: Own "Mod" start with SSE2 fine, but debug brings report
Well though I thought I deleted everything... I obviously didn't... I have put everything together in the correct folders by hand, again, and now everything's alright. No error message at the beginning  :)