Author Topic: PUBLIC BETA: Knossos 0.13.3 (combined launcher/installer)  (Read 81677 times)

0 Members and 1 Guest are viewing this topic.

Offline PIe

  • 28
  • GTVA POLICE
    • freespace3.com
Re: PUBLIC BETA: Knossos 0.13.3 (combined launcher/installer)
This may not be the problem but you have to have any dependencies installed.
You could try adding the MVPs as a dependency only to the recommended/optional package but I don't know if this would do what you want (ngld would know).
[9:50 PM] Sottises: wait did you do vassago's verge?
[9:50 PM] Sottises: .. dirge?
[9:50 PM] Axem: yes
[9:50 PM] Sottises: ohh
[9:50 PM] Sottises: well I have that and JAD too
[9:50 PM] Axem: :)
[9:50 PM] Sottises: what a contrast of themes lmao
[9:50 PM] Axem: isnt it
[9:51 PM] Axem: super grimdark thriller about unknowable alien intelligence and over the top colorful action about friendship
[9:51 PM] PIe: jad is grimdark???
[9:51 PM] Axem: :skull:

[6:23 PM] PIe: why do I have the feeling that I shouldn't be able to give orders to 22nd armored hq
[6:24 PM] Axem: 22nd armored hq, i order you to get me a cup of coffee
[6:24 PM] PIe: and donuts
[6:24 PM] PIe: BECAUSE THIS IS THE GTVA POLICE
[6:25 PM] Axem: :O
[6:25 PM] Axem: am i under arrest
[6:26 PM] [`_`]/: no, just please step out of the myrmidon
[6:26 PM] [`_`]/: you have so much to fred for

 

Offline CP5670

  • Dr. Evil
  • Global Moderator
  • 212
  • 142857
Re: PUBLIC BETA: Knossos 0.13.3 (combined launcher/installer)
Maybe I'll try update it to make it compatible with the current media VPs. It seems the only change needed is to update a few models with the media VP versions.

 

Offline ngld

  • Administrator
  • 29
  • Knossos dev
Re: PUBLIC BETA: Knossos 0.13.3 (combined launcher/installer)
You can make an optional (or recommended) package which depends on the MediaVPs. Knossos would then only load them if that package was enabled / installed. There's no mechanism to only use certain dependencies, if they're already installed.
In case you haven't seen it, yet, here's a guide that should explain the whole mod creation process. Not sure how much help that's going to be since you seem to have already come quite far.

@jr2: Just wanted to acknowledge that I've seen your post. I haven't had time to test it yet, though. I'm not 100% sure whether it's going to work or not.

 
Re: PUBLIC BETA: Knossos 0.13.3 (combined launcher/installer)

 

Offline ngld

  • Administrator
  • 29
  • Knossos dev
Re: PUBLIC BETA: Knossos 0.13.3 (combined launcher/installer)
That's a dependency conflict. PI wants FSO 3.8.0-3 or later but the MediaVPs version PI depends on requires exactly 3.8.0-2.

@CP5670: Which MediaVPs version did you select and were you able to launch PI through Knossos after your changes?
@woutersmits: There have been a few changes to the MediaVPs' metadata. Can you please go to the troubleshooting tab and click "discard local changes to mod metadata"? That should make sure you have the latest metadata. If launching PI still fails afterwards, we need to fix PI's dependencies.


 

Offline PIe

  • 28
  • GTVA POLICE
    • freespace3.com
Re: PUBLIC BETA: Knossos 0.13.3 (combined launcher/installer)
The 3.6.12 MVPs should require >=3.8.0.2.  PI works fine for me.
[9:50 PM] Sottises: wait did you do vassago's verge?
[9:50 PM] Sottises: .. dirge?
[9:50 PM] Axem: yes
[9:50 PM] Sottises: ohh
[9:50 PM] Sottises: well I have that and JAD too
[9:50 PM] Axem: :)
[9:50 PM] Sottises: what a contrast of themes lmao
[9:50 PM] Axem: isnt it
[9:51 PM] Axem: super grimdark thriller about unknowable alien intelligence and over the top colorful action about friendship
[9:51 PM] PIe: jad is grimdark???
[9:51 PM] Axem: :skull:

[6:23 PM] PIe: why do I have the feeling that I shouldn't be able to give orders to 22nd armored hq
[6:24 PM] Axem: 22nd armored hq, i order you to get me a cup of coffee
[6:24 PM] PIe: and donuts
[6:24 PM] PIe: BECAUSE THIS IS THE GTVA POLICE
[6:25 PM] Axem: :O
[6:25 PM] Axem: am i under arrest
[6:26 PM] [`_`]/: no, just please step out of the myrmidon
[6:26 PM] [`_`]/: you have so much to fred for

 

Offline PIe

  • 28
  • GTVA POLICE
    • freespace3.com
Re: PUBLIC BETA: Knossos 0.13.3 (combined launcher/installer)
@CP5670, PI is currently broken because all the mod files are currently directly inside the package folder but they need to be in a data folder inside the package.
[9:50 PM] Sottises: wait did you do vassago's verge?
[9:50 PM] Sottises: .. dirge?
[9:50 PM] Axem: yes
[9:50 PM] Sottises: ohh
[9:50 PM] Sottises: well I have that and JAD too
[9:50 PM] Axem: :)
[9:50 PM] Sottises: what a contrast of themes lmao
[9:50 PM] Axem: isnt it
[9:51 PM] Axem: super grimdark thriller about unknowable alien intelligence and over the top colorful action about friendship
[9:51 PM] PIe: jad is grimdark???
[9:51 PM] Axem: :skull:

[6:23 PM] PIe: why do I have the feeling that I shouldn't be able to give orders to 22nd armored hq
[6:24 PM] Axem: 22nd armored hq, i order you to get me a cup of coffee
[6:24 PM] PIe: and donuts
[6:24 PM] PIe: BECAUSE THIS IS THE GTVA POLICE
[6:25 PM] Axem: :O
[6:25 PM] Axem: am i under arrest
[6:26 PM] [`_`]/: no, just please step out of the myrmidon
[6:26 PM] [`_`]/: you have so much to fred for

 

Offline CP5670

  • Dr. Evil
  • Global Moderator
  • 212
  • 142857
Re: PUBLIC BETA: Knossos 0.13.3 (combined launcher/installer)
I'll fix that shortly. I'm still working on a few things with this. I was going to make the campaign itself compatible with the 3.8 media VPs, which involves adding some new models and modifying a few missions to account for them.

  

Offline CP5670

  • Dr. Evil
  • Global Moderator
  • 212
  • 142857
Re: PUBLIC BETA: Knossos 0.13.3 (combined launcher/installer)
I put up a new sub-version of it. There are still a few issues I wanted to test before calling it an "official" version, but it should work now with the 3.8 VPs.