Author Topic: PUBLIC BETA: Knossos 0.14.1 (combined launcher/installer)  (Read 156876 times)

0 Members and 2 Guests are viewing this topic.

Re: PUBLIC BETA: Knossos 0.13.3 (combined launcher/installer)
Maybe someone capable can make a snap app for Knossos if the licenses are not violated?!

 

Offline anagram

  • 22
Re: PUBLIC BETA: Knossos 0.13.3 (combined launcher/installer)
Alternative compiling instructions

Tested on a clean Ubuntu 20.04 install
OBS: This doesn't use pipenv because I don't know how to use it.

Code: [Select]
sudo apt install build-essential git p7zip-full libopenal-dev ninja-build pipenv pyqt5-dev pyqt5-dev-tools qttools5-dev-tools qt5-default
sudo apt install nodejs npm yarnpkg
sudo apt install python3-semantic-version python3-pyqt5.qtwebengine python3-requests-toolbelt python3-ply
sudo apt install libsdl2-dev

git clone https://github.com/ngld/knossos.git
cd knossos

pip3 install token-bucket
yarnpkg install
python3 configure.py

ninja run


If everything works, you can install knossos using:

Code: [Select]
sudo python3 setup.py install
sudo install -Dm644 ./releng/ubuntu/debian/knossos.desktop /usr/share/applications/knossos.desktop
sudo install -Dm644 ./knossos/data/hlp.png /usr/share/knossos/knossos/data/hlp.png

It gives an error on startup (I don't know why) but you can safely ignore it.

I made this because the instructions of the other users didn't work on my system for some reason.


Edit: fixed typos
« Last Edit: May 20, 2020, 12:52:11 pm by anagram »

 
Re: PUBLIC BETA: Knossos 0.13.3 (combined launcher/installer)
Thanks for the instruction.

18.04 users: the packages "pipenv" and "yarnpkg" are not avaiable in 18.04. You might need this one, too, before compiling
Code: [Select]
sudo apt install curl
curl https://raw.githubusercontent.com/pypa/pipenv/master/get-pipenv.py | sudo python3
curl -sS https://dl.yarnpkg.com/debian/pubkey.gpg | sudo apt-key add -
echo "deb https://dl.yarnpkg.com/debian/ stable main" | sudo tee /etc/apt/sources.list.d/yarn.list
sudo apt update && sudo apt install yarn
and using

Code: [Select]
yarn install
instead of

Code: [Select]
yarnpkg install

 

Offline m!m

  • 211
Re: PUBLIC BETA: Knossos 0.13.3 (combined launcher/installer)
I just released version 0.14.1: https://github.com/ngld/knossos/releases/tag/v0.14.1

Thanks to the tireless work of chief1983 we now have Mac builds again! There are no other functional changes in this release.

 

Offline chief1983

  • Still lacks a custom title
  • Moderator
  • 212
  • ⬇️⬆️⬅️⬅️🅰➡️⬇️
    • Minecraft
    • Skype
    • Steam
    • Twitter
    • Fate of the Galaxy
Re: PUBLIC BETA: Knossos 0.14.1 (combined launcher/installer)
I updated the title of the OP but not sure if any more data in that post should be updated at this point.
Fate of the Galaxy - Now Hiring!  Apply within | Diaspora | SCP Home | Collada Importer for PCS2
Karajorma's 'How to report bugs' | Mantis
#freespace | #scp-swc | #diaspora | #SCP | #hard-light on EsperNet

"You may not sell or otherwise commercially exploit the source or things you created based on the source." -- Excerpt from FSO license, for reference

Nuclear1:  Jesus Christ zack you're a little too hamyurger for HLP right now...
iamzack:  i dont have hamynerge i just want ptatoc hips D:
redsniper:  Platonic hips?!
iamzack:  lays

 
Re: PUBLIC BETA: Knossos 0.14.1 (combined launcher/installer)
I just released version 0.14.1: https://github.com/ngld/knossos/releases/tag/v0.14.1

Thanks to the tireless work of chief1983 we now have Mac builds again! There are no other functional changes in this release.

@anagram: did you try it in 20.04? As I am no python/programming expert: How to revert your installation instructions, especially the "sudo install" lines?

  
Re: PUBLIC BETA: Knossos 0.14.1 (combined launcher/installer)
According to the Readme this should work

Code: [Select]
pipenv run python3 configure.py
Warning: Python 3.6 was not found on your system…
python3 version here is 3.8.2 in 20.04. Ideas?

 
Re: PUBLIC BETA: Knossos 0.14.1 (combined launcher/installer)
Sorry for confusing everyone here. That error comes from the README instructions of 0.14.1 referring to Ubuntu 18.04. Using anagrams instructions works flawlessly. It seems much more stable than using the 0.13.3 from the PPA

@m!m: Would you mind updating the README accordingly for 20.04 users?

 

Offline anagram

  • 22
Re: PUBLIC BETA: Knossos 0.14.1 (combined launcher/installer)
I just released version 0.14.1: https://github.com/ngld/knossos/releases/tag/v0.14.1

Thanks to the tireless work of chief1983 we now have Mac builds again! There are no other functional changes in this release.

@anagram: did you try it in 20.04? As I am no python/programming expert: How to revert your installation instructions, especially the "sudo install" lines?

To update you can run:
Code: [Select]
git pull
sudo python3 setup.py install

you don't need to uninstall before updating, but if you want to uninstall run:
Code: [Select]
sudo pip uninstall knossos

 I am not a python programmer myself but I am learning. If the community wants I can try to make a ppa/deb to make it easier to install.





 
Re: PUBLIC BETA: Knossos 0.14.1 (combined launcher/installer)
I am not a python programmer myself but I am learning. If the community wants I can try to make a ppa/deb to make it easier to install.
SHUT UP AND TAKE MY MONEY!  :yes:
"Any idiot can face a crisis; it is this day to day living that wears you out." – Anton Chekhov