Author Topic: Trying to reinstall FSO - not working :(  (Read 459 times)

0 Members and 1 Guest are viewing this topic.

Offline Stealth

  • Braiiins...
  • 211
Trying to reinstall FSO - not working :(
Hi,
So I installed FS2 from the CDs a few weeks ago, installed FSO, but ran into some issues when I tried installing campaigns (through the FSO installer..)
Uninstalled everything, deleted the C:\games\freespace2 folder, and reinstalled, downloaded FSO installer and tried again

Having problems - it shows the list of modules with checkboxes next to them all greyed out (the ones I tried downloading or previously downloaded).  even when I selected the bottom checkbox to download anyway, I still end up with errors.

Log is attached.  would welcome any help :(

[attachment stolen by Russian hackers]

 

Offline Stealth

  • Braiiins...
  • 211
Re: Trying to reinstall FSO - not working :(
I tried installing to a completely different folder (C:\freespace2) but same thing - half of them are greyed out.  items I'd picked in the past. (screenshot attached)

[attachment stolen by Russian hackers]

 
Re: Trying to reinstall FSO - not working :(
Dll errors? Depending on the build you need different .dlls. As far as I remember the 64-bit builds need their respective dlls to work. Also the log looks like you downloaded all the builds for windows and depending on the gen of your cpu, you would only need one.

« Last Edit: December 04, 2017, 07:29:25 pm by de121188 »

 

Offline Stealth

  • Braiiins...
  • 211
Re: Trying to reinstall FSO - not working :(
Yeah but everything worked.  I played through the entire FS2 campaign, the entire FS port campaign.  So it's not like the version of the launcher or DLLs I have is wrong - I KNOW they work.  It's only when I went to try to reinstall (redownload) everything since I had problems when I tried installing some of the third party campaigns that I had problems

 

Offline ngld

  • Administrator
  • 29
  • Knossos dev
Re: Trying to reinstall FSO - not working :(
The FSO Installer saves which mods you installed in C:\Users\<your username>\fsoinstaller.properties .
If you delete that file, all the disabled checkboxes should be enabled again. I think there's also a button in the installer to check for missing mods or something like that which should also fix this problem.

 

Offline Stealth

  • Braiiins...
  • 211
Re: Trying to reinstall FSO - not working :(
Thank you; i'll try that